Midori does not work

Non release banter
Kulle
Shogun
Shogun
Posts: 205
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Midori does not work

Post#1 by Kulle » 24 Feb 2019, 15:56

Using usm I have created the module midori-0.5.11-x86_64-bundle.xzm
But it does not work:

Code: Select all

guest@porteus:~$ midori
midori: symbol lookup error: /usr/lib64/libwebkitgtk-1.0.so.0: undefined symbol: UCNV_FROM__CALLBACK_SUBSTITUTE_56
What does this error mean?

donald
Full of knowledge
Full of knowledge
Posts: 1556
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Re: Midori does not work

Post#2 by donald » 25 Feb 2019, 03:08

Select these packages to create Midori
( tested with port 4.0-x86_64-XFCE )

Code: Select all

aspell-0.60.6.1-x86_64-1.txz
enchant-1.6.0-x86_64-1.txz
gst-plugins-base-1.6.4-x86_64-1.txz
gstreamer-1.6.4-x86_64-1.txz
hunspell-1.3.3-x86_64-1.txz
icu4c-56.1-x86_64-2.txz
libvisual-0.4.0-x86_64-3.txz
libwebp-0.5.0-x86_64-1gv.txz
midori-0.5.11-x86_64-1gv.txz
webkitgtk-2.4.11-x86_64-1gv.txz
btw
Please let us know (always) which DE you are using and / or update your profile accordingly.

Kulle
Shogun
Shogun
Posts: 205
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Re: Midori does not work

Post#3 by Kulle » 25 Feb 2019, 16:24

Many Thanks.
But there were usm_errors:
==============================================================================
WARNING! WARNING! WARNING! WARNING! WARNING!
==============================================================================
One or more errors occurred while usm was running:

FATAL ERROR!
resolve_deps 369
Please wait 6 hours for the next database update. Could not find: LIBS.TXT

I give up, the use of usm is obviously not suitable for normal users.

User avatar
Ed_P
Contributor
Contributor
Posts: 5266
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Midori does not work

Post#4 by Ed_P » 25 Feb 2019, 17:10

Sounds like a mirror didn't get updated. Manually tweak them, /etc/usm/, or use sesm.sh, [INFO & SCRIPT] Slackware Mirror Settings for USM to tweak all of them automatically.
Ed

beny
Full of knowledge
Full of knowledge
Posts: 799
Joined: 02 Jan 2011, 11:33
Location: italy

Re: Midori does not work

Post#5 by beny » 25 Feb 2019, 20:02

hi Ed_P, you can take a look at this software slpkg,maybe is useful... https://dslackw.gitlab.io/slpkg/

User avatar
Ed_P
Contributor
Contributor
Posts: 5266
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Re: Midori does not work

Post#6 by Ed_P » 26 Feb 2019, 04:09

Thank beny. Hopefully Kulie will try it and report his results.
Ed

Kulle
Shogun
Shogun
Posts: 205
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Midori does not work

Post#7 by Kulle » 02 Mar 2019, 10:17

Sometimes usm does not work correctly, dependencies remain.
As soon as I have time, I will try https://dslackw.gitlab.io/slpkg/.
Thanks for the info.

Kulle
Shogun
Shogun
Posts: 205
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Midori does not work

Post#8 by Kulle » 02 Mar 2019, 11:56

I downloaded slpkg 3.4.2
and I have created slpkg-3.4.2-x86_64-1_dsw.txz:

Code: Select all

...
/usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'extras_require'
  warnings.warn(msg)
/usr/lib64/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'install_requires'
  warnings.warn(msg)
running install
...
usr/lib64/python2.7/site-packages/slpkg/binary/check.py
usr/lib64/python2.7/site-packages/slpkg/binary/__init__.py

Slackware package /tmp/slpkg-3.4.2-x86_64-1_dsw.txz created.

./slpkg.SlackBuild: line 124: upgradepkg: command not found.
I have created slpkg-3.4.2-x86_64-1_dsw.xzm
But slpkg does not work:

Code: Select all

guest@porteus:~$ slpkg 
Traceback (most recent call last):
  File "/usr/bin/slpkg", line 35, in <module>
    from slpkg.main import main
  File "/usr/lib64/python2.7/site-packages/slpkg/main.py", line 60, in <module>
    from slpkg.sbo.network import SBoNetwork
  File "/usr/lib64/python2.7/site-packages/slpkg/sbo/network.py", line 27, in <module>
    import pydoc
ImportError: No module named pydoc
guest@porteus:~$

beny
Full of knowledge
Full of knowledge
Posts: 799
Joined: 02 Jan 2011, 11:33
Location: italy

Midori does not work

Post#9 by beny » 02 Mar 2019, 12:34

hi, take a look at this tread: missing pydoc module

Kulle
Shogun
Shogun
Posts: 205
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Midori does not work

Post#10 by Kulle » 03 Mar 2019, 08:16

Hi beny,
I take a look at this tread: missing pydoc module

I wanted now to download python 3, but it does not exist.
Error message:
Not Found
The requested URL /pub/slackware/slackware64-current/slackware64/d/python3-3.6.7-x86_64-1.txz was not found on this server.
Apache Server at ftp.slackware.com Port 80

beny
Full of knowledge
Full of knowledge
Posts: 799
Joined: 02 Jan 2011, 11:33
Location: italy

Midori does not work

Post#11 by beny » 03 Mar 2019, 13:20

sorry but it is an old tread :https://mirrors.slackware.com/slackware ... kware64/d/ seem you need the whole python package, so try it,but the mix of 14.2 and current.....make a standalone package no trouble if you have to remove it.

donald
Full of knowledge
Full of knowledge
Posts: 1556
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Midori does not work

Post#12 by donald » 03 Mar 2019, 14:41

@Kulle
(porteus 4)
midori-0.5.11-x86_64-xfce-don
https://filehorst.de/d/ctjwDmgE

as usual:
The File is on a german hosting service so please do as follows to get it.
Wait 15 sec > click "Jetzt zur Download-Seite" (means go to download page) >
click "Klicke hier, um ihn zu starten" (means click to start the download).

Kulle
Shogun
Shogun
Posts: 205
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Midori does not work

Post#13 by Kulle » 04 Mar 2019, 13:08

Thank you Donald,
but midori-0.5.11-x86_64-xfce-don.xzm does not work:

Code: Select all

guest@porteus:~$ midori
The configuration couldn't be loaded: No such file or directory
Midori can't find the page you're looking for
The page located at “www.salixos.org” cannot be found. Check the web address for misspelled words and try again.
TLS/SSL support not available; install glib-networking
Try Again

Midori gets no internet connection.
But other browsers (Chromium, Dillo) is working.
How can that be?

donald
Full of knowledge
Full of knowledge
Posts: 1556
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Midori does not work

Post#14 by donald » 04 Mar 2019, 16:21

Hi Kulle
The configuration couldn't be loaded: No such file or directory
Click the icon which looks like an eye at the top right corner > preferences >
change some settings like the default (home) page etc.
Close midori. Midori has now its conf file.
TLS/SSL support not available; install glib-networking
Yep, these files are not present in stock porteus - activate them:
gsettings-desktop-schemas-3.18.1-x86_64-1.txz
glib-networking-2.46.1-x86_64-1.txz
you can get them via USM

Kulle
Shogun
Shogun
Posts: 205
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Midori does not work

Post#15 by Kulle » 05 Mar 2019, 12:26

Many Thanks.
With the two additional modules, midori is now working for me.
But this example shows how difficult (!) it is sometimes
to create additional software in Porteus.

Post Reply