Page 1 of 1

(SOLVED) Printers: the case of brother hl2170w (bis)

Posted: 04 Aug 2011, 01:51
by francois
The first post being overloaded with excessive information:

I will try to define the situation in this post in cleared terms: there are printing problems for brother printers under Porteus. In my case, the brother hl2170w and dcp-7020:

Beny reported it does not work either for its brother dcp-197c.

Non satisfied to have my HP laserjet 3030 working on Porteus v 1.0 32-bit with Wread's strategy (many thanks to him):

I am working on the case of the printer brother hl2170w. Essentially, I am following the same path as I did under slax: ... ntID=33379

However following Guest instructions from post 2, after downloading the two necessary printer drivers from: ... l#HL-2170W

- LPR: brhl2170wlpr-2.0.2-1.i386.rpm
- cupswrapper:cupswrapperHL2170W-2.0.2-1.i386.rpm

1.0 Under porteus, I could not get them to be converted in proper xzm (lzma2) modules using the right click rpm2xzm command: 'Some error occured while activating the module' message appears. But I finally had to go the slax 612 way to get the xzm modules for these two printer drivers:

1.1 First solution (less elegant, mine):
1.11 under slax 612 downloaded rpm2lzm
1.12 rpm2lzm under slax612
1.13 exported brhl2170wlpr-2.0.2-1.i386.lzm and cupswrapperHL2170W-2.0.2-1.i386.lzm to porteus
1.14 converted with lzm2xzm command the two modules

Second solution (beny's solution):
Under porteus rpm2txz and txz2xzm works

2.0 Although I have these two modules, I am not able to get the above mentioned solution to work,
the same path as I did under slax: ... ntID=33379

3.0 Gutenprint, ghostscrip and ghostscript-fonts solution. I am not able to get the brother printer to work, even when adding gutenprint, ghostscrip and ghostscript-fonts. Which in fact, is usually a very good solution for many brands of printers. This solution works under slax 612 and it works for Blablotin and cttan for respectively their HP Deskjet 930C and Canon MP145:

However adding gutenprint, hplip helped cups recognise my brother hl2170w. This seems not to be enough. When trying the print page I always get the error message:

''The page your are trying to view is the result of posted form data. If you resend the data, any action the form carried out (such as search or online purchase) will be repeated.''

4.0 Restarting cups (hamza's solution), reinstalling cups or cups older version. Beny was able to print with his brother printer by installing a former version of cups downgrade at 1.4.3 of the 32-bit architecture. However, he is working under Porteus 64-bit with compat libraries: ... 8&start=10

4.1 Beny's solution adapted under Porteus 32-bit: ... 8&start=10
hi francois, i have a new for the brother print, well i have make the two driver lpt and cupswrapper for my model, installed i have run a script into a folder for to make a module filter,i have installed all the printer software located in slackware repo and i have change cups version i have downgrade at 1.4.3 version,well not printing yet at final i have installed the compat-32-libraries-1.1.02_13.37 located in slacky 64 bit libraries,and restarted cups i have print in 64 bit with the dcp-197c,i have to fight for the scanner but for now it is ok.and of course all the software installed isn't so light in weight,but virtualbox and windows loads more.
4.11 downloaded thru slackyd cups 1.4.3-i486-3.
4.12 slapt-get, search cups, downgraded to cups 1.4.3-i486-3.
4.13 Starting cups in browser:
4.141 Working with a brother DCP-7020. I have to use the only driver available a DCP-1500. Looks good, the printer was installed with no error message. However, no printout.
4.142 Working with a brother hl2170w. I get the error message:"could not connect with local host"

I will try beny's solution under Porteus 64-bit and then will experiment Porteus 32-bit on brother hl-2170w for my next steps.

Do you have some printer other than hp that works under porteus?

Re: Printers: the case of brother hl2170w (bis)

Posted: 14 Oct 2011, 19:48
by francois
Finally the suggestion of cttan to use gutenprint and ghostscript works for brother hl2170w under 32bit edition:

32bit v 1.0 porteus edition (tested):
-You need ghostscript-9.00-i486-2.txz, ghostscript-fonts-std-8.11-noarch-1.txz,gutenprint-5.2.6-i486-1.txz
-Transform these into xzm modules
-Reboot your linux box (just activating these will not work)
-Get into cups using kde > system > manage printing
-Add new printer (do not use the find printer option)
-Select Brother_HL-2170W_series
-In the list offered select hl_1040 and select add printer (as there is no HL-2170W available, hl_1040 seems to work fine)
-Select default options
-To verify that everything works fine try print test page from the maintenance menu.

Re: Printers: the case of brother hl2170w (bis)

Posted: 14 Oct 2011, 20:06
by fanthom
any chance for creating a "Porteus printer - HOWTO" with all your knowledge in this subject?
shame on me but i have never used any printer under linux :oops:

Re: Printers: the case of brother hl2170w (bis)

Posted: 15 Oct 2011, 23:29
by francois
I was thinking about it. It will be my pleasure. With HPlip and gutenscript-ghostscript solutions (Wread, Cttan, Beny, and anonymous, solutions and suggestions), we might cover a lot of printers.

Posted after 1 hour 17 minutes 43 seconds:
Finally, I achieved printing with the brother printers under porteus 64-bit edition (thanks for the encouragement of beny).

This gutenprint and ghostscript solution works for Cttan for his Canon MP145 and for Blablotin HP Deskjet 930C, see: ... gutenprint
Temporary notes for the 64bit v 1.0 porteus edition and brother hl2170w:
1) I have installed ghostscript-9.00-x86_64-2.xzm, ghostscript-fonts-std-8.11-noarch-1.xzm, gutenprint-5.2.6-x86_64-1.xzm (this solution works). In contrast, without results, I had tried before with the equivalent packages for the 32bit architecture as I had compat.xzm the multilib 32bit compatible library for the 64bit edition, but with no results. There was failing of the print test page.
2) For the rest I go thru the Cups steps to setup the brother printer (see the above procedure for the 32bit
edition of porteus). The setup is completed and the brother hl2170w becomes a usable printer.

a) Adding brhl2170wlpr-2.0.2-1.i386.xzm and cupswrapperHL2170W-2.0.2-1.i386.xzm from the rpm versions will work. However, the printer is not to be found in alphabetical order. You can also resort to an equivalent printer driver. In the particular case of the brother hl2170w,selecting hl-1040 does the job. for the printer from: ... l#HL-2170W
results in internal error 500 of the CUPS server.
b) Under 32bit and 64bit v 1.0 porteus edition, I have tried the gutenprint-postscript solution for the brother printer to my hp laserjet 3030. It works. It would be interesting to see how it does with other printer brands.

Foomatic solution.
The foomatic solution for the hl2170w is described in the following thread of archlinux: ... -ppds.html ... umentation
Edited as of 2011-1017