TERM=xterm-256color

Technical issues/questions of an intermediate or advanced nature.
Post Reply
rych
Samurai
Samurai
Posts: 158
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

TERM=xterm-256color

Post#1 by rych » 01 May 2019, 08:50

I can't find the script setting "TERM=xterm-256color" on my system. And it seems to break wine related programs (complains: 'xterm-256color': unknown terminal type.) Setting it back to TERM=xterm seems to solve it. I say "back to" because on my previous USB with LXDE it is indeed TERM=xterm -- I've just checked.

When I switched to OpenBox this problem hasn't occurred; as I've installed and customized it quite a bit since then, I have TERM=xterm-256color and the problems.

Who is setting it on my system, how/where to change it back?

burdi01
Samurai
Samurai
Posts: 101
Joined: 18 Aug 2013, 12:09
Distribution: Slackware, Xubuntu
Location: The Netherlands

TERM=xterm-256color

Post#2 by burdi01 » 01 May 2019, 09:35

This seems to be a default in Slackware and its derivates since quite some time -- I could not find an explicit setting either.
In /etc/profile I changed the TERM setting therefore to:

Code: Select all

# Fight TERM pecularities:
if [ "$TERM" = "" -o "$TERM" = "unknown" ]; then
 TERM=linux
elif [ "$TERM" = "xterm-256color" ]; then
 TERM=xterm
fi
:D

nanZor
Samurai
Samurai
Posts: 157
Joined: 09 Apr 2019, 03:27
Distribution: Porteus 5.0 RC1 XFCE
Location: Los Angeles

TERM=xterm-256color

Post#3 by nanZor » 28 May 2019, 09:37

It's not just Slackware but further upstream too. I do much the same for HTOP and MC in TinycorePure64, which is independent.

I've just been aliasing the critters that pop up setting the TERM that way....
That's a UNIX book - cool. -Garth

Post Reply