Page 2 of 2

Porteus 4.0 not booting in UEFI mode SOLVED

Posted: 15 Aug 2019, 08:15
by nanZor
Yep, some of the docs are a bit before uefi, so the instructions in the iso itself are the latest. Just copy the contents of the entire mounted iso to the flash drive before running the BOOT/Porteus-installer-for-Windows.exe from the drive you copied the iso to.

As a general reminder for windows users, double-click or mount the porteus iso *first*, and then attach your desired target usb stick last.

That way, the target usb drive should show up as drive "E", which essential for the porteus windows installer utility to work. It wants to see the E drive to burn to. If you have the stick attached before you mount the iso, the drive ordering will be wrong.

And, once all the files have been copied over to the new usb-stick "E" drive, run the Porteus-for-Windows.exe installer *from the E drive", not from the mounted iso.

With these steps in mind, the Porteus windows installer utility works like a charm!

Porteus 4.0 not booting in UEFI mode SOLVED

Posted: 15 Aug 2019, 08:38
by nanZor
P.S. - I never tried using Rufus with Porteus before, and am glad to report that works just fine too.

For my UEFI-only machines, I just made sure I used the "GPT" partitioning method, and the default iso burn worked fine.

I never had a problem burning bootable drives from withing Porteus itself, and appreciate not having to rely on a 3rd-party burner with Porteus' own utilities, but good to know that Rufus can handle it just as well too. Thanks for making me check that out.

Porteus 4.0 not booting in UEFI mode SOLVED

Posted: 15 Aug 2019, 14:06
by zahtar
nanZor, thanks for your reply.

I didn't mount the iso, I just extracted it with 7zip and copied-pasted the folders to the flash drive. I found this a lot simpler. With the .exe being in the same drive already, the correct drive letter was succesfully detected. From that point on, I could successfully boot in bios mode, and after I copied the efi folder, I've been booting in UEFI with no problems.

I don't know what RUFUS is (despite having seen it somewhere mentioned) I've never used it. I'm glad my question motivated further research, I hope other users can benefit from it. :good:

Porteus 4.0 not booting in UEFI mode SOLVED

Posted: 15 Aug 2019, 21:53
by nanZor
Rufus is a usb-stick burning utility. Without going too far off topic about it, if nothing else, it will properly recognize and format drives that windows won't recognize, or try to format with some strange capacity, like your 32gb stick windows tries to format to 12gb. :)

Just use the non-bootable option for a simple clean format. Then you can follow the Porteus iso burn instructions with the Porteus utility, or simply allows Rufus to now make the iso bootable. Or use whatever technique you prefer, but at least now the stick is properly recognized. And unlike windows, when presented with large sticks, it won't try to switch to exFAT, but will burn even large drives with vfat. Handy.

It gets coverage elsewhere, but I recommend it highly just for the ability to detect and simply format a drive that other utilities don't even recognize. Having it properly burn Porteus on my modern uefi-only machines is an added bonus!

Porteus 4.0 not booting in UEFI mode SOLVED

Posted: 31 Aug 2019, 08:04
by M. Eerie
nanZor wrote:
15 Aug 2019, 21:53
Rufus is a usb-stick burning utility.
Microsoft opens ExFAT. Sort of...

And then... Rufus adds persistence feature to USB image creation