Page 1 of 1

Problems in booting v3.2.2 32 bit in old Laptop

Posted: 29 May 2017, 07:38
by raja
As advised I am posting this again in a new subject line.

I have been trying to somehow get v3.2.2,32 bit run in my old Laptop.
Today, I replaced Kernel and Vmlinuz with the latest and started in fresh mode. Booted ok and the best thing was the kernel had MT7601u driver for USB WiFi dongle and connected @110 kbps.My old Raling thing had limitation to 801.11B/G and no N protocol.

I replaced core module with the v3.2.2. The machine booted but with the error message, " unknown user 'Avahi' in the D message bus configuration. Reboot resulted in hanging after 'unmounting all'', may be due to this avahi thing. Solution please.How can I remove Avahi servers once for all?. I don't need them.

Next, I replaced XFCE module with the new one. Boot process got stuck with the 'login'splash screen. 'Guest' was already entered, and on entering password, the login screen comes back in loop,I paused the screen. Following were the log entries.
Initializing Vidmode extension
Initializing DGA
Initializing DRI
Loading extension Glx
Linear memory allocation xxxx etc
DRM memory allocation failed -6Linear memory allocated and xxxx memory freed.
/user/bin/xauth file /home/guest does not exist
/user/bin/startxpce4:X server already running on display 0.0
XFCE4 session:error while loading shared library '
cannot open shared object, no such file or directory

freed memory closed server successfully.

and the splash login screen loops back.
When you can help me to over come these fault lines while loading core and xfce4(v3,2,2) modules,
I shall replace xorg.xzm with the latest and reply back.

Hope I will succeed in booting v3.2.2 in my old machine with expert help.

Re: Problems in booting v3.2.2 32 bit in old Laptop

Posted: 29 May 2017, 08:44
by Evan
Post the Make and Model in case someone else has the same laptop or one with the same specifications.

Jack used to be good at getting Porteus to run on really old laptops but i've not seen him on the forum for ages..........

Re: Problems in booting v3.2.2 32 bit in old Laptop

Posted: 29 May 2017, 09:13
by raja
Mitac VT6363a Note Book
Processor:Intel T2060- Dual core @1.6GHZ
Memory:2 GB,667 MHz, DDR2
VIA Chipsets in Motherboard
Graphics: VIA Chrome 9 family IGP. M4P900 Chip
2007 make.
BIOS Pheonix R1.03,KBC BIOS R1.04
Windows XP.Porteus v3.1,Slax all run very well.

Re: Problems in booting v3.2.2 32 bit in old Laptop

Posted: 13 Jun 2017, 11:34
by raja
I was assuming, poor specs could be source of trouble for porteus 3.2.2. Last week end,I tried, Debian dog Stretch with Deepin desktop.apt-get,was the motivation,since .deb packages are plenty.

Kernel-4.7.1; X org-1.19; Deepin-15.3, all almost current versions. Surprisingly, system booted with no problem in my old m/c,once written by 'dd' command from usb stick.

This package uses porteus initrd script or debian live boot.I tried both,successful. So where is the source of trouble?

On the negative side,debian halt,reboot,suspend,quit x, scripts, nothing works, m/c hangs..heard kernel problem associated with power mgt in version

Deepin is attractive but size is around 150 mb. Porteus Gnome player plays full HD videos without lag.cpu @80%: Debian Gnome player 1.09 with deepin wm, struggle ;cpu @100 and heavy lag,only frames are moved,may be at 15 fps.

X org, strangely, could not use open chrome,and wastes 25 sec to find screen resolution with vesa, all drivers compiled for v 1.19, and finally decides 1280*720; actual is 1280*800 @60hz.porteus 3.1 never had this problem. x org used both drivers on different times.

installed mesa-utils. 3d, glx gears show 88 fps. in porteus i got 106 fps.

more for info.

Re: Problems in booting v3.2.2 32 bit in old Laptop

Posted: 14 Jun 2017, 07:07
by fulalas
You can try to boot in Always Fresh mode. If it doesn't succeed, try to download the whole ISO again: ... x86_64.iso

Problems in booting v3.2.2 32 bit in old Laptop

Posted: 31 Jul 2017, 08:42
by raja
Finally. I managed to boot v3.2.2 - 32 bit in this Laptop. The trouble was with X. org's strange ways.
In fact, 83% of the people that were said to be using the VESA driver were using either Intel, NVIDIA, or ATI/AMD hardware! The other 17% were using SiS / XGI, VIA, Matrox, or something else. When it came to the percentages of the big three vendors, Intel was at 26%, NVIDIA was at 29%, and ATI was at 28%. ... &px=Nzc3Nw

That means, irrespective of Graphic chip sets, X. org configuration can lead you to trouble. Every driver has to be compiled for the particular X- server version and ABI class video version, otherwise X server rejects.

After a long search in the net, I located a 'rpm' resource nearly matching the X-Server in v3.2.2, 'xorg-x11-drv-openchrome-0.3.3-17.fc23.i686.rpm', removed openchrome -0.4.1 bundled with the release ( does not work-blank screen), and extracted the 'usr' directory from the 'rpm' to 'rootcopy and booted.

Everything fine. see log below.

Code: Select all

X.Org X Server 1.18.3
Release Date: 2016-04-04
[    17.991] X Protocol Version 11, Revision 0
[    17.991] Build Operating System: Slackware 14.2 Slackware Linux Project
[    17.991] Current Operating System: Linux porteus 4.4.76-porteus #1 SMP PREEMPT Sat Jul 8 19:08:57 UTC 2017 i686
[    17.992] Kernel command line: quiet initrd=initrd.xz changes=/mnt/sda1/save322.dat BOOT_IMAGE=vmlinuz 
[    17.992] Build Date: 15 April 2016  11:51:37AM

 LoadModule: "openchrome"
[    18.403] (II) Loading /usr/lib/xorg/modules/drivers/
[    18.428] (II) Module openchrome: vendor=""
[    18.428] 	compiled for, module version = 0.3.3
[    18.428] 	Module class: X.Org Video Driver
[    18.428] 	ABI class: X.Org Video Driver, version 20.0

clock: 71.1 MHz   Image Size:  331 x 207 mm

[    19.479] (II) CHROME(0): VIAGetPanelSizeFromDDCv1: (1280x800)
[    19.479] (II) CHROME(0): ViaPanelLookUpModeIndex, Width 1280, Height 800, NativeModeIndex7
[    19.479] (II) CHROME(0): NativeMode: 1280 800

CHROME(0): Timed   MMX2 YUV420 copy... 1025700. Throughput: 925.4 MiB/s.
[    19.879] Freed 8504320 (pool 4)
[    19.879] (--) CHROME(0): Using MMX2 YUV42X copy for video.

CHROME(0): Setting screen physical size to 338 x 211
Now Screen sizing is exact and Full HD Videos play without any problem.

This is done under 2 seconds. VESA was taking 30 secs and ended up fixing resolution at 1280*720.

Problems in booting v3.2.2 32 bit in old Laptop

Posted: 01 Aug 2017, 17:52
by jssouza
Wow! Well done. :good:

Problems in booting v3.2.2 32 bit in old Laptop

Posted: 05 Aug 2017, 22:10
by brokenman
Yeah. Wow Raja. Nice catch.

This would have been impossible for me to track down. I hope this information comes in useful in the future, and I hope you are happy with your new found knowledge and faster system.

Problems in booting v3.2.2 32 bit in old Laptop

Posted: 10 Aug 2017, 09:22
by raja
Thanks js souza and brokenman,,,

I looked at the openchrome driver's Video copy Bench mark test in Porteus v3.2.2 (kernel 4.4.76), Aporteus-Arch based (kernel 4.11.3) and in Debdog Stretch - Debian based )kernel 4.7.1PAE) in my Laptop. (all 32 bit)

Porteus : 924.4 MiBs/sec
Aporteus -Arch : 334.5 "
Debdog -Debian : 553.2 "

So for the same architecture, bench mark results vary by 2x, 3x. Must be the way , the OS is structured and resides in the memory and its communication with the Video,main processors and memory is different in the three cases.

Speed and Stability are the main criteria for any OS implementation . In my case , Porteus wins hands down. 'Collar up' , brokenman!