[Solved] porteus refuses to switch language

Technical issues/questions of an intermediate or advanced nature.
Chuck
White ninja
White ninja
Posts: 5
Joined: 10 Oct 2023, 15:29
Distribution: Porteus LXQT 5.0 x86_64

[Solved] porteus refuses to switch language

Post#1 by Chuck » 20 Apr 2024, 12:38

Hello. I've installed the language files through the porteus settings centre, the modules are loaded at startup but the menus and applications remain in english. If i logout the language selection shows only "default". How do I troubleshoot this? I'm using porteus 5.01 lxqt x64

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3955
Joined: 20 Mar 2012, 03:42
Distribution: v5.0-64bit
Location: australia
Contact:

porteus refuses to switch language

Post#2 by ncmprhnsbl » 21 Apr 2024, 02:09

Chuck wrote:
20 Apr 2024, 12:38
I'm using porteus 5.01 lxqt x64
not 100% sure, but it looks like language selection for lxqt is not properly implemented for lxqt.
see what happens if you go to menu>preferences>lxqt settings>locale, and set you chosen locale there. (this will add [formats]LANG=<your_locale> to ~/.config/lxqt/lxqt-config-locale.conf file)
you'll need to logout/in, too, i think.
Chuck wrote:
20 Apr 2024, 12:38
If i logout the language selection shows only "default".
if you mean on the lxdm login screen, i'm not sure it works there, though i would have thought it'd be handled by gtk..
also, to check whether the LANG environment variable is set properly, in terminal:

Code: Select all

echo $LANG
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

Chuck
White ninja
White ninja
Posts: 5
Joined: 10 Oct 2023, 15:29
Distribution: Porteus LXQT 5.0 x86_64

porteus refuses to switch language

Post#3 by Chuck » 21 Apr 2024, 09:19

ncmprhnsbl wrote:
21 Apr 2024, 02:09
Chuck wrote:
20 Apr 2024, 12:38
I'm using porteus 5.01 lxqt x64
not 100% sure, but it looks like language selection for lxqt is not properly implemented for lxqt.
see what happens if you go to menu>preferences>lxqt settings>locale, and set you chosen locale there. (this will add [formats]LANG=<your_locale> to ~/.config/lxqt/lxqt-config-locale.conf file)
you'll need to logout/in, too, i think.
Chuck wrote:
20 Apr 2024, 12:38
If i logout the language selection shows only "default".
if you mean on the lxdm login screen, i'm not sure it works there, though i would have thought it'd be handled by gtk..
also, to check whether the LANG environment variable is set properly, in terminal:

Code: Select all

echo $LANG
I have a laptop with the same porteus version but language changing has worked flawlessly, maybe a fluke.

In lxqt locale the language is already set correctly. Anyway running the echo $LANG command returns:

Code: Select all

scn_IT.utf-8
Edit: I found the solution, looking at that output. In lxqt settings there are multiple Italian languages. Instead of it_IT there was chosen scn_IT for all of them apart the first setting. Thanks for the help.

Post Reply