How to install xsp and mod_mono

Arch based Porteus community project
Post Reply
User avatar
Blaze
DEV Team
DEV Team
Posts: 2878
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

How to install xsp and mod_mono

Post#1 by Blaze » 06 Apr 2018, 08:55

I'am not able to install xsp and mod_mono in the nemesis-xfce-18.03.29-x86_64.iso >>> 2018 Updated Nemesis Base Modules (Post by neko #63724)

Code: Select all

pman -S xsp
error: target not found: xsp
with yaourt I have failed too.

Can anybody help me to build xsp and mod_mono xzm modules?

I builded only these modules from my list
apr-1.6.3-1 apr-util-1.6.1-2 apache-2.4.33-3
gtk-sharp-2-2.12.45-1 gtk-sharp-3-2.99.3-1 libgdiplus-5.6-1 mono-5.10.0.179-1 python-3.6.4-2 mono-addins-1.3.3-1

Thanks.
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2480
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

How to install xsp and mod_mono

Post#2 by ncmprhnsbl » 06 Apr 2018, 12:58

these are AUR packages(not actually packages but PKGBUILDs like SlackBuilds)
you'll need the devel.xzm , then pman should work. (i moved all AUR functionality to devel(pacaur,git) to save some size in core.
note that i haven't updated devel.xzm, so there may be some out of date pkgs/headers in it)
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Blaze
DEV Team
DEV Team
Posts: 2878
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

How to install xsp and mod_mono

Post#3 by Blaze » 06 Apr 2018, 20:36

ncmprhnsbl, the same for pacaur.
For building xsp I need fsharp + monodevelop-stable, but I'am not able to build these dev packages :buhehe:
For building mod_mono I need xsp :wall:

Code: Select all

Making all in Mono.WebServer
  DMCS  /out:4.0/Mono.WebServer2.dll
Note: dmcs is deprecated, please use mcs instead!

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
  at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.TermInfoDriver..ctor (System.String term) [0x00055] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.ConsoleDriver..cctor () [0x0004d] in <2dfe84a36ef4410ca18642993b51b799>:0 
   --- End of inner exception stack trace ---
  at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.Console..cctor () [0x0008e] in <2dfe84a36ef4410ca18642993b51b799>:0 
   --- End of inner exception stack trace ---
  at Mono.CSharp.Driver.Main (System.String[] args) [0x00019] in <c7a76d4c9e1e4fe68a25392c10a27768>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
  at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.TermInfoDriver..ctor (System.String term) [0x00055] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.ConsoleDriver..cctor () [0x0004d] in <2dfe84a36ef4410ca18642993b51b799>:0 
   --- End of inner exception stack trace ---
  at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <2dfe84a36ef4410ca18642993b51b799>:0 
  at System.Console..cctor () [0x0008e] in <2dfe84a36ef4410ca18642993b51b799>:0 
   --- End of inner exception stack trace ---
  at Mono.CSharp.Driver.Main (System.String[] args) [0x00019] in <c7a76d4c9e1e4fe68a25392c10a27768>:0 
make[2]: *** [Makefile:494: 4.0/Mono.WebServer2.dll] Error 1
make[1]: *** [Makefile:389: all-recursive] Error 1
make: *** [Makefile:428: all-recursive] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
:: failed to build xsp package(s)
I builded only these dependencies (link for download press on скачать все http://dropmefiles.com/fcu0M)

Code: Select all

apache-2.4.33-3-x86_64.xzm
apr-1.6.3-1-x86_64.xzm*
apr-util-1.6.1-2-x86_64.xzm*
gtk-sharp-2-2.12.45-1-x86_64.xzm*
gtk-sharp-3-2.99.3-1-x86_64.xzm*
#icu-61.1-1-x86_64.pkg.xzm (installed in the system)
libgdiplus-5.6-1-x86_64.xzm*
mono-5.10.0.179-1-x86_64.xzm*
mono-addins-1.3.3-1-x86_64.xzm*
#sqlite-3.23.0-1-x86_64.pkg.xzm (installed in the system)
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2480
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

How to install xsp and mod_mono

Post#4 by ncmprhnsbl » 06 Apr 2018, 22:45

Blaze wrote:
06 Apr 2018, 20:36
For building xsp I need fsharp + monodevelop-stable
xsp should only require mono and sqlite:
https://aur.archlinux.org/packages/xsp/
monodevel-stable requires these: 'mono' 'mono-addins>=0.6.2' 'gtk-sharp-2' 'fsharp' 'libssh2' 'curl' 'msbuild-stable' and optionally xsp
https://aur.archlinux.org/packages/monodevelop-stable/
fsharp might need some adjustment to the pkgbuild: https://aur.archlinux.org/packages/fsharp/ (read the comments)
also, there's been quite a bit of updates recently, so some of the base modules could be out of date..
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Blaze
DEV Team
DEV Team
Posts: 2878
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

How to install xsp and mod_mono

Post#5 by Blaze » 07 Apr 2018, 09:53

I have mono and sqlite, but can't to build xsp package from AUR (look at my log in previous post).
Linux 5.4.8-porteus #1 SMP Sun Jan 5 09:14:47 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2480
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

How to install xsp and mod_mono

Post#6 by ncmprhnsbl » 08 Apr 2018, 04:39

just tried to make xsp on my full arch install, and it fails with the same errors.. so something is broken, probably the PKGBUILD..
possibly it's just out of date .. last realease of xsp(3 days ago) is 4.5 https://github.com/mono/xsp/releases
the PKGBUILD is at 4.4..
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

Post Reply