[Solved][PXE Boot] http_server empty

'User made' tutorials related to Porteus Kiosk edition.
Official kiosk documentation can be find here: http://porteus-kiosk.org/documentation.html
Post Reply
kaaremai
White ninja
White ninja
Posts: 13
Joined: 13 May 2016, 13:10
Distribution: 4.9.0
Location: Denmark

[Solved][PXE Boot] http_server empty

Post#1 by kaaremai » 18 Sep 2019, 13:04

Hi,

I'm trying to setup PXE booting. I'm using this guide: https://porteus-kiosk.org/pxe-server.html

I use a Windows Server 2016 running TFTP and HTTP. Another server is running our DHCP server which i have updated with the proper PXE boot info.

I have created the ISO with the pxe client enabled and unpacked the ISO in the proper folders so that the pxe boot files them selves get served in:

c:\tftp\boot and the xzm files get serverd on <ip>\xzm.

The client machine boots properly over LAN through TFTP but then it errors out with blue text saying:

Code: Select all

If you are booting from writable media then please make sure you have burned teh ISO using.... and then later Press ´d´ to display debug info....
Then when i press "d" it says:

booting parameters: net.ifnames=0 video=hyperv_fb:1920x1080 initrd=initrd.xz,pxelinux.cfg/initrdpxe.xz quiet http_server= BOOT_IMAGE=vmlinuz
kernel...'
kernel modules...
available network interfaces: lo

The http_server field i updated in the pxelinux.cfg/default file but it's still empty in the above text. Also is it correct that available network interfaces should only say "lo"?
Last edited by kaaremai on 19 Sep 2019, 12:13, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 5177
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland
Contact:

[PXE Boot] http_server empty

Post#2 by fanthom » 19 Sep 2019, 10:48

Hello kaaremai,

"The http_server field i updated in the pxelinux.cfg/default file but it's still empty in the above text. Also is it correct that available network interfaces should only say "lo"?"
Your kiosk client must be booting from some other ISO as initrdpxe.xz is not transported on the client side.
Also http_server can not be empty.

Thanks
Please add [Solved] to your thread title if the solution was found.

kaaremai
White ninja
White ninja
Posts: 13
Joined: 13 May 2016, 13:10
Distribution: 4.9.0
Location: Denmark

[PXE Boot] http_server empty

Post#3 by kaaremai » 19 Sep 2019, 11:54

fanthom wrote:
19 Sep 2019, 10:48
Hello kaaremai,

"The http_server field i updated in the pxelinux.cfg/default file but it's still empty in the above text. Also is it correct that available network interfaces should only say "lo"?"
Your kiosk client must be booting from some other ISO as initrdpxe.xz is not transported on the client side.
Also http_server can not be empty.

Thanks
Hi,

I made the ISO file on the client with the PXE client box ticked. Then i downloaded the ISO to the server and unpacked it. The client can now boot over PXE. However it fails when trying to download the xzm modules it seems.

The client cannot be booting from something else as theres no harddrive in the machine with linux on and no conected USB drive either.

I just noticed that it also says the following before the above error:
Missing parameter in configuration file. Keyword: x.x.x.x (where the x's are the IP that i entered in the config file)

The config file looks like this:

Code: Select all

timeout 0
prompt 0
default pxe
label pxe
kernel vmlinuz
append initrd=initrd.xz,pxelinux.cfg/initrdpxe.xz quiet http_server=x.x.x.x
Where again the x.x.x.x is the IP of the server.

One thing that i'm also not sure about which is not clear in the tutorial is the file structure on the http server. Right now if i enter http://x.x.x.x/ then it shows one folder named /xzm where the xzm files is located in is this correct? I seem to have read somewhere that you should see a folder named /porteus.

kaaremai
White ninja
White ninja
Posts: 13
Joined: 13 May 2016, 13:10
Distribution: 4.9.0
Location: Denmark

[PXE Boot] http_server empty

Post#4 by kaaremai » 19 Sep 2019, 12:12

The problem was the file format! When opening the default file in notepad on windows it changes the carriage return from only CR to CR LF. When editing it in notepad++ it now works!

I still have some issues but they're not related to this problem so i'll make another post if i can't solve them my self.

Post Reply