Self signed SSL - Your connection is not private [Solved]

'User made' tutorials related to Porteus Kiosk edition.
Official kiosk documentation can be find here: http://porteus-kiosk.org/documentation.html
Post Reply
Farfh
Ronin
Ronin
Posts: 3
Joined: 20 May 2020, 09:21
Distribution: 5.0.0.0

Self signed SSL - Your connection is not private [Solved]

Post#1 by Farfh » 20 May 2020, 21:50

Hi

I use Porteus-Kiosk 5.0.0.0 with Chrome.

I need to use it without Internet and just a direct LAN connection between a touch screen all-in-one pc and a BMS Controller (Building Management System)

Is there a way to configure and accept a self signed SSL certificate to avoid the alert page:
"Your connection is not private" -> Advanced -> Proceed to 10.10.10.10 (unsafe) before showing the login screen?

I use full screen without Navigator.

Have tried to whitelist and set some browser_preferences without succes.
Last edited by Farfh on 26 May 2020, 19:44, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 5286
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland
Contact:

Self signed SSL - Your connection is not private

Post#2 by fanthom » 21 May 2020, 08:40

Hello Farfh,

For Chrome you can use this parameter to workaround the problem:
https://porteus-kiosk.org/parameters.ht ... rtificates

Mind it will completely skip certificate checking on all websites. This should be safe for LAN but i would not enable it if internet browsing is possible in the kiosk (for this case a custom build with manually added certificate exception would be better).

Thanks
Please add [Solved] to your thread title if the solution was found.

Farfh
Ronin
Ronin
Posts: 3
Joined: 20 May 2020, 09:21
Distribution: 5.0.0.0

Self signed SSL - Your connection is not private

Post#3 by Farfh » 26 May 2020, 19:43

It worked.
Made a simple custom build with a kiosk-config.txt file ready to edit and import under installation.
Thank you

Post Reply