Unable to load config file

'User made' tutorials related to Porteus Kiosk edition.
Official kiosk documentation can be find here: http://porteus-kiosk.org/documentation.html
Post Reply
dessington
White ninja
White ninja
Posts: 7
Joined: 08 Aug 2018, 12:11
Distribution: Custom built Ubuntu Plasma

Unable to load config file

Post#1 by dessington » 08 Aug 2018, 12:19

Hi,

I have the kiosk.txt file on my server (publicly accessible & loads correctly in browser so is correct & accessible) with all settings including kiosk_config url but the setup will not load it. Url is: kiosk_config=http://myserver.co.za/lab/kiosk.txt. Have tried with and without https & www. Any ideas?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4800
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Unable to load config file

Post#2 by fanthom » 08 Aug 2018, 16:35

I understand you enter just the URL in the wizard and not parameter+URL?

Make sure on final config window:
http://porteus-kiosk.org/screens/wizard/config.png

you have parameter+URL:

Code: Select all

kiosk_config=http://myserver.co.za/lab/kiosk.txt
By the way - this url is not valid:
http://myserver.co.za/lab/kiosk.txt

i cant find any kiosk config there.
Please add [Solved] to your thread title if the solution was found.

dessington
White ninja
White ninja
Posts: 7
Joined: 08 Aug 2018, 12:11
Distribution: Custom built Ubuntu Plasma

Unable to load config file

Post#3 by dessington » 08 Aug 2018, 18:49

It was an example domain I used. The actual one is https://www.kingsschool.co.za/lab/kiosk.txt

User avatar
fanthom
Site Admin
Site Admin
Posts: 4800
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Unable to load config file

Post#4 by fanthom » 08 Aug 2018, 19:10

Your webserver is configured to reject all clients which does not have an user agent set:

Code: Select all

wget https://www.kingsschool.co.za/lab/kiosk.txt
--2018-08-08 21:08:11--  https://www.kingsschool.co.za/lab/kiosk.txt
Resolving www.kingsschool.co.za... 77.104.189.92
Connecting to www.kingsschool.co.za|77.104.189.92|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2018-08-08 21:08:12 ERROR 403: Forbidden.
This works:

Code: Select all

wget -U mozilla https://www.kingsschool.co.za/lab/kiosk.txt
--2018-08-08 21:08:23--  https://www.kingsschool.co.za/lab/kiosk.txt
Resolving www.kingsschool.co.za... 77.104.189.92
Connecting to www.kingsschool.co.za|77.104.189.92|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/plain]
Saving to: 'kiosk.txt'

kiosk.txt                                                [ <=>                                                                                                                 ]     782  --.-KB/s    in 0s      

2018-08-08 21:08:24 (40.5 MB/s) - 'kiosk.txt' saved [782]
Maybe you could remove this policy?

We cant add user agent by default as it breaks configs hosted on e.g. dropbox.com.
Please add [Solved] to your thread title if the solution was found.

dessington
White ninja
White ninja
Posts: 7
Joined: 08 Aug 2018, 12:11
Distribution: Custom built Ubuntu Plasma

Unable to load config file

Post#5 by dessington » 08 Aug 2018, 19:17

Yes this is to block spam traffic and cannot be disabled. How could I set the user agent?

dessington
White ninja
White ninja
Posts: 7
Joined: 08 Aug 2018, 12:11
Distribution: Custom built Ubuntu Plasma

Unable to load config file

Post#6 by dessington » 08 Aug 2018, 19:19

Ok I managed to remove just wget and it works :) Thank you for your assistance.

dessington
White ninja
White ninja
Posts: 7
Joined: 08 Aug 2018, 12:11
Distribution: Custom built Ubuntu Plasma

Unable to load config file

Post#7 by dessington » 08 Aug 2018, 20:04

This is such a useful piece of software thank you.

dessington
White ninja
White ninja
Posts: 7
Joined: 08 Aug 2018, 12:11
Distribution: Custom built Ubuntu Plasma

Unable to load config file

Post#8 by dessington » 08 Aug 2018, 20:14

Last question: When it boots it shows my wallpaper, then a black screen for a few seconds then displays the wallpaper again. Is there any way to skip the black screen interval?

User avatar
fanthom
Site Admin
Site Admin
Posts: 4800
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Unable to load config file

Post#9 by fanthom » 09 Aug 2018, 09:42

Its not possible to skip the black screen completely as splash works on a kernel framebuffer while browser needs Xorg session (different drivers).
Please add [Solved] to your thread title if the solution was found.

dessington
White ninja
White ninja
Posts: 7
Joined: 08 Aug 2018, 12:11
Distribution: Custom built Ubuntu Plasma

Unable to load config file

Post#10 by dessington » 09 Aug 2018, 16:17

Ok ty.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4800
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Unable to load config file

Post#11 by fanthom » 09 Aug 2018, 16:27

Actually - you may try:

Code: Select all

gpu_driver=modesetting
but you'll loose some features (e.g. there may be tearing on Intel GPU when screen is rotated).
Please add [Solved] to your thread title if the solution was found.

Post Reply