Porteus Server on a VM brokes network connections

'User made' tutorials related to Porteus Kiosk edition.
Official kiosk documentation can be find here: http://porteus-kiosk.org/documentation.html
Post Reply
Prtiller
Ronin
Ronin
Posts: 1
Joined: 11 May 2018, 11:49
Distribution: 4.6

Porteus Server on a VM brokes network connections

Post#1 by Prtiller » 11 May 2018, 12:05

Hi,

On a virtual machine (Esxi) a LAMP server is installed, with Ubuntu Server, Apache2, MySql, PhpMyAdmin, etc, with many Wordpress sites. I installed the Porteus server (4.6 Basic) on a new virtual machine, on the same physical server, to test (obviously on a different IP address). When launched, all connections to the LAMP server have been interrupted. I could only ping the server, but no SSH, HTTP, FTP, etc. connection was not working anymore. After deleting the VM with Porteus Server everything started to work again.

Regards

Paolo Rossi
University of Bologna
IT Department
Italy

User avatar
fanthom
Site Admin
Site Admin
Posts: 4739
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Porteus Server on a VM brokes network connections

Post#2 by fanthom » 11 May 2018, 15:47

Hi Paolo,

PK Server runs 'stunnel' daemon by default which listens on port 443 on local server IP. Ports 80 and 5900 also may be opened if you enabled SSH/VNC in the server wizard.
PK Server may connect to your DHCP service if you selected this option during installation.

I'm not sure how these services could affect your network environment. Its pretty standard and your are first reporting such issues.

Thanks
Please add [Solved] to your thread title if the solution was found.

Post Reply