Add module driver printer

Here you can post about the issues related to modifications performed manually (not through the kiosk wizard). Example: swapped kernel, added 3rd party modules or files.
Please describe in detail what has been changed and hopefully other kiosk user will be able to help.
Porteus team wont resolve bugs posted in this category as we support only modifications made by the kiosk wizard.
Post Reply
diannella
Ronin
Ronin
Posts: 2
Joined: 17 Oct 2019, 13:51
Distribution: 4.9

Add module driver printer

Post#1 by diannella » 17 Oct 2019, 14:31

Hi,

I create e module that contain a driver printer ARGOX P4250.

I followed this guide:

Code: Select all

mkdir remaster
cd remaster
wget http://porteus-kiosk.org/public/4.0/Porteus-Kiosk-Server-4.0.0-x86_64.iso
 
mkdir /mnt/cdrom
mkdir kiosk_ISO
mkdir fakeroot

mkdir PPD
mount -o loop Porteus-Kiosk-Server-4.0.0-x86_64.iso /mnt/cdrom
cp -a -v /mnt/cdrom/* kiosk_ISO/
cd fakeroot

mkdir -p usr/share/cups/model/argox
mkdir -p usr/libexec/cups/filter
cp -v ../PPD/pbhc203psc200en.ppd usr/share/cups/model/argox/

nano opt/scripts/files/wizard/printers.d/argox

cd ..
mksquashfs fakeroot/ konica.xzm -comp xz -b 256K -Xbcj x86 -noappend
cp -v konica.xzm kiosk_ISO/xzm/
cd kiosk_ISO
when i ran this code:

Code: Select all

./make_iso.sh
system answer with this error:

Code: Select all

Something went wrong - could not create the ISO. Please use 'mkisofs' utility from latest 'cdrtools' package rather tahn 'cdr-kit'.
You can download 'mkisofs' utility directly from this location: http://porteus-kiosk.org/public/files/mkisofs make it executable, move to /usr/local/bin floder and rerun this csript
[/b]

then i use this code:

Code: Select all

sudo mkisofs -o Porteus-Kiosk.iso /home/daniel/Documenti/remaster/kiosk_ISO
the system has created the Porteus-Kiosk.iso but if I execute this command,

Code: Select all

isohibrid Porteus-kiosk.iso
the result is:

Code: Select all

isohybrid: Porteus-Kiosk.iso: could not find boot record
[/b]

YOU CAN HELP ME :wall: :wall:

Thank You all

User avatar
fanthom
Site Admin
Site Admin
Posts: 5180
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland
Contact:

Add module driver printer

Post#2 by fanthom » 20 Oct 2019, 07:53

Diannella,

You need to download mkisofs utility from kiosk website, make it executable and place it in the /use/local/bin folder - as instructed in the error message.

Please also switch to root with:
sudo su

run following command to ensure our utility will be used:
which mkisofs
(it should return /use/local/bin/mkisofs)

and then rerun 'make_iso.sh' script.

Thanks
Please add [Solved] to your thread title if the solution was found.

Post Reply