Page 1 of 1

[Solved] cannot lock screen

Posted: 12 Feb 2019, 19:54
by user0815
Dear All,
Cannot find any option to lock screen in xfce, also wake up after suspend doesn’t do it although setting was on. Can anyone help?

Re: cannot lock screen

Posted: 13 Feb 2019, 05:57
by donald
Lock screen
Seems it is not included in porteus_4 -- it is in 3.2.2
However you need the xlockmore-5.46-x86_64-1.txz package.

But that's not enough, you also need which is in imagemagick-6.9.4_9-x86_64-1.txz

and in package libwmf-

Extract the needed files or activate the whole package.
(convert to xzm first)

adjustments can be made in /etc/X11/app-defaults/Xlock - i think

A keyboard shortcut to lock the screen can be made at
settings > keyboard > Application Shortcuts

Download the packages at
( slackware 14.2 )

Re: cannot lock screen

Posted: 13 Feb 2019, 06:03
by Ed_P
Or use USM. GUI or via terminal.

Code: Select all

guest@porteus:~$ su
root@porteus:/home/guest# usm -g xlockmore

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) xlockmore-5.46-x86_64-1.txz
#? 1

Processing:   xlockmore-5.46-x86_64-1.txz 
Ignored libraries: 

Libraries required:  15
Libraries found in system: 14
Libraries to resolve: 1

Processing library:

Processing:   imagemagick-6.9.4_9-x86_64-1.txz 
Ignored libraries: 

Libraries required:  75
Libraries found in system: 72
Libraries to resolve: 3

Processing library:
Processing library:
Processing library:

Processing:   libwmf- 
Ignored libraries: 

Libraries required:  20
Libraries found in system: 18
Libraries to resolve: 2

Processing library:
Processing library:

 The following packages are required. 
imagemagick-6.9.4_9-x86_64-1.txz [6424K] [not installed]
libwmf- [740K] [not installed]
xlockmore-5.46-x86_64-1.txz [1020K] [not installed]

Total size: 8 MB

 Multiple packages were detected.
 Would you like to merge the packages into one module? [y/n]

 Press [r] to remove packages, [q] to quit, or enter to start downloading.
Downloading: imagemagick-6.9.4_9-x86_64-1.txz  DONE
Downloading: libwmf-  DONE
Downloading: xlockmore-5.46-x86_64-1.txz  DONE
imagemagick-6.9.4_9-x86_64-1: a robust collection of image processing too [ 18M]
libwmf- WMF graphics format library .................... [1.6M]
xlockmore-5.46-x86_64-1: screen locker for X ............................ [3.6M]
Parallel mksquashfs: Using 4 processors
Creating 4.0 filesystem on /tmp/usm/xlockmore-5.46-x86_64-bundle.xzm, block size 262144.
[=============================================================/] 1368/1368 100%

Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
	compressed data, compressed metadata, compressed fragments,
	compressed xattrs, compressed ids
	duplicates are removed
Filesystem size 8393.66 Kbytes (8.20 Mbytes)
	36.63% of uncompressed filesystem size (22914.40 Kbytes)
Inode table size 6776 bytes (6.62 Kbytes)
	15.03% of uncompressed inode table size (45076 bytes)
Directory table size 12230 bytes (11.94 Kbytes)
	36.34% of uncompressed directory table size (33651 bytes)
Number of duplicate files found 711
Number of inodes 1392
Number of files 1317
Number of fragments 36
Number of symbolic links  13
Number of device nodes 0
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 62
Number of ids (unique uids + gids) 2
Number of uids 1
	root (0)
Number of gids 2
	root (0)
	shadow (43)
Quiet mode: off
Updating shared library links:  /sbin/ldconfig

/tmp/usm/xlockmore-5.46-x86_64-bundle.xzm is ready.


cannot lock screen

Posted: 20 Mar 2019, 04:13
by user0815
Could you please help me to add [solved] to thread title? Due to some reason I don’t have the edit button for my first post. Thank you.