Problem with VLC LAN under 4.0 64bit Porteus.

Get help with XFCE specific problems
Kulle
Samurai
Samurai
Posts: 172
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Problem with VLC LAN under 4.0 64bit Porteus.

Post#1 by Kulle » 04 Aug 2018, 14:17

I have created the module vlc-3.0.3-x86_64-1alien.xzm
Then I tried one after the Libs:
libidn-1.30-x86_64-1.xzm
libidn-1.34-x86_64-1_slack14.2.xzm
perl-Net-LibIDN-0.12-x86_64-1_slonly.xzm

!! Everything didn't work. !!
Always the same error message:
Libidn. So. 12: Cannot open Shared object file: No such file or directory
I'm desperate, Can anyone help?
Thank you very much.

User avatar
Ed_P
Contributor
Contributor
Posts: 5037
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

[SOLVED] Problem with latest VLC LAN under 3.2.2 64bit Porteus.

Post#2 by Ed_P » 04 Aug 2018, 14:40

Ed

Kulle
Samurai
Samurai
Posts: 172
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

[SOLVED] Problem with latest VLC LAN under 3.2.2 64bit Porteus.

Post#3 by Kulle » 04 Aug 2018, 14:58

Thanks for the note.
But the module vlc-2.2.4_bundle_non-kde-x86_64-1bp.xzm
does not work!
When I click "Media Open File", VLC crashes !

Kulle
Samurai
Samurai
Posts: 172
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Problem with VLC LAN under 4.0 64bit Porteus.

Post#4 by Kulle » 05 Aug 2018, 09:41

Google search Result:
libidn.so.12 is part of the package libidn-1.35-x86_64.txz
But (!)
usm -g libidn-1.35-x86_64.txz
Error message: Nothing found for: libidn-1.35-x86_64.txz
And now ??
The module vlc-3.0.3-x86_64-1alien.xzm required libidn.so.12

User avatar
Ed_P
Contributor
Contributor
Posts: 5037
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Problem with VLC LAN under 4.0 64bit Porteus.

Post#5 by Ed_P » 05 Aug 2018, 13:30

Try a different version.

Code: Select all

root@porteus:/home/guest# usm -g vlc

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) vlc-2.2.4-x86_64-1gv.txz	  3) vlc-3.0.3-x86_64-1_slonly.txz
2) vlc-3.0.2-x86_64-1alien.txz	  4) vlc2-2.2.8-x86_64-2alien.txz
#? ^[
Ed

Kulle
Samurai
Samurai
Posts: 172
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Problem with VLC LAN under 4.0 64bit Porteus.

Post#6 by Kulle » 05 Aug 2018, 18:10

Many thanks.
I have chosen the latest version vlc-3.0.3-x86_64-1_slonly.txz
There were a very (!) lot of dependencies!
And at the end:
FATAL ERROR! resolve_deps 369
Please wait 6 hours for the next database update.

Why is Linux so complicated??
I never had such difficulties on Windows.
The above problem is only: missing libidn.so.12
That would have to be solvable?
Does anyone know how to add the missing library program?
Thanks for the help.

User avatar
Ed_P
Contributor
Contributor
Posts: 5037
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Problem with VLC LAN under 4.0 64bit Porteus.

Post#7 by Ed_P » 05 Aug 2018, 23:17

Kulle wrote:
05 Aug 2018, 18:10
I have chosen the latest version vlc-3.0.3-x86_64-1_slonly.txz
There were a very (!) lot of dependencies!
And at the end:
FATAL ERROR! resolve_deps 369
Please wait 6 hours for the next database update.
Did you do a USM update before using it?
Did you tweak your USM mirrors?
Kulle wrote:
05 Aug 2018, 18:10
Why is Linux so complicated??
I never had such difficulties on Windows.
Linux has many more independent facets than Windows. ;)
Ed

donald
Full of knowledge
Full of knowledge
Posts: 1532
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Problem with VLC LAN under 4.0 64bit Porteus.

Post#8 by donald » 06 Aug 2018, 00:32

@ Kulle
Hi
I tried to build the "vlc-3.0.2-x86_64-1alien.xzm" module via USM...
It took several attempts to get past the "FATAL ERROR! resolve_deps 369" error.
(selecting different packages)

These packages did finaly build the module and doesn't show the "libidn.so.12" error.
But the size of the module is grotesque...

The list:

Code: Select all

glew-1.13.0-x86_64-1.txz
gst-plugins-base-1.6.4-x86_64-1.txz
gstreamer-1.6.4-x86_64-1.txz
hunspell-1.3.3-x86_64-1.txz
icu4c-56.1-x86_64-2.txz
jasper-1.900.1-x86_64-5.txz
jemalloc-3.6.0-x86_64-1.txz
judy-1.0.5-x86_64-1.txz
libinput-1.11.1-x86_64-2_slonly.txz
libiodbc-3.52.10-x86_64-2.txz
libunistring-0.9.3-x86_64-1.txz
libvisual-0.4.0-x86_64-3.txz
libvncserver-0.9.10-x86_64-2.txz
libwacom-0.30-x86_64-1_slonly.txz
libxkbcommon-0.8.0-x86_64-1_slonly.txz
mariadb-10.0.26-x86_64-1.txz
qt5-5.7.1-x86_64-1alien.txz
vlc-3.0.2-x86_64-1alien.txz
wayland-1.12.0-x86_64-1_slonly.txz
xcb-util-image-0.4.0-x86_64-2.txz
xcb-util-keysyms-0.4.0-x86_64-2.txz
xcb-util-renderutil-0.3.9-x86_64-2.txz
xcb-util-wm-0.4.1-x86_64-2.txz

Kulle
Samurai
Samurai
Posts: 172
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Problem with VLC LAN under 4.0 64bit Porteus.

Post#9 by Kulle » 06 Aug 2018, 08:00

Thank you Donald,
I've tried that now too,
It took a very long time and it crashed just before the end.

There is a version for KDE :
VLC 3.0.2 for Porteus 4.0 KDE
vlc-3.0.2-x86_64-kde-jss.xzm (14MB)

Size only 14 MB !

It should be possible also for Xfce to create such a module ??
Can anyone help?
thank you

donald
Full of knowledge
Full of knowledge
Posts: 1532
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Problem with VLC LAN under 4.0 64bit Porteus.

Post#10 by donald » 06 Aug 2018, 17:31

Size only 14 MB !
It should be possible also for Xfce to create such a module ??
I don't think so.
QT is the underlying framework in KDE, but GTK in XFCE.

Assembling a VLC module for XFCE needs all the QT stuff and more..

At the end the module will run, but the size is...ridiculous...
and I have no idea what to take out to make it significant smaller without
losing functionality... :unknown:

Kulle
Samurai
Samurai
Posts: 172
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Problem with VLC LAN under 4.0 64bit Porteus.

Post#11 by Kulle » 07 Aug 2018, 13:46

I have downloaded all 23 files from https://slackware.pkgs.org:
vlc-3.0.2-x86_64-1alien.txz
and the 22 lib-files
glew-1.13.0-x86_64-1.txz ... xcb-util-wm-0.4.1-x86_64-2.txz

All 23 files in one folder.

Is there any way from all files to build a single XZM module?
I think that will be possible. But how?
Thanks for the help

donald
Full of knowledge
Full of knowledge
Posts: 1532
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Problem with VLC LAN under 4.0 64bit Porteus.

Post#12 by donald » 07 Aug 2018, 14:21

Is there any way from all files to build a single XZM module?
Example:
all *.txz files put into /tmp/bla
create a 2nd folder named /tmp/vlc

The commands (as root) are:

Code: Select all

for pkgs in /tmp/bla/*.txz; do installpkg -root /tmp/vlc $pkgs; done
After this step you can review the content of the "vlc" folder and change/delete files/folders
you dont want in the final module.
(but you should be sure about what you're doing)

When happy with the content use this command to build the final module.

Code: Select all

dir2xzm /tmp/vlc /tmp/vlc-bundle.xzm
You should find the vlc-bundle.xzm in /tmp

Tip
If you are low on RAM, place the *.txz files into a folder outside the live-filesystem
and adjust the command path accordingly.

jssouza
DEV Team
DEV Team
Posts: 1008
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Problem with VLC LAN under 4.0 64bit Porteus.

Post#13 by jssouza » 07 Aug 2018, 14:53

Kulle wrote:
06 Aug 2018, 08:00
There is a version for KDE :
VLC 3.0.2 for Porteus 4.0 KDE
vlc-3.0.2-x86_64-kde-jss.xzm (14MB)

Size only 14 MB !

It should be possible also for Xfce to create such a module ??
Can anyone help?
thank you
Kulle, you can try activating qt5-base-5.9.5-x86_64-jss.xzm from Qt 5.9.5 for Porteus 4.0 along with vlc-3.0.2-x86_64-kde-jss.xzm to satisfy qt dependencies.

tome
Contributor
Contributor
Posts: 633
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Problem with VLC LAN under 4.0 64bit Porteus.

Post#14 by tome » 07 Aug 2018, 20:39

No intelligence, no life and no information can exist without prior intelligence, life or information (in place where things change and time is running).

Kulle
Samurai
Samurai
Posts: 172
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

Problem with VLC LAN under 4.0 64bit Porteus.

Post#15 by Kulle » 09 Aug 2018, 10:02

Thank you tome for the information.
But the unofficial VLC versions in AppImage format do not work.
The first program:
error while loading shared libraries: /home/guest/Downloads/usr/bin/../lib/libvlc.so.5: file too short
The second program:
error while loading shared libraries: libvlc.so.5: cannot open shared object file: No such file or directory
The third programm:
error while loading shared libraries: /home/guest/Downloads/usr/bin/../lib/libvlc.so.5: file too short

But: file too short??
What to do?

Post Reply