Problem with keyboard " character

Get help with XFCE specific problems
Post Reply
xenos
Black ninja
Black ninja
Posts: 40
Joined: 20 Aug 2016, 22:20
Distribution: Porteus
Location: Blackhole

Problem with keyboard " character

Post#1 by xenos » 21 Oct 2018, 22:44

I am having difficulties to type " character, other character works fine, what could be the possible causes?

I already boot into other distro and testing the particular key ", it works fine there and also in Windows.

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1971
Joined: 20 Mar 2012, 03:42
Distribution: 4.0-64bit all-DE+more
Location: australia
Contact:

Problem with keyboard " character

Post#2 by ncmprhnsbl » 22 Oct 2018, 01:20

you need to change the keyboard layout from us_alt-intl to just us (see the flag icon on the taskbar to access the setting)
why is this so? because our xfce maintainer is brazilian and prefers this layout.. :)
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

xenos
Black ninja
Black ninja
Posts: 40
Joined: 20 Aug 2016, 22:20
Distribution: Porteus
Location: Blackhole

Problem with keyboard " character

Post#3 by xenos » 22 Oct 2018, 19:52

thanks ncmprhnsbl, found similar issue here with solution,

BUG: [Solved] Fix Quotes on US Keyboard

nanZor
Samurai
Samurai
Posts: 147
Joined: 09 Apr 2019, 03:27
Distribution: Porteus 5.0 RC1 XFCE
Location: Los Angeles

Problem with keyboard " character

Post#4 by nanZor » 09 Apr 2019, 07:11

For me it was the apostraphe key driving me batty with the dead-key behavior.

One other solution that worked for me was that since my system identified with a flag for US English in the toolbar, I clicked my way to happiness with:

Settings > Keyboard > Layout and checked [x] Use system defaults

Good to know all the other ways to fine tune the keyboard with the other thread too.

fulalas
DEV Team
DEV Team
Posts: 1327
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Problem with keyboard " character

Post#5 by fulalas » 08 May 2019, 11:20

ncmprhnsbl wrote:
22 Oct 2018, 01:20
why is this so? because our xfce maintainer is brazilian and prefers this layout.. :)
Hahaha! I did that not thinking about Portuguese, but thinking that there's a big world outside English :P

Post Reply