printing.xzm does not work properly

Get help with MATE specific problems
Post Reply
alubypass
White ninja
White ninja
Posts: 6
Joined: 12 Sep 2019, 14:01
Distribution: Porteus 4

printing.xzm does not work properly

Post#1 by alubypass » 12 Sep 2019, 14:11

Hello, I'm using Porteus 4 Mate in the 64 bit version.

I noticed the following. When I add a printer connected via USB in Cups and want to print a Cups test page, I get the error that a test page cannot be printed.

But if I use the 32-bit version of Proteus 4 Mate, the same configuration and printer will print the Cups test page.

Does anyone have any idea why?
Is there any way to set the log level of cups higher that you could evaluate why cups doesn't print the test page?

Yours sincerely
alubypass

User avatar
Blaze
DEV Team
DEV Team
Posts: 2693
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

printing.xzm does not work properly

Post#2 by Blaze » 12 Sep 2019, 15:30

Hi alubypass.

You can look at /var/log/cups/error_log

run these commands

Code: Select all

su
toor
cache-module
# or
glib-compile-schemas /usr/share/glib-2.0/schemas
and check your printer.

BTW what is model of your printer?
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

alubypass
White ninja
White ninja
Posts: 6
Joined: 12 Sep 2019, 14:01
Distribution: Porteus 4

printing.xzm does not work properly

Post#3 by alubypass » 13 Sep 2019, 14:23

I found the mistake:

In the Cups error log of the 64-bit Porteus Mate it says that cups can't find the file libpoppler.so.75. This is indeed not present on the whole system. Instead, there is a libpoppler.so.74. If I set a link from libpoppler.so.75 to libpoppler.so.74, then printing works again. In my search I found out that the error is in package 003-Mate.xzm . More exactly in poppler-0.63.0. This version is too old to provide the libpoppler.so.75.

In the 32 bit Porteus Mate version you can find the correct version here: poppler-0.64.0. It provides the correct libpoppler.so.75.

Is it possible to provide a corrected version of Porteus 4 Mate in the 64 bit version for this ?

Yours sincerely
alubypass

User avatar
Blaze
DEV Team
DEV Team
Posts: 2693
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

printing.xzm does not work properly

Post#4 by Blaze » 13 Sep 2019, 17:00

alubypass, it's call to jssouza - he is mantainer of MATE.
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

alubypass
White ninja
White ninja
Posts: 6
Joined: 12 Sep 2019, 14:01
Distribution: Porteus 4

printing.xzm does not work properly

Post#5 by alubypass » 13 Sep 2019, 17:39

Thank you so much for your help.
I sent jssouza an e-mail.

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2209
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

printing.xzm does not work properly

Post#6 by ncmprhnsbl » 14 Sep 2019, 04:24

moved this to Mate section of the forum, since it seems to be mate specific and the modules section is for posts supplying a module.
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

jssouza
DEV Team
DEV Team
Posts: 1033
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

printing.xzm does not work properly

Post#7 by jssouza » 14 Sep 2019, 05:23

Hi alubypass, thanks for your email.

It is a drawback of using a rolling slackware current as our base. When I build the DE modules, I start with Mate, then move on to Cinnamon and then to KDE. What happened here was when I built Mate, slackware current was on poppler 63 which got pulled into Mate. And when I moved on to Cinnamon, Slackware current upgraded to poppler 64. 32 bit modules were built after 64 bits, so Mate 32 has poppler 64.
We then test the DE with the base modules. The printing module was built later which would be built against the later poppler 64.

To provide you with a Mate module of Porteus 4, I would have to have the poppler 64 slackware current package. Unfortunately,
1. Slackware current has moved on and now has poppler 68
2. Just changing to poppler 64 might break atril, which was built with poppler 63.

So I would have to take the slackware current packages when Mate was built, upgrade poppler to v64, and then build the mate packages on top of it. I do not have the slackware snapshot of porteus 4 with me at the moment (I only have the porteus 5). If you could wait a month, I could be able to provide you this Mate module, once I have access to my slackware current snapshot for porteus 4.

I would also suggest you move to Porteus 5. Even though we name it an rc, imo it is as stable as Porteus 4. Mate has also been upgraded from v1.20 to v1.22.

It seems not just Mate 64, but 64 bit versions of Openbox, LXDE, LXQt, XFCE all have poppler v63 in Porteus 4.

alubypass
White ninja
White ninja
Posts: 6
Joined: 12 Sep 2019, 14:01
Distribution: Porteus 4

printing.xzm does not work properly

Post#8 by alubypass » 14 Sep 2019, 08:41

Hi jssouza,thanks for your message.
I've already thought about switching to Porteus 5. But for that I still need the German language package. Is it possible that the German language packs from Porteus 4 to Porteus 5 work for the most part ?

Is the workaround with setting a link from libpoppler.so.75 to libpoppler.so.74 okay for now or could this cause problems elsewhere?

User avatar
Blaze
DEV Team
DEV Team
Posts: 2693
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

printing.xzm does not work properly

Post#9 by Blaze » 14 Sep 2019, 09:36

alubypass,
1. Yes. But some stuff can have not a full 100% translation.
2. I think no.
Linux 5.4.0-rc7-porteus #2 SMP Tue Nov 12 17:45:45 UTC 2019 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

jssouza
DEV Team
DEV Team
Posts: 1033
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

printing.xzm does not work properly

Post#10 by jssouza » 14 Sep 2019, 09:44

Here is the complete mate locales for all languages for Porteus 5rc1.
http://www.mediafire.com/file/oz637n5lu ... s.xzm/file
md5sum: e69230845dd597c919de980531f0c96a

You can or someone can help with extracting the German language translations.

Please note that these locales are only for Mate DE (003). So no translations are present for packages from base modules (001 and 002).

alubypass
White ninja
White ninja
Posts: 6
Joined: 12 Sep 2019, 14:01
Distribution: Porteus 4

printing.xzm does not work properly

Post#11 by alubypass » 14 Sep 2019, 10:08

Thank you so much for the news.
I will download the language files and try to improve the German language packs.
From my point of view, jssouza doesn't have to provide a fix for Porteus 4 for printing. I would then switch directly to Porteus 5 x64.
I also noticed in Porteus 4 Mate that the touchpads of some Dell notebooks don't work. I test this in Porteus 5. If this also occurs there,I would contact you again.
Many thanks for the quick and uncomplicated help.

Post Reply