Porteus 5.0 RC2 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2788
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Porteus 5.0 RC2 bug reports

Post#241 by ncmprhnsbl » 12 Dec 2020, 04:13

Rava wrote:
12 Dec 2020, 04:04
an extra line only in /root/.bashrc
see my edited post above ^ about sudo su
why is this so? .. idk .. maybe sudo makes some sort of dbus connection that su doesn't?
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2788
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Porteus 5.0 RC2 bug reports

Post#242 by ncmprhnsbl » 12 Dec 2020, 06:50

and there's more :D
if you use:

Code: Select all

$ su -l
that'll work too ... because ..smthg, smthng.. login shell ;P
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#243 by Rava » 12 Dec 2020, 17:12

ncmprhnsbl wrote:
12 Dec 2020, 04:13
about sudo su
why is this so? .. idk .. maybe sudo makes some sort of dbus connection that su doesn't?
ncmprhnsbl wrote:
12 Dec 2020, 06:50
and there's more :D
if you use:

Code: Select all

$ su -l
that'll work too ... because ..smthg, smthng.. login shell ;P
And in rc1 and rc2 I have an reverse issue. I need a root script to use mpv or mpg123.

Here are the errors when trying as native root:

Code: Select all

root@porteus:/mnt/live/memory/images# mpg123 /mnt/sda2/sound/notification_-15dB.mp3 
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
	version 1.26.3; written and copyright by Michael Hipp and others
	free software (LGPL) without any warranty but with best wishes
XDG_RUNTIME_DIR (/var/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
XDG_RUNTIME_DIR (/var/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
XDG_RUNTIME_DIR (/var/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
Segmentation fault
root@porteus:/mnt/live/memory/images# mpv /mnt/sda2/sound/notification_-15dB.mp3 
 (+) Audio --aid=1 (mp3 1ch 44100Hz)
XDG_RUNTIME_DIR (/var/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
XDG_RUNTIME_DIR (/var/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused

[ao/alsa] Playback open error: Connection refused
[ao/oss] Can't open audio device /dev/dsp: No such file or directory
[ao] Failed to initialize audio driver 'oss'
Could not open/initialize audio device -> no sound.
Audio: no audio


Exiting... (Errors when loading file)
and here the errors trying as sudo -u guest:

Code: Select all

root@porteus:/mnt/live/memory/images# sudo -u guest mpg123 /mnt/sda2/sound/notification_-15dB.mp3 
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
	version 1.26.3; written and copyright by Michael Hipp and others
	free software (LGPL) without any warranty but with best wishes
Segmentation fault
root@porteus:/mnt/live/memory/images# sudo -u guest mpv /mnt/sda2/sound/notification_-15dB.mp3 
 (+) Audio --aid=1 (mp3 1ch 44100Hz)
ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused

[ao/alsa] Playback open error: Connection refused
[ao/oss] Can't open audio device /dev/dsp: No such file or directory
[ao] Failed to initialize audio driver 'oss'
Could not open/initialize audio device -> no sound.
Audio: no audio


Exiting... (Errors when loading file)
sudo -l -u guest is also no help:

Code: Select all

root@porteus:/mnt/live/memory/images# sudo -l -u guest mpv /mnt/sda2/sound/notification_-15dB.mp3 
/usr/bin/mpv /mnt/sda2/sound/notification_-15dB.mp3
root@porteus:/mnt/live/memory/images# sudo -lu guest mpg123 /mnt/sda2/sound/notification_-15dB.mp3 
/usr/bin/mpg123 /mnt/sda2/sound/notification_-15dB.mp3

Any ideas?

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#244 by Rava » 12 Dec 2020, 18:45

Another issue, took one of my several 8 GB USB sticks, but a rare one with small 2nd Linux partition for rootcopy, copied 5.0rc2 on it and my trusty kernel 5.4.30, moved stuff away from too full small ext2 partition and wanted to umount both its partitions, alas this ensued:
Image
not so helpful…

how to safely umount it without a reboot?

On the other hand, its an ext2 partition, Linux should be able to fsck the partition… without data loss. =@

After Eject anyway this happens:

Code: Select all

root@porteus:/mnt/live/memory/images# fsck /dev/sdd2
fsck from util-linux 2.36
e2fsck 1.45.6 (20-Mar-2020)
/dev/sdd2 is in use.
e2fsck: Cannot continue, aborting.


root@porteus:/mnt/live/memory/images# dx  /dev/sdd2
12.12.2020 19:45:53 ____________________________________________________________
Filesystem     Type     1M-blocks  Used Available Use% Mounted on
root@porteus:/mnt/live/memory/images# mount|grep /dev/sdd2
root@porteus:/mnt/live/memory/images# type dx
dx is a function
dx () 
{ 
    echo $(date +%d.%m.%Y\ %H:%M:%S) ____________________________________________________________;
    /bin/df -Tm $* | grep -vE 'tmpfs|/mnt/live/run|squashfs'
}
dfree and mount do not list /dev/sdd2 as mounted, while fsck insists its in use. Whut? :no:
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2788
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Porteus 5.0 RC2 bug reports

Post#245 by ncmprhnsbl » 13 Dec 2020, 00:45

Rava wrote:
12 Dec 2020, 17:12
sudo -l -u guest is also no help:
wonder why? ;)

Code: Select all

sudo -h
-----------------------------------------------
-l, --list                    list user's privileges or check a specific command;
                                use twice for longer format
--------------------------------
-i, --login                   run login shell as the target user; a command may also
                                be specified

so...

Code: Select all

# su -l guest -c "mpg123 blahblah.mp3"
.. doesn't work?
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#246 by Rava » 13 Dec 2020, 01:13

ncmprhnsbl wrote:
13 Dec 2020, 00:45
so...

Code: Select all

# su -l guest -c "mpg123 blahblah.mp3"
.. doesn't work?
sadly, nope. using another test file: once again success as guest using mpg123 or mpv:

Code: Select all

guest@porteus:~$ mpg123 /sound/CLAUDE-DEBUSSY_CLAIR-DE-LUNE.mp3 
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
	version 1.26.3; written and copyright by Michael Hipp and others
	free software (LGPL) without any warranty but with best wishes

Directory: /sound/

Terminal control enabled, press 'h' for listing of keys and functions.

Playing MPEG stream 1 of 1: CLAUDE-DEBUSSY_CLAIR-DE-LUNE.mp3 ...

MPEG 1.0 L III vbr 44100 j-s


[0:14] Decoding of CLAUDE-DEBUSSY_CLAIR-DE-LUNE.mp3 finished.
[src/libout123/modules/pulse.c:161] error: Failed to flush audio: (null)
guest@porteus:~$ mpv  /sound/CLAUDE-DEBUSSY_CLAIR-DE-LUNE.mp3 
 (+) Audio --aid=1 (mp3 2ch 44100Hz)
AO: [pulse] 44100Hz stereo 2ch float
A: 00:00:15 / 00:05:02 (5%)


Exiting... (Quit)
and failure even with your variant via root su -l guest -c :

Code: Select all

root@porteus:~# time su -l guest -c "mpg123 /sound/CLAUDE-DEBUSSY_CLAIR-DE-LUNE.mp3"
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
	version 1.26.3; written and copyright by Michael Hipp and others
	free software (LGPL) without any warranty but with best wishes

real	0m7.459s
user	0m0.156s
sys	0m0.153s
root@porteus:~# time su -l guest -c "mpv /sound/CLAUDE-DEBUSSY_CLAIR-DE-LUNE.mp3"
 (+) Audio --aid=1 (mp3 2ch 44100Hz)
ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused

[ao/alsa] Playback open error: Connection refused
[ao/oss] Can't open audio device /dev/dsp: No such file or directory
[ao] Failed to initialize audio driver 'oss'
Could not open/initialize audio device -> no sound.
Audio: no audio


Exiting... (Errors when loading file)

real	0m6.522s
user	0m0.437s
sys	0m1.583s
be aware at some time I quit the playing as guest via pressing "q" in mpg123 or mpv, and mpv even lists the time in song I did so.

I did press no keys waiting for the root via su mpg123 or mpv to play.

Since mpv is more verbose here its difference playing via pulse - or trying to:

native guest

Code: Select all

 (+) Audio --aid=1 (mp3 2ch 44100Hz)
AO: [pulse] 44100Hz stereo 2ch float
via root time su -l guest -c :

Code: Select all

 (+) Audio --aid=1 (mp3 2ch 44100Hz)
ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2788
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Porteus 5.0 RC2 bug reports

Post#247 by ncmprhnsbl » 13 Dec 2020, 01:38

pulse is a bit of special case, i guess..
funny thing: here, in openbox/sakura/dev-base for root it just works:

Code: Select all

root@porteus:~# mpg123 /mnt/sda6/Music/bitbof/bitbof-wild.mp3
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
	version 1.26.3; written and copyright by Michael Hipp and others
	free software (LGPL) without any warranty but with best wishes

Directory: /mnt/sda6/Music/bitbof/

Terminal control enabled, press 'h' for listing of keys and functions.

Playing MPEG stream 1 of 1: bitbof-wild.mp3 ...

MPEG 1.0 L III cbr128 44100 j-s

Title:   wild                            Artist: bitbof                         
Comment:                                 Album:                                 
Year:    2011                            Genre:  Unknown                        

[0:07] Decoding of bitbof-wild.mp3 finished.
[src/libout123/modules/pulse.c:161] error: Failed to flush audio: (null)
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#248 by Rava » 13 Dec 2020, 01:42

ncmprhnsbl wrote:
13 Dec 2020, 01:38
pulse is a bit of special case, i guess..
funny thing: here, in openbox/sakura/dev-base for root it just works:
I could try that, too, but what is dev-base for root?

Also how to tell mpv to be more verbose.

--msg-level=all and --msg-level=all=yes end in errors, e.g.

Code: Select all

Invalid message level 'yes'
Error parsing option msg-level (option parameter could not be parsed)
Setting commandline option --msg-level=all=yes failed.
and --msg-level=all=no is less verbose.

When

Code: Select all

 --msg-level=all=no
is valid but unhelpful, then why is

Code: Select all

--msg-level=all=yes
invalid?
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2788
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Porteus 5.0 RC2 bug reports

Post#249 by ncmprhnsbl » 13 Dec 2020, 02:14

Rava wrote:
13 Dec 2020, 01:42
I could try that, too, but what is dev-base for root?
"dev-base" is the current development version of porteus that i'm currently using/testing ;)
Rava wrote:
13 Dec 2020, 01:42
Also how to tell mpv to be more verbose.
from https://mpv.io/manual/master/#options

Code: Select all

--msg-level=<module1=level1,module2=level2,...>

    Control verbosity directly for each module. The all module changes the verbosity of all the modules. The verbosity changes from this option are applied in order from left to right, and each item can override a previous one.

    Run mpv with --msg-level=all=trace to see all messages mpv outputs. You can use the module names printed in the output (prefixed to each line in [...]) to limit the output to interesting modules.

    This also affects --log-file, and in certain cases libmpv API logging.

    Note

    Some messages are printed before the command line is parsed and are therefore not affected by --msg-level. To control these messages, you have to use the MPV_VERBOSE environment variable; see ENVIRONMENT VARIABLES for details.

    Available levels:

        no:	complete silence
        fatal:	fatal messages only
        error:	error messages
        warn:	warning messages
        info:	informational messages
        status:	status messages (default)
        v:	verbose messages
        debug:	debug messages
        trace:	very noisy debug messages

    Example

    mpv --msg-level=ao/sndio=no

    Completely silences the output of ao_sndio, which uses the log prefix [ao/sndio].

    mpv --msg-level=all=warn,ao/alsa=error

    Only show warnings or worse, and let the ao_alsa output show errors only.
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#250 by Rava » 13 Dec 2020, 08:35

ncmprhnsbl wrote:
13 Dec 2020, 02:14
"dev-base" is the current development version of porteus that i'm currently using/testing ;)
Is that available for a global forum moderator and contributor like me?
______________________________________________________

Also thanks for the info on mpv's log levels, would be nice if they put that into "mpv --list-options", also why do they have -h=string when there is no more info that way:

Code: Select all

mpv --h=msg-level
[…]
 --msg-level        Output verbosity levels (default: )
In my case, trace and debug give the very same info, and not a more helpful one as well than the standard verbosity:

Code: Select all

root@porteus:~# time sudo -u guest mpv --msg-level=all=warn,ao/alsa=trace /sound/CLAUDE-DEBUSSY_CLAIR-DE-LUNE.mp3
[ao/alsa] requested format: 44100 Hz, stereo channels, floatp
[ao/alsa] using ALSA version: 1.2.2
[ao/alsa] opening device 'default'
ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused

[ao/alsa] Playback open error: Connection refused
[ao/oss] Can't open audio device /dev/dsp: No such file or directory
[ao] Failed to initialize audio driver 'oss'
Could not open/initialize audio device -> no sound.

real	0m5.840s
user	0m0.328s
sys	0m0.134s
Really,

Code: Select all

ALSA lib pulse.c:242:(pulse_connect) PulseAudio: Unable to connect: Connection refused
is no more helpful than

Code: Select all

[ao/alsa] Playback open error: Connection refused
Added in 12 minutes 55 seconds:
but when it works for you on openbox/dev, then the issue must be somehow with either rc2 to your rc2-pre-rc3 version sans DE, or with rc2-pre-rc3 openbox vs rc2 XFCE including DE, or not?

But I would need rc2-pre-rc3 "root-dev" in both XFCE and Openbox variant to check out if there could be a hardware issue as well, I do use the Nvidia GPU driver (and an older kernel because of the NV driver, le sigh) and it could be that the driver not only handles the GPU but the Nvidia sound chip or chips as well. I would have to start up my 5.0rc2 one time with native NV GPU driver, and one time with nouveau and compare the info on the sound drivers that Porteus reports back into the running system to know for sure.

The Toshiba Satellite Notebook has both IBM and NVidia sound hardware, and that might make it even trickier for Porteus or any Linux that is not Knoppix (<- seriously, best hardware compatibility or any Linux I have ever known)
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#251 by Rava » 13 Dec 2020, 22:12

I use quote instead of code to be able to show you the output in colour.
The original /usr/local/bin/fastest-mirror gives a bold green success message even when the update failed - ran fastest-mirror as guest:
guest@porteus:~$ fastest-mirror
Checking fastest mirror ...
Testing http://ftp.vim.org/ftp/os/Linux/distr/porteus/ 1.771459
Testing http://ftp.nluug.nl/os/Linux/distr/porteus/ 0.109448
Testing http://mirrors.dotsrc.org/porteus/ 0.173137
Testing https://mirrors.dotsrc.org/porteus/ 0.344976
Testing http://ftp.cc.uoc.gr/pub/linux/porteus/ 0.384516
Testing http://www6.frugalware.org/mirrors/linux/porteus/ 0.274732
Testing http://ftp.riken.jp/Linux/porteus/ 1.170712
Testing http://www.mirrorservice.org/sites/dl.porteus.org/ 0.255198
Testing http://linux.rz.rub.de/porteus/ 0.172147
Testing http://ftpmirror1.infania.net/mirror/porteus/ 0.362317

Results:

0.109448 http://ftp.nluug.nl/os/Linux/distr/porteus/
0.172147 http://linux.rz.rub.de/porteus/
0.173137 http://mirrors.dotsrc.org/porteus/
0.255198 http://www.mirrorservice.org/sites/dl.porteus.org/
0.274732 http://www6.frugalware.org/mirrors/linux/porteus/
0.344976 https://mirrors.dotsrc.org/porteus/
0.362317 http://ftpmirror1.infania.net/mirror/porteus/
0.384516 http://ftp.cc.uoc.gr/pub/linux/porteus/
1.170712 http://ftp.riken.jp/Linux/porteus/
1.771459 http://ftp.vim.org/ftp/os/Linux/distr/porteus/

Would you like to add http://ftp.nluug.nl/os/Linux/distr/porteus/ as your main Porteus server? [y/n]
sed: couldn't open temporary file /etc/sedowQNM6: Permission denied
Porteus server updated in /etc/porteus.conf
and here the output of my script version of fastest-mirror - as guest:
guest@porteus:~$ fastest-mirror
Checking fastest mirror ...
Testing http://ftp.vim.org/ftp/os/Linux/distr/porteus/ 0.118515
Testing http://ftp.nluug.nl/os/Linux/distr/porteus/ 0.102934
Testing http://mirrors.dotsrc.org/porteus/ 0.146744
Testing https://mirrors.dotsrc.org/porteus/ 0.298653
Testing http://ftp.cc.uoc.gr/pub/linux/porteus/ 0.177627
Testing http://www6.frugalware.org/mirrors/linux/porteus/ 0.196362
Testing http://ftp.riken.jp/Linux/porteus/ 0.570592
Testing http://www.mirrorservice.org/sites/dl.porteus.org/ 0.286932
Testing http://linux.rz.rub.de/porteus/ 0.105236
Testing http://ftpmirror1.infania.net/mirror/porteus/ 0.132984

Results:

0.102934 http://ftp.nluug.nl/os/Linux/distr/porteus/
0.105236 http://linux.rz.rub.de/porteus/
0.118515 http://ftp.vim.org/ftp/os/Linux/distr/porteus/
0.132984 http://ftpmirror1.infania.net/mirror/porteus/
0.146744 http://mirrors.dotsrc.org/porteus/
0.177627 http://ftp.cc.uoc.gr/pub/linux/porteus/
0.196362 http://www6.frugalware.org/mirrors/linux/porteus/
0.286932 http://www.mirrorservice.org/sites/dl.porteus.org/
0.298653 https://mirrors.dotsrc.org/porteus/
0.570592 http://ftp.riken.jp/Linux/porteus/

Would you like to add http://ftp.nluug.nl/os/Linux/distr/porteus/ as your main Porteus server? [y/n]
sed: couldn't open temporary file /etc/sedQw7mBo: Permission denied
Couldn't update Porteus server in /etc/porteus.conf
and as root:
root@porteus:~# fastest-mirror
Checking fastest mirror ...
Testing http://ftp.vim.org/ftp/os/Linux/distr/porteus/ 0.101996
Testing http://ftp.nluug.nl/os/Linux/distr/porteus/ 0.100792
Testing http://mirrors.dotsrc.org/porteus/ 0.138080
Testing https://mirrors.dotsrc.org/porteus/ 0.260392
Testing http://ftp.cc.uoc.gr/pub/linux/porteus/ 0.156392
Testing http://www6.frugalware.org/mirrors/linux/porteus/ 0.192451
Testing http://ftp.riken.jp/Linux/porteus/ 0.894536
Testing http://www.mirrorservice.org/sites/dl.porteus.org/ 0.125348
Testing http://linux.rz.rub.de/porteus/ 0.103635
Testing http://ftpmirror1.infania.net/mirror/porteus/ 0.136431

Results:

0.100792 http://ftp.nluug.nl/os/Linux/distr/porteus/
0.101996 http://ftp.vim.org/ftp/os/Linux/distr/porteus/
0.103635 http://linux.rz.rub.de/porteus/
0.125348 http://www.mirrorservice.org/sites/dl.porteus.org/
0.136431 http://ftpmirror1.infania.net/mirror/porteus/
0.138080 http://mirrors.dotsrc.org/porteus/
0.156392 http://ftp.cc.uoc.gr/pub/linux/porteus/
0.192451 http://www6.frugalware.org/mirrors/linux/porteus/
0.260392 https://mirrors.dotsrc.org/porteus/
0.894536 http://ftp.riken.jp/Linux/porteus/

Would you like to add http://ftp.nluug.nl/os/Linux/distr/porteus/ as your main Porteus server? [y/n]
Porteus server updated in /etc/porteus.conf
And here the diff between the original and my script version:

Code: Select all

guest@porteus:~$ diff /mnt/live/memory/images/001-core.xzm/usr/local/bin/fastest-mirror /usr/local/bin/fastest-mirror 
7c7
< # Modified for Porteus by brokenman <brokenman@porteus.org>
---
> # Modified for Porteus by brokenman <brokenman@porteus.org> , updated by Rava - V2020-12-13
61c61,65
< 	green "Porteus server updated in /etc/porteus.conf"
---
> 	if [ $? -eq 0 ] ; then
> 		green "Porteus server updated in /etc/porteus.conf"
> 	else
> 		red "Couldn't update Porteus server in /etc/porteus.conf"
> 	fi
HTH!

Here the complete script code for the ones unaware how to apply changes via diff:

Code: Select all

#!/bin/bash

# mirror_test.sh
# This script tests a list of porteus mirrors for speed
#
# AUTHOR: Lance Rushing <lance_rushing@hotmail.com>
# Modified for Porteus by brokenman <brokenman@porteus.org> , updated by Rava - V2020-12-13
# This script is covered under the GNU Public License: http://www.gnu.org/licenses/gpl.txt

. /usr/share/porteus/porteus-functions
get_colors

## Vars
DUMP=/tmp/.fmr.tmp


## Trap ctrl C exits
cutandrun(){
[ -e $DUMP ] && rm $DUMP
exit
}
trap cutandrun SIGHUP SIGINT SIGTERM

is_online_url http://porteus.org/porteus-mirrors.txt || { red "The porteus server appears to be offline."; exit; }

## get list
MIRRORS=$(curl -s http://porteus.org/porteus-mirrors.txt)

## Number of seconds before the test is considered a failure
TIMEOUT="4"

## Sting to store results in
RESULTS=""

echo "Checking fastest mirror ..."
for MIRROR in $MIRRORS ; do
	
	echo -n "Testing ${MIRROR} "
	
	URL="${MIRROR}%{FILE}"
	
	TIME=`curl --max-time $TIMEOUT --silent --output /dev/null --write-out %{time_total} $URL`
	
	if [ "$TIME" == "0.000" ] ; then
		echo "Fail";
	else 
		echo $TIME
		RESULTS="${RESULTS}${TIME}\t${MIRROR}\n";
	fi

done;

echo -e "\nResults:"
echo -e $RESULTS | sort -n | tee $DUMP
FMIR=`sed '/^$/d' $DUMP | head -n1 | awk '{print$2}'`

echo
read -p "`gettext " Would you like to add $FMIR as your main Porteus server? [y/n]"`" -n 1 -r -s && echo
if [[ $REPLY =~ ^[Yy]$ ]]; then
	sed -i 's@^SERVER=.*@SERVER='$FMIR'@g' /etc/porteus.conf
	if [ $? -eq 0 ] ; then
		green "Porteus server updated in /etc/porteus.conf"
	else
		red "Couldn't update Porteus server in /etc/porteus.conf"
	fi
fi
cutandrun
and finally the md5sums of the original and my version:

Code: Select all

ccbeb81d5a185a22ecde9e2377374f4e  /mnt/live/memory/images/001-core.xzm/usr/local/bin/fastest-mirror
f3bc9ea2eda198724a58d3b51dc8eccb  /usr/local/bin/fastest-mirror
:magic:
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 5884
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 & 5.0rc2 Cinnamon 64 ISOs
Location: Western NY, USA

Porteus 5.0 RC2 bug reports

Post#252 by Ed_P » 16 Dec 2020, 02:47

vncviewer in tightvnc-1.3.10-x86_64-1_slonly.xzm produces:

Code: Select all

guest@porteus:~$ vncviewer
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
and a small serverDialog window with a blank VNC server: box.

In Porteus 4.0 I get:

Code: Select all

guest@porteus:~$ vncviewer
vncviewer: ConnectToTcpAddr: connect: Connection refused
Unable to connect to VNC server
guest@porteus:~$ 
and a small serverDialog window with a blank VNC server: box.

-update-

and in both systems when the vncserver is up I connect. :good:
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#253 by Rava » 16 Dec 2020, 12:38

GIMP 2.10.8 that ran without issue in 5.0rc2 is now getting a segfault:

Code: Select all

GNU Image Manipulation Program version 2.10.8
git-describe: GIMP_2_10_6-294-ga967e8d2c2
C compiler:
	Reading specs from /usr/lib64/gcc/x86_64-slackware-linux/8.2.0/specs
	COLLECT_GCC=/usr/bin/gcc
	COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-slackware-linux/8.2.0/lto-wrapper
	Target: x86_64-slackware-linux
	Configured with: ../gcc-8.2.0/configure --prefix=/usr --libdir=/usr/lib64 --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,brig,c,c++,fortran,go,lto,objc --enable-threads=posix --enable-checking=release --enable-objc-gc --with-system-zlib --enable-libstdcxx-dual-abi --with-default-libstdcxx-abi=new --disable-libstdcxx-pch --disable-libunwind-exceptions --enable-__cxa_atexit --disable-libssp --enable-gnu-unique-object --enable-plugin --enable-lto --disable-install-libiberty --disable-werror --with-gnu-ld --verbose --with-arch-directory=amd64 --disable-gtktest --disable-multilib --target=x86_64-slackware-linux --build=x86_64-slackware-linux --host=x86_64-slackware-linux
	Thread model: posix
	gcc version 8.2.0 (GCC) 
	
using GEGL version 0.4.12 (compiled against version 0.4.12)
using GLib version 2.64.4 (compiled against version 2.56.2)
using GdkPixbuf version 2.40.0 (compiled against version 2.36.12)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.42.4 (compiled against version 1.42.4)
using Fontconfig version 2.13.92 (compiled against version 2.13.1)
using Cairo version 1.16.0 (compiled against version 1.16.0)

```
> fatal error: Segmentation fault

Stack trace:
```
/usr/lib64/libgimpbase-2.0.so.0(gimp_stack_trace_print+0x376)[0x7f77b4a59786]
gimp[0x4aa38c]
gimp(gimp_fatal_error+0x17)[0x4aa7c7]
gimp[0x4aaf16]
/lib64/libc.so.6(+0x41ddf)[0x7f77b36c6ddf]
gimp(gimp_param_spec_layer_id+0x6b)[0x7ffb0b]
gimp(gimp_pdb_compat_param_spec+0x1ec)[0x72750c]
gimp(gimp_plug_in_handle_message+0x1196)[0x733b26]
gimp(gimp_plug_in_manager_call_query+0x180)[0x741da0]
gimp(gimp_plug_in_manager_restore+0x777)[0x739fe7]
gimp[0x756e4c]
/usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0x1a1)[0x7f77b3bcdd81]
/usr/lib64/libgobject-2.0.so.0(+0x26b55)[0x7f77b3bdfb55]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0xc0a)[0x7f77b3beaf7a]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x81)[0x7f77b3beb8c1]
gimp(gimp_restore+0xfc)[0x7563ec]
gimp(app_run+0x46a)[0x4a9d2a]
gimp(main+0x384)[0x4a94e4]
/lib64/libc.so.6(__libc_start_main+0xea)[0x7f77b36a8e5a]
gimp(_start+0x29)[0x4a9659]
All dependencies seem to be met:

Code: Select all

guest@porteus:/mnt/live/memory/images$ ldd /usr/bin/gimp-2.10|grep not
guest@porteus:/mnt/live/memory/images$ 
Any ideas?

Added in 7 minutes 54 seconds:
Update
The non-stripped newer version of GIMP - gimp-2.10.10-x86_64-1_sam.pack.xzm - 52.91 MB - also crashes with a segfault:

Code: Select all

GNU Image Manipulation Program version 2.10.10
git-describe: GIMP_2_10_8-775-g596f855749
C compiler:
	Using built-in specs.
	COLLECT_GCC=gcc
	COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/8/lto-wrapper
	OFFLOAD_TARGET_NAMES=nvptx-none
	OFFLOAD_TARGET_DEFAULT=1
	Target: x86_64-redhat-linux
	Configured with: ../configure --enable-bootstrap --enable-languages=c,c++,fortran,objc,obj-c++,ada,go,lto --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-shared --enable-threads=posix --enable-checking=release --enable-multilib --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-gcc-major-version-only --with-linker-hash-style=gnu --enable-plugin --enable-initfini-array --with-isl --enable-libmpx --enable-offload-targets=nvptx-none --without-cuda-driver --enable-gnu-indirect-function --enable-cet --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
	Thread model: posix
	gcc version 8.3.1 20190223 (Red Hat 8.3.1-2) (GCC) 
	
using GEGL version 0.4.14 (compiled against version 0.4.14)
using GLib version 2.64.4 (compiled against version 2.58.3)
using GdkPixbuf version 2.40.0 (compiled against version 2.38.1)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.42.4 (compiled against version 1.42.3)
using Fontconfig version 2.13.92 (compiled against version 2.13.1)
using Cairo version 1.16.0 (compiled against version 1.16.0)

```
> fatal error: Segmentation fault

Stack trace:
```
/usr/lib64/libgimpbase-2.0.so.0(gimp_stack_trace_print+0x3a6)[0x7fc8008df846]
gimp(+0xe1bbf)[0x55d09962abbf]
gimp(gimp_fatal_error+0x1d)[0x55d09962affd]
gimp(+0xe277c)[0x55d09962b77c]
/lib64/libc.so.6(+0x41ddf)[0x7fc7ff92addf]
gimp(gimp_param_spec_layer_id+0x6f)[0x55d0999ad8df]
gimp(gimp_pdb_compat_param_spec+0x1ec)[0x55d0998c6ffc]
gimp(gimp_plug_in_handle_message+0x11a6)[0x55d0998d3aa6]
gimp(gimp_plug_in_manager_call_query+0x1a0)[0x55d0998e2140]
gimp(gimp_plug_in_manager_restore+0x787)[0x55d0998da0d7]
gimp(+0x3af080)[0x55d0998f8080]
/usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0x1a1)[0x7fc7ffe31d81]
/usr/lib64/libgobject-2.0.so.0(+0x26b55)[0x7fc7ffe43b55]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0xc0a)[0x7fc7ffe4ef7a]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x81)[0x7fc7ffe4f8c1]
gimp(gimp_restore+0x100)[0x55d0998f75c0]
gimp(app_run+0x4a2)[0x55d09962a512]
gimp(main+0x395)[0x55d099629cb5]
/lib64/libc.so.6(__libc_start_main+0xea)[0x7fc7ff90ce5a]
gimp(_start+0x2d)[0x55d099629e3d]
Same as above, all dependencies are met:

Code: Select all

root@porteus:/usr/lib64# ldd /usr/bin/gimp-2.10 |grep not
root@porteus:/usr/lib64# 
Cheers!
Yours Rava

User avatar
Rava
Contributor
Contributor
Posts: 2853
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 x86-64 XFCe
Location: Forests of Germany

Porteus 5.0 RC2 bug reports

Post#254 by Rava » 19 Dec 2020, 05:37

ncmprhnsbl, any yet another browser-update bug:

palemoon.org changed the name of the most recent Palemoon to palemoon-28.17.0.linux-x86_64-gtk2.tar.xz and partly browser-update gets it, in the end it failed.
See for yourself:

Code: Select all

root@porteus:/mnt/ext3/Porteus_modules/5.0/palemoon# update-browser -d -p
 Starting checks ... 
[OK] User is root.
[OK] Distro is Porteus
Downloading live script ...
Downloading: update-palemoon-live  DONE
Work will be done in: /mnt/ext3/Porteus_modules/5.0/palemoon 
 Checking if palemoon is installed ... 
[OK] palemoon is installed
[OK] installed palemoon version:  28.16.0 

 A palemoon tarball was found in /mnt/ext3/Porteus_modules/5.0/palemoon 
 We will use this archive to create palemoon.

Choose the palemoon file you want to process.


1) palemoon-28.16.0.linux-x86_64.tar.xz
2) palemoon-28.17.0.linux-x86_64-gtk2.tar.xz
#? 2
CHOICE:palemoon-28.17.0.linux-x86_64-gtk2.tar.xz
 Checking for Porteus ... 
[PASS] Distro is Porteus
Getting latest version ...
Checking http://ftp.nluug.nl/os/Linux/distr/porteus//x86_64/current/modules
 Set your home page. 
 Leave blank for: https://forum.porteus.org and press Enter to continue.
> 
[PASS] Homepage is available

Choose a locale from the list.

1) bg	    5) en-GB   9) es-MX	 13) ko	    17) ru     21) tr
2) cs	    6) en-US  10) fr	 14) pl	    18) sk     22) uk
3) de	    7) es-AR  11) hu	 15) pt-BR  19) sv-SE  23) vi
4) el	    8) es-ES  12) it	 16) pt-PT  20) tl     24) zh-CN
#? 5
 en-GB locale chosen 
Downloading: palemoon-28.17.0.linux-x86_64.tar.xz  DONE
Fetching language pack..
 Done.

[ERROR] File palemoon-28.17.0.linux-x86_64.tar.xz not found

Code: Select all

Downloading: palemoon-28.17.0.linux-x86_64.tar.xz  DONE
There is no such file downloaded into /mnt/ext3/Porteus_modules/5.0/palemoon
Also, why downloading when the local file palemoon-28.17.0.linux-x86_64-gtk2.tar.xz should be the one being processed.
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 2788
Joined: 20 Mar 2012, 03:42
Distribution: 5.0rc1-64bit all-DE+more
Location: australia
Contact:

Porteus 5.0 RC2 bug reports

Post#255 by ncmprhnsbl » 19 Dec 2020, 06:01

Rava wrote:
19 Dec 2020, 05:37
ncmprhnsbl, any yet another browser-update bug:
already fixed on the server ;) .. with mirrors to sync when they do..
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

Post Reply