Page 3 of 9

Porteus v5.0rc1 problems

Posted: 19 Jun 2019, 01:32
by nanZor
Thanks for looking into this stuff guys - and even though I'm not running an ssd (yet), those notes AcnapyxoB absolutely rock! That went straight into the Porteus notebook. Now I feel confident enough to get one.

Live-USB tool - I absolutely love that utility, so that's why I cried when it threw up the Illegal Iso error on the rc. I have various ways of burning Porteus iso's, but to have those cool built-in tools means a lot to me - that is, a serious way for Porteus to be self-supporting (aka "eating your own dog food" - in a good way). BIG kudos for that and all the things that make Porteus a stand-out in the world of small distros...

Porteus v5.0rc1 problems

Posted: 19 Jun 2019, 02:27
by nanZor
Sluggish Mount detective work ...

Aha! It seems that the sluggish filesystem mounts of up to 20 seconds on my XFCE4 RC1 may be due to permissions.

When I boot up with the noauto cheatcode, the system comes right up - bang!

HOWEVER, if I try to immediately mount one of the filesystems by right clicking one of the filesystem icons, I get yelled at for having the wrong permissions.

If I wait another 20 seconds, I *can* then mount the partitions with no permission problems.

Porteus v5.0rc1 problems

Posted: 19 Jun 2019, 03:50
by fulalas
jssouza wrote:
19 Jun 2019, 01:02
Yes, haveged might be a good workaround if low entropy is the reason. Thanks AcnapyxoB.
I tried, but it didn't change anything :(

Porteus v5.0rc1 problems

Posted: 19 Jun 2019, 23:18
by nanZor
USM segmentation fault:

XFCE4:
Trying to USM > Update > Update All >

From the gui ends with a segmentation fault. It seems to go normally at first, checking files, optimizing manifest and so forth. But what is seen is before it segfaults, it is as if someone is rapidly hitting a return/enter key (no, not me!).

The blinking white cursor trails down to the bottom left edge, sits there for a time, and then segfaults.

----------------

Commandline attempt as root with

usm -u all

finishes up just fine.


Problem: Despite the updates, attempts to download and install packages always results in:
"Please wait 6 hours for next database udate - failure to find LIBS.TXT"
"Fatal error LIBS.TXT"

Porteus v5.0rc1 problems

Posted: 20 Jun 2019, 00:11
by Rava
Where do I find md5sum info?
Especially for the files in these folders:
http://dl.porteus.org/x86_64/Porteus-v5.0/kernel/
http://dl.porteus.org/x86_64/Porteus-v5.0/modules/

Porteus v5.0rc1 problems

Posted: 20 Jun 2019, 02:22
by nanZor
Missing Dependencies

I ran usm -d

and it reported that I was missing 31 dependencies. I'm assuming some like Python 2.7 are just flukes since we've transitioned to 3 etc etc :

Code: Select all

Missing dependencies:  31

libcdio.so.18
libcelt0.so.2
libclangAST.so.8
libclangAnalysis.so.8
libclangBasic.so.8
libclangCodeGen.so.8
libclangDriver.so.8
libclangEdit.so.8
libclangFrontend.so.8
libclangFrontendTool.so.8
libclangLex.so.8
libclangParse.so.8
libclangSema.so.8
libclangSerialization.so.8
libfluidsynth.so.1
libgc.so.1
libgd.so.3
libgdk-1.2.so.0
libgladeui-1.so.11
libglib-1.2.so.0
libgmodule-1.2.so.0
libgsf-1.so.114
libgstreamer-1.0.so.0
libgsttag-1.0.so.0
libgtk-1.2.so.0
libmariadb.so.3
libopusfile.so.0
libpython2.7.so.1.0
libtk8.6.so
libvamp-sdk.so.2
libxmms.so.1
Yeah, I'm not going to try and install all those, but wonder if any are vital?

Porteus v5.0rc1 problems

Posted: 21 Jun 2019, 07:07
by jssouza
fulalas wrote:
19 Jun 2019, 03:50
jssouza wrote:
19 Jun 2019, 01:02
Yes, haveged might be a good workaround if low entropy is the reason. Thanks AcnapyxoB.
I tried, but it didn't change anything :(
Oh.. Back to square one :(

Porteus v5.0rc1 problems

Posted: 22 Jun 2019, 00:45
by joe nar quo
I have problem with google chrome, when I write an email (I use gmail and hotmail) and then I try to upload attachment, it suddenly closed. Please help ( I use mate desktop).

Porteus v5.0rc1 problems

Posted: 22 Jun 2019, 05:22
by Ed_P
Hello joe.

Did you have these chrome problems with version 4.0 of Porteus

Porteus v5.0rc1 problems

Posted: 22 Jun 2019, 07:28
by raja
I find ISO file , downloaded earlier was corrupt. Downloaded base modules core,xorg and open box, used neko´s Kernel without AER for pcie , Palemoon & old initrd from v4.0-rc3.

10 seconds to desktop. Clean boot.

Noticed some new errors in syslog. details later.

SpaceFM ,not perfect still.

jssouza, can you please try ztd compression with suitable changes to initrd and release a trail ISO? something new to relish!

Porteus v5.0rc1 problems

Posted: 22 Jun 2019, 11:43
by jssouza
raja wrote:
22 Jun 2019, 07:28
jssouza, can you please try ztd compression with suitable changes to initrd and release a trail ISO? something new to relish!
Here you go:
Porteus with zstd compression

Porteus v5.0rc1 problems

Posted: 24 Jun 2019, 13:39
by joe nar quo
Ed_P wrote:
22 Jun 2019, 05:22
Hello joe.

Did you have these chrome problems with version 4.0 of Porteus
Hi Ed,
Before I use Porteus 3.2.2 on my old laptop and have no problem. Now I try to use Porteus 5.0 on my new laptop Acer Aspire 3 A315-41-R3LC AMD Ryzen 3 and I got this problem.

Porteus v5.0rc1 problems

Posted: 25 Jun 2019, 06:26
by jssouza
Hi joe nar quo,

Try running chrome from a terminal. It might dump some error message on the terminal when it closes.

Porteus v5.0rc1 problems

Posted: 26 Jun 2019, 06:23
by joe nar quo
jssouza wrote:
25 Jun 2019, 06:26
Hi joe nar quo,

Try running chrome from a terminal. It might dump some error message on the terminal when it closes.
Hi Ed,
Here is error message when I run from terminal:

Code: Select all

guest@porteus:~$ google-chrome-stable
[3773:3773:0626/124739.380038:ERROR:browser_dm_token_storage_linux.cc(101)] Error: /etc/machine-id contains 0 characters (32 were expected).
[3808:3808:0626/124739.732827:ERROR:sandbox_linux.cc(368)] InitializeSandbox() called with multiple threads in process gpu-process.
[3808:3808:0626/124740.048184:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command

(engrampa:4191): GLib-GIO-ERROR **: 12:49:34.007: Settings schema 'org.gtk.Settings.FileChooser' does not contain a key named 'startup-mode'

(google-chrome-stable:3773): GLib-GIO-ERROR **: 13:15:06.433: Settings schema 'org.gtk.Settings.FileChooser' does not contain a key named 'startup-mode'
Trace/breakpoint trap

Porteus v5.0rc1 problems

Posted: 27 Jun 2019, 02:28
by fulalas
@nanZor, in order to fix the black screen issue, please try this module (put it inside porteus/base): https://www.mediafire.com/file/gbd3r5c5 ... 2.xzm/file

Let us know if it solves your problem :)