Porteus v5.0rc1 problems

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
chromer
White ninja
White ninja
Posts: 15
Joined: 13 Jan 2019, 18:00
Distribution: APorteus , Porteus 5
Location: Turkey

Porteus v5.0rc1 problems

Post#61 by chromer » 19 Jul 2019, 17:43

due to lack of libgtop on Porteus 5 rc1 Cinnamon , some of applets and desklets not loading and not working...( like : CPU monitor or Memory Monitor applet ).
On Porteus 4 and Aporteus this library is natively present and no problem.

jssouza
DEV Team
DEV Team
Posts: 1008
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Porteus v5.0rc1 problems

Post#62 by jssouza » 19 Jul 2019, 18:01

chromer wrote:
19 Jul 2019, 17:43
due to lack of libgtop on Porteus 5 rc1 Cinnamon , some of applets and desklets not loading and not working...( like : CPU monitor or Memory Monitor applet ).
chromer, thanks. I'll add it back in the next release.

User avatar
Ed_P
Contributor
Contributor
Posts: 5035
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus v5.0rc1 problems

Post#63 by Ed_P » 19 Jul 2019, 21:40

There are TWO Browser Selection and Update Tool items in the menu.

Code: Select all

guest@porteus:~$ ls /usr/share/applications/*browsers*
/usr/share/applications/browsers.desktop*
/usr/share/applications/gtk-update-browsers.desktop*
guest@porteus:~$ 
Ed

fulalas
DEV Team
DEV Team
Posts: 1426
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus v5.0rc1 problems

Post#64 by fulalas » 20 Jul 2019, 01:37

Ed_P wrote:
19 Jul 2019, 21:40
There are TWO Browser Selection and Update Tool items in the menu.
See here:
ncmprhnsbl wrote: we only need two:
browser.desktop which is overwritten when a browser in activated
and one of the other two(since their contents are identical)(probably gtk-update-browsers.desktop to avoid future confusion)

fulalas
DEV Team
DEV Team
Posts: 1426
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus v5.0rc1 problems

Post#65 by fulalas » 20 Jul 2019, 01:58

As Blaze has pointed out, Slack current has finally updated ffmpeg package. So I decided to include it in our current xorg and try an experiment with new mpv.

Here are the changes:
1- ffmpeg updated to 4.1.4 (Slack current)
2- mpv updated to 0.29.1 (built with Slackbuild)
3- changed mpv.desktop command call to:

Code: Select all

mpv --player-operation-mode=pseudo-gui --hwdec=auto --video-sync=display-resample --no-osd-bar --audio-file-auto=fuzzy -- %U
As you can see, hwdec flag is now set to auto. So now we can provide hardware video decode acceleration out of the box to almost all users. I tested on both Intel video card and Nvidia video card (with official drivers) machines and it worked nice! However, users with Nvidia cards that are using Nouveau drivers (Mesa) still need to export a system variable (more here) -- I don't have a decent solution for this right now, so I accept suggestions. And, of course, since I don't have an AMD videocard, I can't test it.

Please, report your results: press i when watching videos like this and check if hwdec (hardware decode) is enabled and if performance is acceptable (low CPU usage is a good sign) :)

https://www.mediafire.com/file/ib29qfqq ... -rc1.1.xzm
(91 MB)

P.S.: when using this updated xorg module you'll notice that video thumbnails will not appear anymore, so I recommend updating ffmpegthumbnailer here.

User avatar
Ed_P
Contributor
Contributor
Posts: 5035
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus v5.0rc1 problems

Post#66 by Ed_P » 20 Jul 2019, 04:33

fulalas wrote:
20 Jul 2019, 01:37
See here:
ncmprhnsbl wrote: browser.desktop which is overwritten when a browser in activated
A browser is active and being used to post this and the menu still has 2 browser entries.

Code: Select all

guest@porteus:~$ ls /mnt/live/memory/images/f*
/mnt/live/memory/images/firefox-60.7.2esr-x86_64-en-US-1.xzm:
usr/  var/

/mnt/live/memory/images/flashplayer-plugin-32.0.0.223-x86_64-1.xzm:
license.pdf  usr/  var/
guest@porteus:~$guest@porteus:~$ ls /usr/share/applications/*browsers*
/usr/share/applications/browsers.desktop*
/usr/share/applications/gtk-update-browsers.desktop*
guest@porteus:~$ 
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Porteus v5.0rc1 problems

Post#67 by Rava » 20 Jul 2019, 20:11

fulalas wrote:
20 Jul 2019, 01:58
As you can see, hwdec flag is now set to auto.
Since I seem to be a bit slow getting all this hardware acceleration and official Nvidia drivers right - my question:
does one need to export the vdpau variable to have vdpau hardware acceperation e.g. does the user have to do a
Rava wrote:
17 Jul 2019, 16:51
guest@porteus:/$ export VDPAU_DRIVER="nvidia"
like discussed in Porteus 5 + Nvidia official driver = no hardware acceleration on Mpv ?
Or will the newest DEs do that for the user by themselves?

Or can it not be done by the DE but e.g. must be part of the Nvidia driver module?
Cheers!
Yours Rava

fulalas
DEV Team
DEV Team
Posts: 1426
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus v5.0rc1 problems

Post#68 by fulalas » 21 Jul 2019, 05:24

@Rava, the idea is to set everything in xorg module so users don't have to do anything. The exception is when using Nvidia official drivers, because in this case the driver module will need to export the variable -- which is already happening with the update I suggested here.

raja
Shogun
Shogun
Posts: 213
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v5.0-rc1-zstd-64
Location: Chennai,India

Porteus v5.0rc1 problems

Post#69 by raja » 21 Jul 2019, 09:49

fulalas with your new module...

Intel(R) Core(TM) i3-7100U CPU @ 2.40GHz
CPU usage: 12-15%

Code: Select all

mpv --vo=opengl --hwdec=vaapi /mnt/sda6/Downloads/bbb_sunflower_2160p_60fps_normal.mp4

Driver 'opengl' has been replaced with 'gpu'!
Playing: /mnt/sda6/Downloads/bbb_sunflower_2160p_60fps_normal.mp4
 (+) Video --vid=1 (*) (h264 3840x2160 60.000fps)
 (+) Audio --aid=1 (*) (mp3 2ch 48000Hz)
     Audio --aid=2 (*) (ac3 6ch 48000Hz)
File tags:
 Artist: Blender Foundation 2008, Janus Bager Kristensen 2013
 Comment: Creative Commons Attribution 3.0 - http://bbb3d.renderfarming.net
 Composer: Sacha Goedegebure
 Genre: Animation
 Title: Big Buck Bunny, Sunflower version
[vo/opengl/vaapi-egl] vaAcquireSurfaceHandle() failed (invalid VASurfaceID)
Using hardware decoding (vaapi).
VO: [gpu] 3840x2160 vaapi[nv12]
AO: [pulse] 48000Hz stereo 2ch float
AV: 00:01:35 / 00:10:34 (15%) A-V:  0.000
:good:
Linux Kernel-4.4.120-32 bit; Linux kernel-5.2-64 bit.

fulalas
DEV Team
DEV Team
Posts: 1426
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus v5.0rc1 problems

Post#70 by fulalas » 21 Jul 2019, 12:14

@raja, why are using this command line instead of the one I recommended above? :)

raja
Shogun
Shogun
Posts: 213
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v5.0-rc1-zstd-64
Location: Chennai,India

Porteus v5.0rc1 problems

Post#71 by raja » 21 Jul 2019, 18:27

No reason.

Whenever I use Netsurf, I use this command to watch videos from the net . VO will show yuv420p if I don't use vaapi. Just a habit.
Linux Kernel-4.4.120-32 bit; Linux kernel-5.2-64 bit.

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Porteus v5.0rc1 problems

Post#72 by Rava » 21 Jul 2019, 19:41

fulalas wrote:
21 Jul 2019, 05:24
which is already happening with the update I suggested here.
At least I get directed to the very first post of [HOWTO] make a xzm module driver for NVIDIA video card - can you please point out which post exactly you referring to?
Cheers!
Yours Rava

fulalas
DEV Team
DEV Team
Posts: 1426
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus v5.0rc1 problems

Post#73 by fulalas » 22 Jul 2019, 00:11

@raja, it would be great if you could test the command line I suggested because it uses an autodetect flag. :)

@Rava, I'm referring to the script that creates the driver module. Read the first post of that topic carefully.

raja
Shogun
Shogun
Posts: 213
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v5.0-rc1-zstd-64
Location: Chennai,India

Porteus v5.0rc1 problems

Post#74 by raja » 22 Jul 2019, 11:09

hwdec, auto selected to vaapi, with your command line. CPU usage more or less same or slightly lower.

Even double clicking to play video, MPV, auto selects vaapi and plays without any lag, with your new xorg module. In Porteus 4.0 this video crawls.
Linux Kernel-4.4.120-32 bit; Linux kernel-5.2-64 bit.

User avatar
Rava
Contributor
Contributor
Posts: 2252
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 4.0 x86-64 XFCe
Location: Forests of Germany

Porteus v5.0rc1 problems

Post#75 by Rava » 22 Jul 2019, 13:39

fulalas wrote:
22 Jul 2019, 00:11
@Rava, I'm referring to the script that creates the driver module.
Okay, thanks for the info.
fulalas wrote:
22 Jul 2019, 00:11
Read the first post of that topic carefully.
I am the author of that post, since I was the one to translate the instructions from Blaze original Russian post (with lots of help by automated translation software, since I do not speak Russian)

So, yes, I do know the script. :)
Cheers!
Yours Rava

Post Reply