Page 1 of 1

[Solved] touchpad vertical scrolling

Posted: 31 Dec 2010, 05:31
by fanthom
I have tried many configurations by adjusting /etc/X11/xorg.conf, /etc/X11/xorg.conf.d/50-synaptic.conf,
trying different x11-input-synaptics drivers and still no joy :bad:

if anybody knows the solution, please post it here.

Re: touchpad vertical scrolling

Posted: 10 Jan 2011, 19:48
by Ahau
Here are some relevant threads that I've found: ... nt-849714/ ... op-675065/

The problem appears to be that your system is recognizing your touchpad as a standard mouse, rather than a SynPS/2 device (or it recognizes it as SynPS/2 and then changes it to standard mouse).

Check this with cat /proc/bus/input/devices. My system came up with a standard mouse.

Temporary work around:

Code: Select all

rmmod psmouse
modprobe psmouse proto=auto
Apparently you can add those lines to the end of your /etc/rc.d/rc.local (see first thread), though I haven't tested it. There's more info in those threads, and this does not appear to be the only way to fix it.



Re: touchpad vertical scrolling

Posted: 10 Jan 2011, 19:56
by fanthom
you can also edit /etc/modprobe.d/psmouse.conf and change:
'options psmouse proto=imps'
'options psmouse proto=auto'

should do the job :)

Thanks Ahau - [Solved]