Page 1 of 1

Version 4.0 questions

Posted: 30 Apr 2018, 14:19
by sci_fi
Version 4.0 questions

I am currently running Porteus Version 3.2.2 LXDE and XFCE 64 bit always fresh on a Dell 6330 laptop.

When I attempt to run version 4.0 LXDE 64 bit I have the following problems:

1. Wireless simply does not work. The "wpa_supplicant" command is not found. No networks are found.
I downloaded "wpa_supplicant" via USM and loaded it but still no luck with wireless.

2. Pulseaudio appears to not be included in the the 4.0 release.
I downloaded the pulseaudio module and attempted to use it with version 4.0 but this did not help.
I have similar issues with version 4.0 XFCE 64 bit.

Any suggestions will be much appreciated.

Thank you and best regards,


Version 4.0 questions

Posted: 30 Apr 2018, 16:32
by brokenman
Something is certainly wrong with your install. wpa_supplicant and pulseaudio are both included in the ISO. Can you explain your setup a little more?

Version 4.0 questions

Posted: 30 Apr 2018, 21:31
by fulalas
This usually happens when we mix old kernel with new kernel -- in your case Porteus 3.22 version with Porteus 4.0 version. During the update to Porteus 4, did you remember to update the boot folder in your USB stick?

Version 4.0 questions

Posted: 01 May 2018, 09:46
by sci_fi
@brokenman, fulalas
My apologies for the slow response. I wanted to experiment a bit more before responding.
fulalas, I double checked that the boot folder is from version 4.0. No change in performance.

Results of my experiments are interesting:

The good news:

I realize now that while pulseaudio is included in 4.0, the pavucontrol module is not. When I added the pavucontol module my pulseaudio problems went away. Great.

I did some wireless testing on a second notebook PC. This one is a Dell 6230 (rather than 6330). Wireless on 4.0 works out of the box on the 6230. This was using the same usb stick that fails on the 6330.
An interesting note on this, however. When I look at "wireless" in the "Network" section of "Porteus System Information", it is blank. No information at all. Yet wireless works fine. This is for the 6230.

The bad news:
Back to the Dell 6330. On this notebook, wireless does not work at all. No wireless networks are detected. Like the wireless card is not present. However, on this notebook, Porteus System Info says my wireless is:
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
Subsystem: Dell Device 0015
This PC's wireless works fine on version 3.2.2

Since the same USB stick wireless works perfectly with the dell 6230 but not at all with the 6330, I am stuck.
Possibly the driver for this wireless card was omitted from 4.0 or is corrupted.

Any ideas?

As always, thank you for your help.


Version 4.0 questions

Posted: 01 May 2018, 22:57
by cchuang
It might be concered with the lack of module, b43, for boardcom wifi chip; I also had this problem. It had been solved by installing b43 module by

export FIRMWARE_INSTALL_DIR="/lib/firmware"
b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" broadcom-wl-5.100.138/linux/wl_apsta.o
b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" broadcom-wl-
b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta-

and load b43 module.

Version 4.0 questions

Posted: 02 May 2018, 16:51
by sci_fi
Thank you, cchuang. I will give it a try.

Also, I have found a workaround for this particular PC. As follows:

Use rootcopy to delete the contents of the following

Also used rootcopy to delete the /lib/modprobe.d/bcm43xx.conf file

This may be overkill but it allowed wireless to work properly on this PC. Hurrah

Thanks to everyone for your help.

Best regards,


Version 4.0 questions

Posted: 12 May 2018, 09:31
by Blaze
Hi sci_fi.

Can you try this variant:

1) Download b43-firmware-classic-5.100.138-1-noarch.xzm and copy to modules folder of Porteus.
2) Run in terminal these commands

Code: Select all

echo 'blacklist wl' > /etc/modprobe.d/broadcom_blacklist.conf
echo 'blacklist wl' > /etc/modprobe.d/b43_blacklist.conf
3) After reboot open terminal and check

Code: Select all

dmesg | grep -i b43
modprobe b43
and try your wifi connection.


Version 4.0 questions

Posted: 13 May 2018, 18:03
by sci_fi
Hello Blaze,

Thank you for your suggestions. They work like a charm. I have incorporated them and things are working great.

Much appreciated as always.

Best regards,


Version 4.0 questions

Posted: 22 Jul 2018, 01:00
by rchase
Blaze, I managed to find your solution for old Broadcom wi-fi, but it needs to be made official. Why canĀ“t Porteus detect this old hardware and use the appropriate driver? Failing that, your instructions and module need to be made part of the official documentation, not left for people to search out in the forums! Thanks!

Version 4.0 questions

Posted: 22 Jul 2018, 10:23
by Blaze
Hi rchase.

As said fanthom
As you probably know, Broadcom wifi chipsets are the most problematic in the linux world.
[HOWTO] Broadcom wifi under Porteus
Two reverse-engineered open-source drivers are built-in to the kernel: b43 and b43legacy. b43 supports most newer Broadcom chipsets, while the b43legacy driver only supports the early BCM4301 and BCM4306 rev.2 chipsets. To avoid erroneous detection of your WiFi card's chipset, blacklist the unused driver.

Both of these drivers require non-free firmware to function. Install b43-firmware, b43-firmware-classic or b43-firmware-legacy from the AUR.

  • BCM4306 rev.3, BCM4311, BCM4312 and BCM4318 rev.2 have been noticed to experience problems with b43-firmware. Use b43-firmware-classic for these cards instead.
  • BCM4331 noticed to have problems with b43-firmware-classic. Use b43-firmware for this card instead. - Broadcom wireless