Porteus-v4.0 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
Rava
Contributor
Contributor
Posts: 1585
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Porteus-v4.0 bug reports

Post#166 by Rava » 21 Jul 2018, 19:15

donald wrote:
21 Jul 2018, 01:16
Thunar / Edit / Configure custom actions ...> create a new one = + button
Thanks
I presume this is somehow stored in ~/.config/xfce4
Cheers!
Yours Rava

donald
Full of knowledge
Full of knowledge
Posts: 1416
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Porteus-v4.0 bug reports

Post#167 by donald » 21 Jul 2018, 19:28

~/.config/Thunar/uca.xml

<action>
<icon>package-x-generic</icon>
<name>Get md5sum</name>
<unique-id>1479219991020421-1</unique-id>
<command>/opt/porteus-scripts/context-menu/clipsum %f</command>
<description>Get md5sum</description>
<patterns>*</patterns>
<audio-files/>
<image-files/>
<other-files/>
<text-files/>
<video-files/>
</action>

User avatar
Rava
Contributor
Contributor
Posts: 1585
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Porteus-v4.0 bug reports

Post#168 by Rava » 23 Jul 2018, 00:12

Found another missing dependency:

Code: Select all

$ ldd /usr/bin/memusagestat|grep not
	libgd.so.3 => not found
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 4247
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0 bug reports

Post#169 by Ed_P » 24 Jul 2018, 16:18

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# usm -s libgd.so.3

 ----------------------------- 
 Are you searching for a library file? 

libgd.so.3, it seems a library.
Would you like to find the package for it? [y/n]

 libgd.so.3  was found in   gd-2.2.5-x86_64-1_slack14.2.txz 

root@porteus:/home/guest# usm -i gd-2.2.5-x86_64-1_slack14.2.txz

Package:  gd-2.2.5-x86_64-1_slack14.2.txz  (144 K) [upgrade]
gd: gd (a graphics library)
gd:
gd: gd is a graphics library. It allows your code to quickly draw images
gd: complete with lines, arcs, text, multiple colors, cut and paste from
gd: other images, and flood fills, and write out the result as a PNG or
gd: JPEG file. This is particularly useful in web applications, where
gd: PNG and JPEG are two of the formats accepted for inline images by
gd: most browsers. The gd library was written by Thomas Boutell.
gd:
gd: Homepage: https://www.libgd.org
gd:

root@porteus:/home/guest#  
:)
Ed

rchase
Samurai
Samurai
Posts: 185
Joined: 10 Jan 2016, 17:26
Distribution: Porteus 4.0 xfce x64
Location: Denver, Colorado

Porteus-v4.0 bug reports

Post#170 by rchase » 25 Jul 2018, 16:12

This may be a bug unrelated to Porteus 4.0, but I notice that my Porteus 4.0 x86-64 XFCE frugal installation to hd on my old Toshiba Satellite constantly resets my display preferences to use the laptop's own display when it resumes from suspend -- I use an external display and have set the display preferences not to use the laptop's display. The preferences are correctly applied on startup, but not when resuming.

mhens
White ninja
White ninja
Posts: 5
Joined: 30 Jul 2018, 10:07
Distribution: Porteus 4.0

Porteus-v4.0 bug reports

Post#171 by mhens » 30 Jul 2018, 10:17

When running the (fresh) Porteus 4.0 XFCE iso file "Porteus-XFCE-v4.0-x86_64.iso" in VirtualBox I get the following error when trying to update usm:

root Terminal
usm -u all

"
Downloading: LIBS.TXT.gz DONE
There was a problem downloading the file:
"

I am a Linux newb and have searched in the internet for around 2h now to find a solution.
Since this happens in fresh mode I would have suspected that other Porteus users also face this bug; but I have not found anything new about that topic.

How can I get USM to work? Are there other ways to (easily) install packages in Porteus? Need MongoDB and MongoDBTools.

Thanks,
Martin

User avatar
Ed_P
Contributor
Contributor
Posts: 4247
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0 bug reports

Post#172 by Ed_P » 30 Jul 2018, 13:59

Hello Martin.

One of the Porteus mirrors has a bad file or you have a bad connection to it. Note the name of the mirror you are downloading from when you get the error. Then click on USM's Settings option, next to the Update one. Edit the problem mirror's file, putting a "#" in front of the active URL and removing a "#" from a URL closer to you. Save the updated file, shutdown USM, restart it and run the update again. :)



BTW I just ran an update on my system and it ran to completion so the problem is not wide spread.
Ed

raja
Samurai
Samurai
Posts: 143
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v4.0-rc1-64
Location: Chennai,India

Porteus-v4.0 bug reports

Post#173 by raja » 30 Jul 2018, 17:54

MongoDB and MongoDB-Compass available in slackonly. Update slackonly and download and convert to xzm module..
Linux Kernel-4.4.120-32 bit; Linux kernel-4.15.7-64 bit.

mhens
White ninja
White ninja
Posts: 5
Joined: 30 Jul 2018, 10:07
Distribution: Porteus 4.0

Porteus-v4.0 bug reports

Post#174 by mhens » 31 Jul 2018, 08:07

Hi Ed_P and Raja, thanks for your help.
When I open the GUI for USM and click Update - Update slackware database I get the following error:

Find /tmp/xdg-runtime-guest/gvfs' : Permission denied
Starting slackware database update
Downloading: vercheck.txt DONE
Downloadin´: CHECKSUM.md5 DONE
Downloading: MANIFEST.bz2 DONE
Downloading PACKAGES.txt DONE
Downloading: LIBS.TXT.gz DONE
There was a problem downloading the file:
EXIT='"OK"
Killed

Please note, that there is nowhere the name of the mirror stated, from where it will download.

I then went to Settings - Edit slackware mirror - Edit
- I added a # in front of http://mirrors.slackware.com/slackware
- I removed the # in front of ftp://ftp.fu-berlin.de/unix/slackware/
- Saved the changes
- Closed USM GUI
- Started USM GUI (the same error as always "You are missing required database files! You can update databases using the update menu" appears) - OK
- Via Updates - Update slackware databases I try the process again .. the same error message appears
- I then changed the server again to another address -> but everything stays the same

When I chose Update - Update slackonly database I get the following error
Find /tmp/xdg-runtime-guest/gvfs' : Permission denied
Starting slackonly database update
Downloading: vercheck.txt DONE
Downloadin´: CHECKSUM.md5 DONE
Downloading: MANIFEST.bz2 DONE
Downloading PACKAGES.txt DONE
Downloading: LIBS.TXT.gz DONE
gzip: /var/usm/slackonly/CHECKSUM.md5.gz: unexpected end of file
==============================
Warning! Warning! Warning! Warning! Warning
==============================
One or more errors occurred while usm was running:
FATAL ERROR!
usm update_database 248
Could not decompress: CHECKSUM.md5.gz
==========================
Killed


In the internet I read about changing the mirrors in /etc/usm/ which I did yesterday and it did not help anything.
Please note that I am running a fresh version (which I verified by creating a file and restarting and the file was gone)

mhens
White ninja
White ninja
Posts: 5
Joined: 30 Jul 2018, 10:07
Distribution: Porteus 4.0

Porteus-v4.0 bug reports

Post#175 by mhens » 31 Jul 2018, 08:12

I just noted that the connection to the internet for the Porteus OS in the VM seems to be broken somehow.
A ping to www.web.de or to 82.165.230.17 is not working (the Host OS can do those pings)

But how can USM say that downloading vercheck.txt, CHECKSUM.md5, MANIFEST.bz2 and PACKAGES.txt are done when internet is not working??

mhens
White ninja
White ninja
Posts: 5
Joined: 30 Jul 2018, 10:07
Distribution: Porteus 4.0

Porteus-v4.0 bug reports

Post#176 by mhens » 31 Jul 2018, 09:04

Found the solution. In VirtualBox I had to set under network tab the Promiscuous-Mode to "deny".
By default, this PromiscousMode was greyed out. To be able to change it, I had to
1 Change the network type to Host-only Adapter
2 Change Promiscuous Mode to deny
3 Change network type back to NAT

Now Porteus has internet connection and the usm update is working.

I wished for the future that the status message "DOWNLOADING vercheck.txt DONE" would be changed to "DOWNLOADING vercheck.txt FAILED" when there is no internet connection because
it actually is failing. The download has not happened - so why is it showing DONE?
Without internet this "Downloading" messages come within half a second. With internet, they come within 5 seconds.

User avatar
Ed_P
Contributor
Contributor
Posts: 4247
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0 bug reports

Post#177 by Ed_P » 31 Jul 2018, 15:05

Hey mhens, glad you found the solution to your problem. :Yahoo!:

I don't agree with your change suggestion to the status msg. I think a test for an Internet connection should be added to the beginning of USM's Updates option before it attempts to start the downloads.
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 4247
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0 bug reports

Post#178 by Ed_P » 10 Aug 2018, 06:20

:shock:

Code: Select all

Warning: No MBR magic, treating disk as raw
Results of selecting porteus.cfg's Boot from the first hd menu option. Booted to Porteus 4.0 installed on a USB single partition drive booted on an EFI system. Fortunately the machine boots just fine when the USB drive is removed.
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 4247
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0 bug reports

Post#179 by Ed_P » 17 Aug 2018, 02:40

Follow up booting posts moved to here: Porteus-v4.0 booting bug reports.
Ed

lukaluki
Black ninja
Black ninja
Posts: 91
Joined: 08 Dec 2011, 01:01
Location: asdfw

Porteus-v4.0 bug reports

Post#180 by lukaluki » 19 Aug 2018, 17:13

VPN is still not working :(
Just tested on Porteus-KDE-v4.0-x86_64.iso

I tried it with standard PPTP. After clicking "connect", just nothing happens. Same problem was on Rc4 when i tried it.

How to make it work?
Messages error log says: result="fail" with reason="The VPN service 'org.freedesktop.NetworkManager.pptp' was not installed."

Post Reply