Porteus-v4.0 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
raja
Samurai
Samurai
Posts: 135
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v4.0-rc1-64
Location: Chennai,India

Porteus-v4.0 bug reports

Post#121 by raja » 18 Jun 2018, 09:00

Donald, Have you tried SMPlayer front end for DVD playing?

I installed in Nemisis-XFCE, to play videos. No lag, perfect. Have options for playing DVDs/Bluray disks...
SMPlayer © 2006-2018 Ricardo Villalba <rvm@users.sourceforge.net>

Version: 18.4.0 (revision 8992)
Using Qt 5.11.0 (compiled with Qt 5.10.1)
Using MPV 0.28.2

Links:
Official website: http://www.smplayer.info
Support forum: http://forum.smplayer.info

SMPlayer is a graphical interface for MPlayer and mpv.
Linux Kernel-4.4.120-32 bit; Linux kernel-4.15.7-64 bit.

User avatar
n0ctilucient
Shogun
Shogun
Posts: 407
Joined: 21 Apr 2017, 15:59
Distribution: fullmoonremix
Location: 127.0.0.1
Contact:

Porteus-v4.0 bug reports

Post#122 by n0ctilucient » 18 Jun 2018, 11:23

tome wrote:
18 Jun 2018, 08:19
I had problem with GSM USB dongle (on 2 laptops)- it didn't show available networks and connections. I installed tcl an tk once and now after reboot it works without tcl and tk. Strange but good to know.
Actually... not so strange.

@ brokenman... do you still think tcl/tk (which combined is less than 5mb) are Python compile deps only?

As I said before, if they are omitted "stuff will break"
(or the USM will download them anyway).

They are low level deps that are every bit as important as Perl or Mesa.

Now... before you kill the messenger run depfinder against Python.
see... https://slakfinder.org/show.php?pkg=1374722

@ the cmdline...

Code: Select all

depfinder -a -j2 -p -s nameofpackage.txz
tk/tcl is in the USM and @...
https://slakfinder.org/show.php?pkg=1420860
https://slakfinder.org/show.php?pkg=1420877

On X11??? packages, the USM asks for "onlyoffice-desktopeditors"..."mariadb"
and "qt2" (a whopping 100+ mb) that's why I've been using depfinder for years.

Sure... compared to the USM depfinder is tedious but also highly accurate.

Take no offense, this is my point of view... backed up by information NOT opinion.
Those that see it differently... are free to choose a different path and I'm Ok w/ that..
Last edited by n0ctilucient on 18 Jun 2018, 23:26, edited 1 time in total.
:hmmm: I do NOT have the "right" to tell anyone what they should do...
but I reserve the "right" to tell them what they should "consider".

donald
Full of knowledge
Full of knowledge
Posts: 1391
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Porteus-v4.0 bug reports

Post#123 by donald » 18 Jun 2018, 14:53

Hello raja
raja wrote:
18 Jun 2018, 09:00
Donald, Have you tried SMPlayer front end for DVD playing?
I did, for testing purpose.
The DVD-menu is displayed but not clickable.(chapters/extras etc.)

but more important:
XFCE is GTK based and smplayer will pull in a bunch of QT stuff..
so I ended up with a huge module (~ 85 MB)..unacceptable.
May be that 1 or 2 MBs can be stripped off, but it would still be
a huge module.

Anyway, thanks for suggesting an alternative to the unloved MPV player.
(I don’t want to have to use a search engine to find out which string of commands
I need to ‘do’ something.)
MPV is a bit more appealing now if one uses ncmprhnsbl's gnome-mpv front end.

User avatar
Ed_P
Contributor
Contributor
Posts: 4125
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0 bug reports

Post#124 by Ed_P » 18 Jun 2018, 16:15

donald wrote:
18 Jun 2018, 14:53
so I ended up with a huge module (~ 85 MB)..unacceptable.
:hmmm:
donald wrote:
08 Jun 2018, 08:22
I'm just a user and not a developer,
so I don't care about the size of the module.
What is the point of stripping down a module to the bone
;)
Ed

donald
Full of knowledge
Full of knowledge
Posts: 1391
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Porteus-v4.0 bug reports

Post#125 by donald » 18 Jun 2018, 16:23

^
completely out of context
a) 85MB single app
b) 20 vs 40 MB XFCE-DE module
What is the point of stripping down a module to the bone
and the sentence continued with:
...if you have to add MB's of stuff afterwards to make it work
like it did before? ;)

fulalas
DEV Team
DEV Team
Posts: 1124
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus-v4.0 bug reports

Post#126 by fulalas » 18 Jun 2018, 22:10

donald wrote:
18 Jun 2018, 16:23
...if you have to add MB's of stuff afterwards to make it work like it did before? ;)
Except that this is not the case. ;)

donald
Full of knowledge
Full of knowledge
Posts: 1391
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Porteus-v4.0 bug reports

Post#127 by donald » 18 Jun 2018, 23:15

that would be magnificent - (if it were true). ;)

fulalas
DEV Team
DEV Team
Posts: 1124
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus-v4.0 bug reports

Post#128 by fulalas » 19 Jun 2018, 03:08

donald wrote:
18 Jun 2018, 23:15
that would be magnificent - (if it were true). ;)
Except for your opinion (preferring app X over Y), give me some examples of Porteus 4 bugs that require the Xfce module to increase to something remotely close to the 45 MB of 3.2.2. Tip: if you know the answer, welcome to the dev team :good:

donald
Full of knowledge
Full of knowledge
Posts: 1391
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Porteus-v4.0 bug reports

Post#129 by donald » 19 Jun 2018, 09:50

@ fulalas
Why I'm not surprised to get that kind of reply..

However, you do already know what you had to add or change
to make the module nearly as good as the one shipped with 3.2.2.
And even more has to be done / changed in the module.
(hint: Thunar (root) .desktop file / custom actions)

It's not important if the final module will reach 20..30..or 40 MB in size at the end,
all what counts is if it works flawlessly, at least as good as in 3.2.2

Anyway, let's stop this fruitless, off topic conversation - let's get some work done...

User avatar
Rava
Contributor
Contributor
Posts: 1582
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Porteus-v4.0 bug reports

Post#130 by Rava » 23 Jun 2018, 23:16

● System: Porteus XFCE 4.0 x86-64 with, of course, added mpv-0.27.2-x86_64-2_SBo.xzm

Since due to moving I have no encrypted DVD at hand, so I tried the only DVD I had, a non encrypted one on a DVD+RW disc, but one with its original DVD menu intact.

Code: Select all

guest@porteus:/$ mpv dvd://0
Playing: dvd://0
libdvdnav: Using dvdnav version 6.0.0
libdvdnav: DVD Title: XYZ_STAFFEL_1
libdvdnav: DVD Serial Number: 00C09917DVDSHRNK
libdvdnav: DVD Title (Alternative): 
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000012d
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00005366
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x000053a3
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x000053f0
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x0019367e
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x001938d2
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x00227393
libdvdread: Elapsed time 0
libdvdread: Found 4 VTS's
libdvdread: Elapsed time 0
libdvdnav: Language 'en' not found, using 'de' instead
libdvdnav: Menu Languages available: de 
[dvdnav] DVDNAV, switched to title: 1
 (+) Video --vid=1 (mpeg2video 720x576)
File tags:
 Title: XYZ_STAFFEL_1
[vo/opengl] retrieving framebuffer depth: OpenGL error INVALID_ENUM.
libdvdnav: DVD disk reports itself with Region mask 0x00000000. Regions: 1 2 3 4 5 6 7 8
libdvdnav: Language 'en' not found, using 'de' instead
libdvdnav: Menu Languages available: de 
[dvdnav] DVDNAV, switched to title: 2
libdvdnav: Language 'en' not found, using 'de' instead
libdvdnav: Menu Languages available: de 
VO: [opengl] 720x576 => 1024x576 yuv420p
 (+) Video --vid=1 (mpeg2video 720x576)
     Audio --aid=1 (ac3 2ch 48000Hz)
V: 00:00:08 / 00:00:03 (100%)
 (+) Video --vid=1 (mpeg2video 720x576)
     Audio --aid=1 (ac3 2ch 48000Hz)
     Subs  --sid=1 (dvd_subtitle)
V: 00:00:50 / 00:00:03 (100%)
[disc] PTS discontinuity: 51.327267->0.247267
V: 00:01:05 / 00:00:03 (100%)


Exiting... (Quit)
It looks like it is playing, and it does indeed loop the main menu, but alas, I am unable to access any of the DVD menu, it is not clickable by the mouse (as it should be), nor can I use the TAB key to move to an menu entry, I then get this error:

Code: Select all

V: 00:00:19 / 00:00:03 (100%)
[input] No key binding found for key 'TAB'.
, nor is any sound played. mpv does report a sound available:

Code: Select all

VO: [opengl] 720x576 => 1024x576 yuv420p
 (+) Video --vid=1 (mpeg2video 720x576)
     Audio --aid=1 (ac3 2ch 48000Hz)
● How do I get it to play sounds?
● How can I access the DVD menu? Is this an issue with "dvdnav version 6.0.0". Is "dvdnav version 6.0.0" some stand alone thingy or is it compiled into mpv?

manual/mplayer-changes.rst: says when grep'ing it for "-i dvd":

Code: Select all

``dvdnav://``               Removed.
Still, mpv.SlackBuild gives this:

Code: Select all

 --enable-dvdnav \
 --enable-dvdread \
Could that be the issue why the DVD menu not works?
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1505
Joined: 20 Mar 2012, 03:42
Distribution: 4.0-64bit all-DE+more
Location: australia
Contact:

Porteus-v4.0 bug reports

Post#131 by ncmprhnsbl » 24 Jun 2018, 03:08

Rava wrote:
23 Jun 2018, 23:16
I am unable to access any of the DVD menu,
Porteus-v4.0 bug reports (Post by ncmprhnsbl #65191)
yeah, the --enable-dvdnav configure option is probably pointless..
Rava wrote:
23 Jun 2018, 23:16
, nor is any sound played. mpv does report a sound available:
this should show available audio tracks, clicking on it cycles through themImage
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Blaze
DEV Team
DEV Team
Posts: 1912
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current Xfce x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus-v4.0 bug reports

Post#132 by Blaze » 24 Jun 2018, 06:43

donald wrote:
18 Jun 2018, 00:52
Exec=/opt/porteus-scripts/xorg/psu "dbus-launch --exit-with-session thunar %F"
to
Exec=gksu -l "dbus-launch --exit-with-session thunar %F"
and also in Thunar's custom actions.
Done. uca-xfce-actions-by-blaze-2018-06-24.xzm
Linux porteus 4.18.3-porteus #1 SMP PREEMPT Sat Aug 18 16:50:00 UTC 2018 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
Rava
Contributor
Contributor
Posts: 1582
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

Porteus-v4.0 bug reports

Post#133 by Rava » 24 Jun 2018, 21:30

ncmprhnsbl wrote:
24 Jun 2018, 03:08
Rava wrote:
23 Jun 2018, 23:16
I am unable to access any of the DVD menu,
Porteus-v4.0 bug reports (Post by ncmprhnsbl #65191)
yeah, the --enable-dvdnav configure option is probably pointless..
Hmm would gnome-mpv be able to play DVDs? But AFAIK thats only a wrapper starting mpv or is it a standalone binary?

About the sound. ... thought I tried all available sounds. Have to check that once more.

Update
gtk-porteus-timeconfig lookes messed up when running in Port 4.0 x86-64 XFCE with NVidia driver nvidia-304.137-k.4.16.3-x86_64-don

The "Cancel" button is half overlaying the other buttons, like in the main window:
Image

ALso, in the Set Time/Date Sub-Window, the edit/select days, months et cetera is messed up, like so:
Image
______________________________

And I still got no reply as how do I optain a module for the original man pages (the ones in English) for my 4.0 x86-64 XFCE system.
Also, no updates if the messed up locales with manpages as described above is now fixed, especially the issue with the missing manpages (e.g. mpg123, mpv) and the man pages that are in this module, but are not existant as programs anymore. Have the man1 folder for example:

Code: Select all

guest@porteus:/mnt/live/memory/images$ ls de-xfce4_locales.xzm/usr/man/de/man1/
apropos.1  chsh.1     login.1     mplayer.1  sg.1      xfce4-terminal.1
chage.1    expiry.1   man.1       newgrp.1   su.1
chfn.1     gpasswd.1  mencoder.1  passwd.1   whatis.1
Example mpv, it exists as LC_MESSAGES/gnome-mpv.mo but not as man page:

Code: Select all

guest@porteus:/mnt/live/memory/images/de-xfce4_locales.xzm/usr$ find .|grep mpv
./share/locale/de_DE/LC_MESSAGES/gnome-mpv.mo
When activating the de-xfce4_locales.xzm, the man pages still not get displayed, running man mencoder results in this:

Code: Select all

guest@porteus:/mnt/live/memory/images$ man mencoder
No manual entry for mencoder
checking network resources...

Looking up man.cx
Unable to locate remote host man.cx.
Alert!: Unable to connect to remote host.

lynx: Can't access startfile http://man.cx/mencoder
Only running it like so:

Code: Select all

man /usr/man/de/man1/mencoder.1 
succeeds.

If that is an issue that e.g. the de-xfce4_locales.xzm must be loaded together with the boot up, then we need some large red signs for users to know about such issue, and that it won't work as module loaded after the systemn is already up.
But it also seems, there is no info which locales and such the system should use, these should be in /etc/, or not?
Cause there are only files and folders in /usr/man and /usr/share and below in the de-xfce4_locales.xzm module.
Cheers!
Yours Rava

donald
Full of knowledge
Full of knowledge
Posts: 1391
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Porteus-v4.0 bug reports

Post#134 by donald » 26 Jun 2018, 17:31

Rava wrote:
24 Jun 2018, 21:30
gtk-porteus-timeconfig lookes messed up when running in Port 4.0 x86-64 XFCE with NVidia driver nvidia-304.137-k.4.16.3-x86_64-don
Can you please check if this happens in the "always fresh" mode (+ nvidia driver)
( place the driver module into the base folder and add a (e.g.) 009 prefix
to make it load in AF mode at boot up)

I've tried to reproduce this problem, even with the adwaita-dark theme, but it looks ok here.

bour59
Samurai
Samurai
Posts: 139
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

Porteus-v4.0 bug reports

Post#135 by bour59 » 30 Jun 2018, 09:49

Hello!
I can't view the content of my webmail under firefox
-processor Intel(R) Pentium(R) D CPU 2.80GHz
-memory 1GiB System Memory
-porteus v4.0 xfce i586 ---( same issue porteus v3.2.2 )
-firefox 61.0 from server

all's ok on the same configuration with slackware-live-xfce instead porteus

all's ok on another hardware
-processor Pentium(R) Dual-Core CPU E5200 @ 2.50GHz
-memory 4GiB System Memory
-porteus v4.0 xfce i586
-firefox 61.0 from server

I am a little confused by this

Post Reply