Porteus-v4.0rc4 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
raja
Samurai
Samurai
Posts: 122
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v4.0-rc1-64
Location: Chennai,India

Porteus-v4.0rc4 bug reports

Post#16 by raja » 19 Feb 2018, 09:26

This refers to v4.0rc1 LxQt.
Preferences/LXQt settings/Time and Date; When I selected Timezone, gives out an error message ,"The name org.freedesktop.timedate1 was not provided by any .service file".

Used PSC to make xzm for timezone. Though time display is correct, this module generated by psc induces "raiserfs" error in Kernel message. ( raised this earlier also).

I shall download latest, only after someone says , no more carry over of error messages from start ( known issue to all developers) during the shutdown process.

*with rc1, I am getting more and more files getting corrupted during write. I am not doing anything funny now to get these. No experiments till I am assured.

Progress means, 'something new' and 'attractive'.

I would like a quiet boot with only a dos animation, till desktop shows up. colorful icons may jazz up the look and feel. Imagine a world with grey suited women.!

But, in Porteus, kernel finishes its job, during boot in just 8 seconds for me, am yet to a competitor, anywhere near.
Linux Kernel-4.4.120-32 bit; Linux kernel-4.15.7-64 bit.

jssouza
DEV Team
DEV Team
Posts: 608
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Porteus-v4.0rc4 bug reports

Post#17 by jssouza » 19 Feb 2018, 09:28

Booting iso in copy2ram mode - linuxrc has this error probably while trying to eject the CD:
linuxrc: line 375: /union/usr/bin/eject: not found

fulalas
DEV Team
DEV Team
Posts: 1103
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus-v4.0rc4 bug reports

Post#18 by fulalas » 19 Feb 2018, 10:11

raja wrote:
19 Feb 2018, 09:26
This refers to v4.0rc1 LxQt.
Preferences/LXQt settings/Time and Date; When I selected Timezone, gives out an error message ,"The name org.freedesktop.timedate1 was not provided by any .service file".
I'm aware of this issue. I've already reported to the developers, but they don't seem to care. So, I'm sorry, but I can't fix this. :Search:

paf
White ninja
White ninja
Posts: 8
Joined: 22 Feb 2018, 15:11
Distribution: Porteus
Location: Portugal

Porteus-v4.0rc4 bug reports

Post#19 by paf » 22 Feb 2018, 15:42

This is with XFCE version, but is related to VirtualBox (building the Guest Additions).

So with Porteus 4.0 rc4 iso I have made an ISO including closed source and level modules.

When building the Virtual Box Guest Additions using the supplied scripts, they fail.

On the /var/log/vboxadd-setup.log file it says:
Kernel configuration is invalid.
it complains about missing "include/generated/autoconf.h" or "include/config/auto.conf"

Then says it cannot find the headers of the linux Kernel to specify KERN_VER=<version> currently 4.15.2-porteus.

My doubts are:
uname -a gives the kernel version 4.15.0-rc7-porteus
/usr/src/linux is a symbolic link to linux-4.15.2 and there on include/linux/ there is the autoconf.h file.

Is there some mismatch between the two?
What can I do to compile the Virtual Box Guest additions?

Oh, and many many, MANY thanks to the Porteus developers.

fulalas
DEV Team
DEV Team
Posts: 1103
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus-v4.0rc4 bug reports

Post#20 by fulalas » 22 Feb 2018, 21:54

@paf, I can't reproduce your issue. I can generate both VBox and VBoxGuest modules from Vbox builder. Have you tried to boot into Always Fresh mode?

BTW, why do you want the Guest Addition? :)

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1431
Joined: 20 Mar 2012, 03:42
Distribution: 4.0-64bit all-DE+more
Location: australia
Contact:

Porteus-v4.0rc4 bug reports

Post#21 by ncmprhnsbl » 22 Feb 2018, 23:53

paf wrote:
22 Feb 2018, 15:42
uname -a gives the kernel version 4.15.0-rc7-porteus
something not right there..
should be:

Code: Select all

$ uname -a
Linux porteus 4.15.2-porteus
what ARCH are you using? x86_64 or x86 ?
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

paf
White ninja
White ninja
Posts: 8
Joined: 22 Feb 2018, 15:11
Distribution: Porteus
Location: Portugal

Porteus-v4.0rc4 bug reports

Post#22 by paf » 23 Feb 2018, 11:05

I am using the 32 bit variant of Porteus and using it inside Virtual Box, so the guest additions are needed.

The purpose is to have a small/light Linux 32 bits virtual machine with dev tools for programming students. The combination of Porteus with Virtual Box results in something very easy to install in different operative systems, and then the students save their work on a VBox shared folder, as the VM has no hard disks, just the iso for booting Porteus. If they do something weird, the next reboot gives them a clean working Porteus platform.

What did I tried

Downloaded from mirrors.dotsrc.org the following versions:

Porteus-MATE-v4.0rc4-i586.iso
Porteus-OPENBOX-v4.0rc4-i586.iso
Porteus-XFCE-v4.0rc4-i586.iso

All give me kernel version 4.15.0-rc7-porteus with uname -a , on an unmodified ISO and with the "always fresh" option.

Binary Enigma
White ninja
White ninja
Posts: 4
Joined: 22 Feb 2018, 11:44
Distribution: Porteus v4 32 bit

Porteus-v4.0rc4 bug reports

Post#23 by Binary Enigma » 23 Feb 2018, 15:26

I've been using Porteus v3.2.2 32 bit with Cinnamon on a daily for about a year now, on an external HDD. Now that v4 is out, I tried to install it to another HDD to see if it's reliable, I ended up with the following:

- As soon as it booted(Graphics Mode), I was met with a login screen that was not in the older version. Upon inserting "guest" as both user and password, the system gave a few errors(1 frame, sometimes just a black screen) and went back to the same screen(this will happen no matter how many times I try it). Upon inserting "root" as user and "toor" as password, the system loaded up cinnamon, however, this gave me the next problem.

- With the root user, connection to the internet is not possible, when attempted with cable it keeps trying to connect without success(this only happens at work networks, presumably because it needs specific settings, my home network works fine, but only via ethernet), with any WiFi USB adapters, it refuses to even check for networks and just reads "unavailable". It should be noted that in "Always Fresh" everything works and in v3.2.2 all of the connections mentioned work.

- Since the guest account did not work, I tried to create a new one other than root, however, the option "Users and Groups" in the cinnamon settings is not functional (every other option works, this one simply does not respond). I then successfully created a user via terminal (adduser command), but when trying to log in, did the same as guest account

-Something less important: upon clicking the "Quit"(shutdown) button in the menu, the window that pops up saying "Shut down this system now?" only has one option, "Cancel". Pressing the physical power button on the computer works.

The only changes that were made to the system after installing were the installation of chromium, which works well but has to be lanched with --no-sandbox as I am stuck as root
Sorry for the long post and I apologize if I'm missing something obvious, I'm gonna try to reinstall porteus v4 with MATE and see if any of the problems go away/persist

paf
White ninja
White ninja
Posts: 8
Joined: 22 Feb 2018, 15:11
Distribution: Porteus
Location: Portugal

Porteus-v4.0rc4 bug reports

Post#24 by paf » 23 Feb 2018, 16:48

ncmprhnsbl wrote:
22 Feb 2018, 23:53
paf wrote:
22 Feb 2018, 15:42
uname -a gives the kernel version 4.15.0-rc7-porteus
something not right there..
should be:

Code: Select all

$ uname -a
Linux porteus 4.15.2-porteus
what ARCH are you using? x86_64 or x86 ?
Tried some different variants, and all the x86_64 give me 4.15.2-porteus, but all the i586 variants give me 4.15.0-rc7-porteus.

jssouza
DEV Team
DEV Team
Posts: 608
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Porteus-v4.0rc4 bug reports

Post#25 by jssouza » 23 Feb 2018, 19:35

Binary Enigma, thank you for your report. Could you tell us a little more on what an install to HDD means? Is it what is called as a "frugal" install of porteus? Also, please try in always fresh mode to see if the same problem occurs.

Are you able to login as guest from a VT? (Ctrl-Alt-F2). If yes, could you provide the output of the following commands:

Code: Select all

cat /proc/cmdline 
and

Code: Select all

cat /var/log/porteus-livedbg
Thanks

User avatar
Ed_P
Contributor
Contributor
Posts: 3929
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0rc4 bug reports

Post#26 by Ed_P » 23 Feb 2018, 19:48

Cinnamon DE

Attempting to view a ini file in an ISO file Archive Manager gives an error.
Archive Manager wrote:
An error occurred while extracting files.

Setting attribute time::created not supported
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 1431
Joined: 20 Mar 2012, 03:42
Distribution: 4.0-64bit all-DE+more
Location: australia
Contact:

Porteus-v4.0rc4 bug reports

Post#27 by ncmprhnsbl » 23 Feb 2018, 21:52

paf wrote:
23 Feb 2018, 16:48
Tried some different variants, and all the x86_64 give me 4.15.2-porteus, but all the i586 variants give me 4.15.0-rc7-porteus.
confirmed
it would appear that a mistake has been made building the i586 ISOs ie. they have the wrong kernel/vmlinuz(4.15.0-rc7)
@paf , if you able, a workaround would be to remake the ISOs, swapping out the /porteus/base/000-kernel.xzm and /boot/syslinux/vmlinuz with the ones from:
<mirror dir>/i586/Porteus-v4.0/kernel/linux-4.15.2/
@brokenman, guess what your job for this weekend is ;) (note: x86_64 isos are correct)
Forum Rules : http://forum.porteus.org/viewtopic.php?f=35&t=44

paf
White ninja
White ninja
Posts: 8
Joined: 22 Feb 2018, 15:11
Distribution: Porteus
Location: Portugal

Porteus-v4.0rc4 bug reports

Post#28 by paf » 24 Feb 2018, 10:19

ncmprhnsbl wrote:
23 Feb 2018, 21:52
paf wrote:
23 Feb 2018, 16:48
Tried some different variants, and all the x86_64 give me 4.15.2-porteus, but all the i586 variants give me 4.15.0-rc7-porteus.
confirmed
it would appear that a mistake has been made building the i586 ISOs ie. they have the wrong kernel/vmlinuz(4.15.0-rc7)
@paf , if you able, a workaround would be to remake the ISOs, swapping out the /porteus/base/000-kernel.xzm and /boot/syslinux/vmlinuz with the ones from:
<mirror dir>/i586/Porteus-v4.0/kernel/linux-4.15.2/
@brokenman, guess what your job for this weekend is ;) (note: x86_64 isos are correct)
YES, YES, YES !

Now, after doing that almost everything is ok.

When doing name -a (on i586) the correct version is shown, but strangely the command complains that the local timezone is not set.
Now, the failure when building the Vbox guest additions is different.

It still complains that the Kernel configuration is invalid, it cannot find include/generated/autoconf.h or include/config/auto.conf and tells me to
run

Code: Select all

make oldconfig && make prepare 
on the kernel source.

Weekend will be very busy, so I will retry during next week.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5864
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Porteus-v4.0rc4 bug reports

Post#29 by brokenman » 25 Feb 2018, 12:42

ncmprhnsbl wrote:
23 Feb 2018, 21:52
@brokenman, guess what your job for this weekend is
:oops: :cry:
Very sorry. Corrected now.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Binary Enigma
White ninja
White ninja
Posts: 4
Joined: 22 Feb 2018, 11:44
Distribution: Porteus v4 32 bit

Porteus-v4.0rc4 bug reports

Post#30 by Binary Enigma » 25 Feb 2018, 16:30

jssouza wrote:
23 Feb 2018, 19:35
Could you tell us a little more on what an install to HDD means? Is it what is called as a "frugal" install of porteus?
I feel kinda dumb because I didn't know what you mean by frugal, and, after looking it up I am still not sure, but what I did was: Created an ext4 partition (Not sure if it matters but there's another partition first, exFat), extracted files from Porteus-CINNAMON-v4.0rc4-i586.iso into the root of said partition, ran Porteus-installer-for-Linux.com(had to change perms to executable first, which wasn't needed when I did the same for v3.2.2), then I just went to check if porteus.cfg was correct, it wasn't(at least in relation to v3.2.2), just changed "APPEND changes=/porteus" to "APPEND changes=/changes" (Which I believe was default in v3.2.2, if it wasn't, it was what I have in my working copy of it). After that, just restarted and booted from it, to find the previously reported problems.
In hindsight, it appears I probably installed it wrong, considering what I found when trying to figure out what you meant by frugal:
"Porteus can be installed to hard drives, but it should be left in its compressed state (otherwise known as a 'Frugal' installation). Installing extracted files to a hard drive is not supported" - although it worked perfectly for my copy of Porteus v3.2.2
I apologize for being quite noobish at this stuff, I kinda just use porteus as one would use a portable version of Windows, I like porteus because it's portable, fast on old machines(which is, unfortunately, all I use) and it gave me no problems(In v3.2.2, that is); I don't use it for anything too technical.
In relation to using VT, I already formatted the partition with porteus in it, to reinstall(since it seems I installed it wrong, I'd appreciate some info on how to do it right), if the problems then persist, I shall test some other things and report my findings then.

Post Reply