Page 2 of 4

Porteus - USM error

Posted: 31 Dec 2017, 18:56
by Ed_P
jake0301 wrote:
31 Dec 2017, 18:14
and i found the "Solution" here: Re: usm errors (Post by brokenman #27466)
Ok. Thanks. Do note that the date of that "Solution" is over 3 yrs ago and probably for 3.0 or 2.1.

BTW In your Distribution you should consider expanding it to include version and architecture.

Slackonly is tough since it has only a single mirror. :x (/etc/usm/mirrors-slackonly.txt)

This should get you the main part of Atom but not sure how you convert it to an .xzm module.

wget http://slackonly.com/pub/packages/14.2- ... slonly.txz -P /home/guest/Downloads

I found it via https://packages.slackonly.com/pub/pack ... CKAGES.TXT :good:

Porteus - usm error

Posted: 31 Dec 2017, 19:34
by ncmprhnsbl
Ed_P wrote:
31 Dec 2017, 18:56
This should get you the main part of Atom but not sure how you convert it to an .xzm module.
rightclick>choose "Convert txz to xzm" (or something similar) it uses the txz2xzm script..

Porteus - usm error

Posted: 01 Jan 2018, 19:00
by jake0301
ERROR 404: Not Found.

Porteus - usm error

Posted: 01 Jan 2018, 19:30
by Jack
I tested USM yesterday usm -u all and it updated without any problem at all. I use a 8gb usb and it is formatted ext4.

Porteus - usm error

Posted: 01 Jan 2018, 20:05
by jake0301
it updates fine, i just cant download certain modules.
im using a 64gb USB formatted to ext4

Porteus - usm error

Posted: 01 Jan 2018, 22:48
by Ed_P
jake0301 wrote:
01 Jan 2018, 19:00
ERROR 404: Not Found.
:shock: It was there when I posted the link. And the PACKAGES.TXT still shows this:

Code: Select all

PACKAGE NAME:  atom-amd64-1.22.1-x86_64-1_slonly.txz
PACKAGE MIRROR:  http://slackonly.com/pub/packages/14.2-x86_64/
PACKAGE LOCATION:  ./development/atom-amd64
PACKAGE SIZE (compressed):  80676 K
PACKAGE SIZE (uncompressed):  424389 K
PACKAGE DESCRIPTION:
atom-amd64: atom-amd64 (the Atom hackable text editor)
atom-amd64:
atom-amd64: Atom is a text editor that's modern, approachable, yet hackable to
atom-amd64: the core—a tool you can customize to do anything but also use
atom-amd64: productively without ever touching a config file.
atom-amd64:
atom-amd64: This is a precompiled version of Atom.
atom-amd64:
atom-amd64: https://atom.io/
atom-amd64:
atom-amd64:

PACKAGE NAME:  atom-1.17.2-x86_64-6_slonly.txz
PACKAGE MIRROR:  http://packages.slackonly.com/pub/packages/14.2-x86_64/
PACKAGE LOCATION:  ./development/atom
PACKAGE SIZE (compressed):  67216 K
PACKAGE SIZE (uncompressed):  350740 K
PACKAGE REQUIRED:  nodejs
PACKAGE CONFLICTS:  
PACKAGE SUGGESTS:  
PACKAGE DESCRIPTION:
atom: atom (Chrome-based and Hackable text editor)
atom:
atom: A chrome-based text editor, with full-featured, right out of the
atom: box: file system browser, multiple panes, snippets, and more.
atom:
atom:
atom:
atom:
atom:
atom:
atom:
Maybe it was taken down until the LIBS.TXT file is fixed.

Porteus - usm error

Posted: 01 Jan 2018, 23:39
by ncmprhnsbl
i think, for some reason your link was missing some dirs :unknown:
two versions:
one 'precompiled', 77mb
https://slackonly.com/pub/packages/14.2 ... slonly.txz
one compiled by slackonly 66mb
https://slackonly.com/pub/packages/14.2 ... slonly.txz

tip: slackonly packages are compiled from sBo (slackbuilds.org)
so searching slackbuilds.org will give a clue where to find a package in slackonly repo( in this case 'development') as well as (sometimes) dependencies..
furthermore, using DuckDuckGo: !sbo atom will search slackbuilds.org directly.
also, slakfinder.org is quite useful to find packages in a number of slackware repos(including slackonly)

Porteus - usm error

Posted: 01 Jan 2018, 23:50
by Ed_P
ncmprhnsbl wrote:
01 Jan 2018, 23:39
i think, for some reason your link was missing some dirs :unknown:
I see what you're saying, my link doesn't include the

Code: Select all

PACKAGE LOCATION:  ./development/atom-amd64
directories but I swear the link worked when I posted it. :happy62:

I'm sure jake0302 will appreciate your updates. :)

Porteus - usm error

Posted: 04 Jan 2018, 18:36
by jake0301
ok, that package worked but...
that's less of a solution more of a workaround so unfortunately, i will not be using Porteus anymore.
I've looked at several Linux distros and I've finally found one that I really like.
so I bid you all a farewell and adjö.
best of luck fixing the package manager
-Jake

P.S. I tried using a different desktop and then I could install atom but now I couldn't install light firefox

Porteus - usm error

Posted: 04 Jan 2018, 20:35
by Ed_P
Sorry things didn't work for you Jake0301. What version do you really like?

Porteus - usm error

Posted: 05 Jan 2018, 02:21
by jake0301
Solus: https://solus-project.com/
i got all the packages i need without a hitch(which s more than i can say for every other distro even ubuntu)
and i love the look of the desktop

Porteus - usm error

Posted: 05 Jan 2018, 02:53
by Ed_P
1.2 GB!! Wow!

Porteus - usm error

Posted: 05 Jan 2018, 13:24
by jake0301
Well, size really doesn't matter that much in my case :)
it's a 64gb stick

Porteus - usm error

Posted: 06 Jan 2018, 05:21
by Ed_P
Well yes, it fits on your stick. I'm thinking download time and boot times. Did you install it or do you boot the ISO?

Porteus - usm error

Posted: 06 Jan 2018, 14:31
by jake0301
install, and it boots pretty fast, and my internets fast enough that the download was not a problem