lzm modules won't all convert?

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Power user
Power user
Posts: 53
Joined: 29 Dec 2010, 01:46
Location: Near SF, CA

Re: lzm modules won't all convert?

Post#16 by Burninbush » 12 Mar 2011, 20:43

Back again to this topic -- with an example that I think must illustrate a bug.

File is here: http://ponce.cc/testing/porteus.old/modules/multilib/ -- the wine-135*lzm module.

So, I d/l that and copy it to some linux filesystem. From my running port64beta, I use Dolphin to navigate to where I copied it, and click on the name. A box pops up asking if I want to open it with the activator, I answer yes. I'm offered the opportunity to convert to .xzm, answer yes. So, system does something, comes back fairly quickly and reports it has made a .xzm. Yes it has, but the size has now shrunk from 25.5 mb to 7mb. I activate it, and it doesn't work, no K menus, and when I run #wine someapp.exe, it complains of missing files.

So ... I really need wine here. I try, on the same .lzm file, #unsquashfs wine.lzm -- and it produces a directory of total size 129mb, 2181 files, 75 subdirs. I then click on that directory, and take the choice to convert to .xzm module. That finishes, I now have new-wine.xzm, of 24.9 mb size. Click on that to activate it, and holy-shamoley, I have the wine that worked perfectly well on remix64-beta2.

Stuff is clearly getting lost in that activator script.

Here's my extramod directory contents:

bash-4.1# cd /mnt/sda3/extramods
bash-4.1# ls -l
total 127360
-rwxrwxrwx 1 root root 1900544 Feb 19 18:39 audacious-2.4.0-x86_64.xzm*
-rwxrwxrwx 1 root root 5767168 Feb 19 18:32 audacity-1.3.12-x86_64.xzm*
-rwxrwxrwx 1 root root 19476480 Feb 20 17:10 compat32-stripped.xzm*
-rwxrwxrwx 1 root root 22827008 Feb 19 18:52 jre-6u23-x86_64.xzm*
-rwxrwxrwx 1 root root 17211392 Feb 18 13:26 mplayer-codecs.xzm*
-rwxrwxrwx 1 root root 22851584 Feb 20 17:03 multilib-stripped-v09.xzm*
-rwxrwxrwx 1 root root 20615168 Feb 20 14:07 samba-3.5.5-x86_64-1.xzm*
-rwxrwxrwx 1 root root 1892352 Feb 20 14:07 smb4k-0.10.7-x86_64-1ponce.xzm*
-rwxrwxrwx 1 root root 17821696 Feb 20 14:07 vlc-1.1.5-x86_64.xzm*

This was the state of the machine when I do the conversions mentioned above [failed, and then working]. The two helper modules were converted [lzm2xzm, I think] from the same Ponce repo, after previous use on remixv09-64.

User avatar
Moderator Team
Moderator Team
Posts: 5667
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland

Re: lzm modules won't all convert?

Post#17 by fanthom » 12 Mar 2011, 23:15

you are absolutely right Burninbush.
there is something wrong with 'xactivate' script which does the conversion. will be fixed in next release or SP.

thanks a ton!
Please add [Solved] to your thread title if the solution was found.

Post Reply