Vmware tools compilation fails to find gcc

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
White ninja
White ninja
Posts: 9
Joined: 26 Jan 2011, 22:46
Location: USA

Vmware tools compilation fails to find gcc

Post#1 by caliban » 26 Jan 2011, 22:56

I am trying to compile vmware tools on Porteus V0.9 and even though I have set the CC env variable, explicitly spell out gcc's location (/usr/bin/gcc), it fails. BTW, 'which gcc' works and so does just running it.

Has anyone compiled VMware tools on Porteus and by any chance would this be related to the gcc mismatch between the kernel and the gcc shipped ?

User avatar
Moderator Team
Moderator Team
Posts: 5667
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland

Re: Vmware tools compilation fails to find gcc

Post#2 by fanthom » 27 Jan 2011, 12:55

Moved from "Community help..." to "Bug reports" as "Community help" subfolder is reserved for creating topics by 64-bit maintainer only.
Which Vmware version do you use? I have tried 6.5.5 on Porteus-v09 and got warning about different gcc version too. Just answered 'yes' and instalation continued. However installator was able to build 2 modules only (vmblock and vmmemory or something) and rest has failed. Looks like 6.5.5 doesn't support 2.6.37 kernel.
Should be ok for 2.6.36 (slax-remix-v09 or earlier).
possible solutions:
- try Vmware 7.x.x with Porteus
- try Vmware 6.5.5 with slax-remix (kernel 2.6.36 or lower)
- switch to Virtualbox which has no problems even with 2.6.38-rc2 kernel :)

In case of going with Vmware, please consider installing xf86-video-vmware and xf86-input-vmmouse which are not included in default ISO (xconf was giving segfaults on real PC). Dont know if they are necessary (have no experience with Vmware).

Please add [Solved] to your thread title if the solution was found.

Post Reply