Page 1 of 4

64bit official Porteus repository bug reports

Posted: 06 Jul 2012, 12:06
by fanthom
Please post bugs related to xzm modules placed in 64bit official repository in this thread only.
Examples: unresolved deps, damaged modules, etc

i'll try to fix them asap.


teamviewer do not start ;-(

Posted: 08 Jul 2012, 08:33
by miguipda

I perfectly installed Porteus 1.2 64 bits.
I also successfully installed teamviewer 6 from the porteus PPM but ...

when I start it from the menu icon this last icon dance on the window but never display the teamviewer program.
Then I tried to run it from a konsole. And it does not returned any error. And the teamviewer still did not appeared on the display.

Could you please have a look to solve it ?

Sincerely thanks and have a nice day,

Miguipda ;-)

Re: 64bit official Porteus repo bug reports

Posted: 08 Jul 2012, 09:19
by fanthom
Hi miguipda,

Teamviewer is in fact 32bit application and requires compat32 package which can be downloaded from here:

PPM wont be able to resolve 32bit deps so this is the only exception in 64bit repo.
I'll update teamviewer to latest version and add this note to the slack-desc file.

hopefully other users will be able to spot it.

Re: 64bit official Porteus repository bug reports

Posted: 19 Jul 2012, 09:43
by edge226
k3b and brasero do not pull cdrdia this causes neither to function. After installing cdrdao I still did not receive dvd functionality.

pburn recieves an error as well. I had this functionality in 1.1. It has got to be be a missing dependency. Ok looks like I can create a disc in brasero and then burn it in pburn, when adding files to a data disc it did not like to display all video items that were added.

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 09:02
by att
I have a "little" problem with Porteus 2.0 64bit XFCE edition and Teamviewer 7.
Teamviewer 7 works fine, but there are some quirks: It uses 25% CPU time on a dualcore machine (Dell Optiplex 755).
The traffic Teamviewer 7 generates was quite high. On a fast local network, which is connected to the Internet, I got 16.3 GB of RX (received) traffic in 3 hours, and it was just Teamviewer who was running. :%)
I have no idea what's going on! (I tried to study everything with 'tcpdump' but only saw some Teamviewer traffic).

Teamviewer 7 also crashed much more often (once a day) compared to usual. I have no idea why.

My modules:

Code: Select all

arp-scan-1.8.1-x86_64-1cf.xzm	233.472	01.02.2013 09:28	-a--
binbot.xzm	1.470.464	08.08.2012 13:00	-a--
cabextract-1.2-i486.xzm	32.768	15.03.2011 16:03	-a--
chntpw-0.99.6-x86_64.xzm	106.496	15.03.2011 16:03	-a--
chttpd-1.3-x86_64.xzm	12.288	15.03.2011 16:03	-a--
cksfv.xzm	12.288	15.03.2011 16:03	-a--
compat32-libraries-1.1.02_13.37-x86_64-2ftm.xzm	46.702.592	19.05.2012 10:16	-a--
ctorrent-1.3.4.xzm	94.208	15.03.2011 16:04	-a--
fping-2.4b2_to-i486-1sl.xzm	16.384	15.03.2011 16:04	-a--
glibmm-2.32.1-x86_64-2sl.xzm	5.824.512	01.02.2013 11:03	-a--
gnutls-3.0.23-x86_64-1.xzm	1.105.920	01.02.2013 08:59	-a--
JDownloader-2-incl_updates_2013_02_x86_64.xzm	54.620.160	17.02.2013 01:21	-a--
kvpnc-0.9.6.xzm	1.679.360	15.03.2011 16:05	-a--
libevent-2.0.11-x86_64-1hamza.xzm	331.776	20.06.2011 10:34	-a--
libiconv--1.13.1--0.1.3.xzm	1.081.344	15.03.2011 16:05	-a--
libmspack-0.3alpha-x86_64-1hamza.xzm	102.400	20.06.2011 10:34	-a--
libnet-1.1.6-x86_64-1cf.xzm	196.608	01.02.2013 08:57	-a--
libnl-1.1-x86_64-1.xzm	118.784	01.02.2013 08:57	-a--
libpcap-1.3.0-x86_64-1.xzm	253.952	01.02.2013 08:57	-a--
libpng-1.4.5-x86_64-1.xzm	937.984	08.06.2011 17:31	-a--
libtasn1-2.12-x86_64-1.xzm	65.536	01.02.2013 10:53	-a--
libtheora-1.1.1-x86_64-1.xzm	335.872	01.02.2013 09:23	-a--
libvisual-0.4.0-x86_64-3.xzm	131.072	01.02.2013 09:23	-a--
lua-5.1.3.xzm	233.472	15.03.2011 16:05	-a--
lynx-cur-2.8.8dev.1-1.xzm	1.695.744	15.03.2011 16:05	-a--
nettle-2.5-x86_64-1.xzm	163.840	01.02.2013 08:59	-a--
netwatch-1.3.0-x86_64-2.xzm	86.016	01.02.2013 09:02	-a--
newsbeuter-2.5-x86_64-1gv.xzm	512.000	01.02.2013 08:49	-a--
newspost.xzm	32.768	15.03.2011 16:06	-a--
nmap-6.01-x86_64-2.xzm	4.317.184	01.02.2013 09:57	-a--
ntfs_progs-x86_64.xzm	278.528	15.03.2011 16:06	-a--
ntp-4.2.4p0-i486-1.xzm	1.290.240	15.03.2011 16:06	-a--
nzb-0.1.9.xzm	5.345.280	15.03.2011 16:06	-a--
nzbget-0.7.0-x86_64-1hamza.xzm	4.255.744	17.06.2011 21:26	-a--
nzbperl_64bit_porteus_addon.xzm	897.024	19.04.2011 12:44	-a--
nzbperl_SSL.xzm	729.088	15.03.2011 16:06	-a--
openjre-7u9_b30-x86_64-2alien.xzm	39.452.672	01.02.2013 09:49	-a--
openldap-client-2.4.31-x86_64-2.xzm	413.696	01.02.2013 09:58	-a--
opera-12.12-x86_64-1ro.xzm	15.413.248	01.02.2013 09:23	-a--
p11-kit-0.13-x86_64-1fg.xzm	69.632	01.02.2013 08:59	-a--
pan-0.139-x86_64-1.xzm	962.560	01.02.2013 09:46	-a--
portmap-5-0.xzm	24.576	15.03.2011 16:06	-a--
python-2.6.6-x86_64-1.xzm	13.320.192	11.12.2012 00:03	-a--
SABnzbd-0.7.11_64bit.xzm	2.359.296	13.02.2013 09:27	-a--
sqlite-3.5.8.xzm	1.003.520	15.03.2011 16:08	-a--
sshd-activate.xzm	4.096	15.03.2011 16:08	-a--
strace-4.5.20-x86_64-1.xzm	98.304	01.02.2013 09:51	-a--
stunnel-4.53-x86_64-1.xzm	122.880	01.02.2013 09:26	-a--
tcc-0.9.25.xzm	241.664	15.03.2011 16:08	-a--
tcl8.4.19.xzm	966.656	15.03.2011 16:08	-a--
tcpdump-4.3.0-x86_64-1.xzm	303.104	01.02.2013 09:26	-a--
teamviewer-7.0.9377-x86_64-1_SBo.xzm	13.234.176	01.02.2013 09:27	-a--
telnet-1.5.xzm	36.864	15.03.2011 16:08	-a--
tigervnc-1.1.0-x86_64-2alien.xzm	2.822.144	01.02.2013 10:25	-a--
tinyproxy.xzm	32.768	15.03.2011 16:08	-a--
upx-3.03.xzm	319.488	15.03.2011 16:08	-a--
uudeview-0.5.20-i486-1as.xzm	212.992	15.03.2011 16:08	-a--
vpnc-0.5.3.xzm	114.688	15.03.2011 16:08	-a--
wine-1.5.10-i486-1sl.xzm	17.920.000	13.09.2012 07:35	-a--
winetricks--20110429--0.1.4.xzm	110.592	04.01.2012 01:56	-a--
wxWidgets-2.9.4-x86_64-1sl.xzm	6.926.336	01.02.2013 09:56	-a--
xchat-2.8.8-x86_64.xzm	1.298.432	15.03.2011 16:09	-a--

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 11:26
by sgtpep
Skype installed from package skype_static- doesn't start on Porteus-XFCE-v2.0-x86_64.
Output from terminal:

Code: Select all

Fatal: QWidget: Must construct a QApplication before a QPaintDevice
/usr/bin/skype: line 19:  2350 Aborted                 LD_PRELOAD=/usr/share/skype/lib32/libv4l/ GCONV_PATH=/usr/share/skype/lib32/gconv QT_PLUGIN_PATH=/usr/share/skype/lib32/plugins /usr/share/skype/lib32/ --library-path /usr/share/skype/lib32/ /usr/share/skype/skype

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 11:28
by sgtpep
Porteus Package Manager does not resolve dependencies for packages from Debian repository. Tried to install openbox-3.5 package. Package itself installs fine, but PPM does not suggest to download dependencies.

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 12:52
by fanthom
i see many outdated and duplicated (included in the ISO) modules in your storage folder.

a) upgrade compat32 package to one from slackware-14.0:
b) drop duplicated modules: telnet, sqlite, ntfs_progs (merged with ntfs-3g)
d) upgrade ALL packages to slackware-14.0. this one: python-2.6.6-x86_64-1.xzm for sure comes from slackware-13.37

if that wont help then boot with 'always fresh' and download/activate teamviewer only, check how it behaves then.
if still troubling then check under other distro (Ubuntu?) as it may be also teamviewer fault itself.

a) skype woks fine here on 64bit XFCE. boot in 'always fresh' -> download skype through ppm, then launch
b) only deps for modules from porteus repo are resolved automatically.

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 13:14
by sgtpep
Tried many times to get the Skype working, but have the same issue. I run Porteus on VirtualBox, here's the system info OK, maybe it's a Skype bug.

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 20:29
by Hamza
Here is the solution about Skype bug. Didn't tried it but seems to works for Ubuntu Users. ... comments/7

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 22:47
by fanthom
i was able to recreate your issue on my dekstop (Xfce edition ran in Vbox). it worked on my laptop (also in Vbox) so must be a vbox settings issue or a skype bug.
i'm using this skype module with standard lxde/kde4 edition on my laptop (real session, not vbox) and never had any troubles...

could you download 64bit standard edition, run in in vbox and check if skype crashes in the same way?

Re: 64bit official Porteus repository bug reports

Posted: 28 Feb 2013, 23:26
by Hamza

I am also having this bug. I'm running 64bit KDE4 on a real session and I'm still not able to get it running. Did you tried to login one time after try to reboot and try to login once again. Why not downgrade to Slackware-13.37 version?

Re: 64bit official Porteus repository bug reports

Posted: 10 Mar 2013, 16:33
by Hamza
Here is a fix for Skype x86_64 launch bug. This fix must be installed with compat32 in order to works correctly. Reboot may be needed.


Re: 64bit official Porteus repository bug reports

Posted: 30 Mar 2013, 11:20
by miguipda

I encounter a border effect after having installed HPLIP package (that also installed 15 others packages).

Yesterday I installed Libreoffice and we watched some videos without problems.
This morning I installed HPLIP and configured my CUPS to be able to print to my network printer.

After a reboot I does not have sound on my computer.
I do not know if it comes from the Libreoffice or (certainly) after having installed the HPLIP package.

I tried to solve this by using the Porteus Settings Center (Sound settings) but it told me that "One or fewer sound card were detected on your system so this utility is not needed...." and said to post a message on this forum.
In the System Configuration - Matrial - Multimedia (Phonon) it well display the nVidia (HDA ALC889A) sound card.
When I boot it well display a form telling that the sound card has been "unexisting" (or removed) and ask if I must consider it as definitively removed or not and allow me to access the same window that the Phonon one.

I also tried to use the alsamixer and alsactl (where I initiate the sound card but never get it back).

How could I get it back ? I test all those thinks and reboot at each time and never get it back.

Sincerely thanks and have a nice day,

Miguipda ;-)

Re: 64bit official Porteus repository bug reports

Posted: 30 Mar 2013, 15:32
by miguipda

as I need to foind a solution for my sound problem I discovered the command line speaker-test.

Then I ran it on a konsole and listen that the speaker seems to open but does not play sound. And when I stop the command line I also listen it closed the speaker but I never heard any sound. And this even after trying to see a small video.

Pleas help me to get this sound card back to be abe to play normally.

Have a nice day,

Miguipda ;-)

Here is the returned result of this command line :

speaker-test 1.0.26

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 8192
Period size range from 1024 to 1024
Using max buffer size 8192
Periods = 4
was set period_size = 1024
was set buffer_size = 8192
0 - Front Left
Time per period = 2,833292
0 - Front Left