Porteus-v5.01 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
i3slkiller
Contributor
Contributor
Posts: 63
Joined: 03 Feb 2020, 18:51
Distribution: Porteus XFCE v5.0rc2 x86_64
Location: Poland

Porteus-v5.01 bug reports

Post#166 by i3slkiller » 06 May 2024, 13:14

Now after update creating python virtual environment without 05-devel fails

Code: Select all

guest@porteus:~$ cat /etc/porteus/*
001-core.xzm:20240429
002-xorg.xzm:20240429
002-xtra.xzm:20240301
003-openbox.xzm:20230922
initrd.xz:20230923
guest@porteus:~$ python3 -m venv /tmp/venv
Error: Command '['/tmp/venv/bin/python3', '-Im', 'ensurepip', '--upgrade', '--default-pip']' returned non-zero exit status 1.
guest@porteus:~$ ls /mnt/live/memory/images/
000-kernel.xzm/   001-core.xzm/
002-xorg.xzm/     002-xtra.xzm/
003-openbox.xzm/  004-vbox-guest-7.0.14-porteus-v5.01-x86_64-1prt.xzm/
guest@porteus:~$
EDIT:

Code: Select all

guest@porteus:~$ python3 -m venv /tmp/venv
Error: Command '['/tmp/venv/bin/python3', '-Im', 'ensurepip', '--upgrade', '--default-pip']' returned non-zero exit status 1.
guest@porteus:~$ /tmp/venv/bin/python3 -Im ensurepip --upgrade --default-pip
Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "/usr/lib64/python3.9/runpy.py", line 225, in run_module
    return _run_module_code(code, init_globals, run_name, mod_spec)
  File "/usr/lib64/python3.9/runpy.py", line 97, in _run_module_code
    _run_code(code, mod_globals, init_globals,
  File "/usr/lib64/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/__main__.py", line 31, in <module>
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/cli/main.py", line 68, in main
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/commands/__init__.py", line 114, in create_command
  File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 627, in _load_backward_compatible
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/commands/install.py", line 16, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/cli/req_command.py", line 21, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/index/package_finder.py", line 30, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/req/__init__.py", line 8, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/req/req_install.py", line 44, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_internal/operations/install/wheel.py", line 39, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_vendor/distlib/scripts.py", line 16, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl/pip/_vendor/distlib/compat.py", line 83, in <module>
  File "/usr/lib64/python3.9/xmlrpc/client.py", line 138, in <module>
    from xml.parsers import expat
  File "/usr/lib64/python3.9/xml/parsers/expat.py", line 4, in <module>
    from pyexpat import *
ImportError: /usr/lib64/python3.9/lib-dynload/pyexpat.cpython-39-x86_64-linux-gnu.so: undefined symbol: XML_SetReparseDeferralEnabled
Traceback (most recent call last):
  File "/usr/lib64/python3.9/runpy.py", line 197, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/lib64/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/usr/lib64/python3.9/ensurepip/__main__.py", line 5, in <module>
    sys.exit(ensurepip._main())
  File "/usr/lib64/python3.9/ensurepip/__init__.py", line 211, in _main
    return _bootstrap(
  File "/usr/lib64/python3.9/ensurepip/__init__.py", line 130, in _bootstrap
    return _run_pip(args + [p[0] for p in _PROJECTS], additional_paths)
  File "/usr/lib64/python3.9/ensurepip/__init__.py", line 39, in _run_pip
    return subprocess.run(cmd, check=True).returncode
  File "/usr/lib64/python3.9/subprocess.py", line 528, in run
    raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['/tmp/venv/bin/python3', '-I', '-c', '\nimport runpy\nimport sys\nsys.path = [\'/tmp/tmpexunzhn2/setuptools-58.1.0-py3-none-any.whl\', \'/tmp/tmpexunzhn2/pip-23.0.1-py3-none-any.whl\'] + sys.path\nsys.argv[1:] = [\'install\', \'--ignore-installed\', \'--no-cache-dir\', \'--no-index\', \'--find-links\', \'/tmp/tmpexunzhn2\', \'--upgrade\', \'setuptools\', \'pip\']\nrunpy.run_module("pip", run_name="__main__", alter_sys=True)\n']' returned non-zero exit status 1.
guest@porteus:~$ sudo activate /mnt/sda1/porteus/modules/05-devel.xzm 

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

For security reasons, the password you type will not be visible.

Password: 
Updating shared library links:  /sbin/ldconfig
Updating MIME database:  /usr/bin/update-mime-database /usr/share/mime
Updating GTK immodules: /usr/bin/update-gtk-immodules
Updating GDK pixbuf loaders: /usr/bin/update-gdk-pixbuf-loaders
Updating GDK pixbuf loaders: /usr/bin/update-gdk-pixbuf-loaders
Updating  menu: update-desktop-database
guest@porteus:~$ /tmp/venv/bin/python3 -Im ensurepip --upgrade --default-pip
Looking in links: /tmp/tmpzlnt124a
Processing /tmp/tmpzlnt124a/setuptools-58.1.0-py3-none-any.whl
Processing /tmp/tmpzlnt124a/pip-23.0.1-py3-none-any.whl
Installing collected packages: setuptools, pip
Successfully installed pip-23.0.1 setuptools-58.1.0
guest@porteus:~$ cat /etc/porteus/05-devel.ver 
05-devel.xzm:20240302
guest@porteus:~$ sudo deactivate /mnt/sda1/porteus/modules/05-devel.xzm 
Updating shared library links:  /sbin/ldconfig
Updating MIME database:  /usr/bin/update-mime-database /usr/share/mime
Updating GTK immodules: /usr/bin/update-gtk-immodules
Updating GDK pixbuf loaders: /usr/bin/update-gdk-pixbuf-loaders
Updating GDK pixbuf loaders: /usr/bin/update-gdk-pixbuf-loaders
Updating  menu: update-desktop-database
guest@porteus:~$ /tmp/venv/bin/python3 -Im ensurepip --upgrade --default-pip
Traceback (most recent call last):
  File "<string>", line 6, in <module>
  File "/usr/lib64/python3.9/runpy.py", line 225, in run_module
    return _run_module_code(code, init_globals, run_name, mod_spec)
  File "/usr/lib64/python3.9/runpy.py", line 97, in _run_module_code
    _run_code(code, mod_globals, init_globals,
  File "/usr/lib64/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/__main__.py", line 31, in <module>
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/cli/main.py", line 68, in main
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/commands/__init__.py", line 114, in create_command
  File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 627, in _load_backward_compatible
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/commands/install.py", line 16, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/cli/req_command.py", line 21, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/index/package_finder.py", line 30, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/req/__init__.py", line 8, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/req/req_install.py", line 44, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_internal/operations/install/wheel.py", line 39, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_vendor/distlib/scripts.py", line 16, in <module>
  File "<frozen zipimport>", line 259, in load_module
  File "/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl/pip/_vendor/distlib/compat.py", line 83, in <module>
  File "/usr/lib64/python3.9/xmlrpc/client.py", line 138, in <module>
    from xml.parsers import expat
  File "/usr/lib64/python3.9/xml/parsers/expat.py", line 4, in <module>
    from pyexpat import *
ImportError: /usr/lib64/python3.9/lib-dynload/pyexpat.cpython-39-x86_64-linux-gnu.so: undefined symbol: XML_SetReparseDeferralEnabled
Traceback (most recent call last):
  File "/usr/lib64/python3.9/runpy.py", line 197, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/lib64/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/usr/lib64/python3.9/ensurepip/__main__.py", line 5, in <module>
    sys.exit(ensurepip._main())
  File "/usr/lib64/python3.9/ensurepip/__init__.py", line 211, in _main
    return _bootstrap(
  File "/usr/lib64/python3.9/ensurepip/__init__.py", line 130, in _bootstrap
    return _run_pip(args + [p[0] for p in _PROJECTS], additional_paths)
  File "/usr/lib64/python3.9/ensurepip/__init__.py", line 39, in _run_pip
    return subprocess.run(cmd, check=True).returncode
  File "/usr/lib64/python3.9/subprocess.py", line 528, in run
    raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['/tmp/venv/bin/python3', '-I', '-c', '\nimport runpy\nimport sys\nsys.path = [\'/tmp/tmptlc_u5hw/setuptools-58.1.0-py3-none-any.whl\', \'/tmp/tmptlc_u5hw/pip-23.0.1-py3-none-any.whl\'] + sys.path\nsys.argv[1:] = [\'install\', \'--ignore-installed\', \'--no-cache-dir\', \'--no-index\', \'--find-links\', \'/tmp/tmptlc_u5hw\', \'--upgrade\', \'setuptools\', \'pip\']\nrunpy.run_module("pip", run_name="__main__", alter_sys=True)\n']' returned non-zero exit status 1.
guest@porteus:~$ 
EDIT2: Replacing /usr/lib64/python3.9/lib-dynload/pyexpat.cpython-39-x86_64-linux-gnu.so with one from older 001-core seems to fix this issue :hmmm:

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3975
Joined: 20 Mar 2012, 03:42
Distribution: v5.0-64bit
Location: australia
Contact:

Porteus-v5.01 bug reports

Post#167 by ncmprhnsbl » 06 May 2024, 23:02

i3slkiller wrote:
06 May 2024, 13:14
Replacing /usr/lib64/python3.9/lib-dynload/pyexpat.cpython-39-x86_64-linux-gnu.so with one from older 001-core seems to fix this issu
here's the relevant slackware changelog entry:

Code: Select all

patches/packages/python3-3.9.19-x86_64-1_slack15.0.txz:  Upgraded.
  This update fixes security issues:
  bundled libexpat was updated to 2.6.0.
  zipfile is now protected from the "quoted-overlap" zipbomb.
  tempfile.TemporaryDirectory cleanup no longer dereferences symlinks when
  working around file system permission errors.
  For more information, see:
    https://pythoninsider.blogspot.com/2024/03/python-31014-3919-and-3819-is-now.html
    https://www.cve.org/CVERecord?id=CVE-2023-52425
    https://www.cve.org/CVERecord?id=CVE-2024-0450
    https://www.cve.org/CVERecord?id=CVE-2023-6597
  (* Security fix *)
changed behavior of the bundled expat?
Ed_P wrote:
05 May 2024, 19:02
I like the updates to the new 001-core and 002-xorg 64bit modules ncmp. :good: Did the pmod & slapt-mod changes get made to other scripts also?
you mean --help not requiring root? not so far.
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 8435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.01 ISO
Location: Western NY, USA

Porteus-v5.01 bug reports

Post#168 by Ed_P » 06 May 2024, 23:21

ncmprhnsbl wrote:
06 May 2024, 23:02
you mean --help not requiring root?
:happy62:
Ed

i3slkiller
Contributor
Contributor
Posts: 63
Joined: 03 Feb 2020, 18:51
Distribution: Porteus XFCE v5.0rc2 x86_64
Location: Poland

Porteus-v5.01 bug reports

Post#169 by i3slkiller » 07 May 2024, 05:28

Okay, maybe that solution didn't seem particularly good for me, but I noticed something else:

Code: Select all

root@porteus:/home/guest# ls -l /mnt/live/memory/images/*/usr/lib64/libexpat*
lrwxrwxrwx 1 root root     17 Apr 29 07:33 /mnt/live/memory/images/001-core.xzm/usr/lib64/libexpat.so.1 -> libexpat.so.1.8.4*
-rwxr-xr-x 1 root root 190528 Apr 29 07:36 /mnt/live/memory/images/001-core.xzm/usr/lib64/libexpat.so.1.8.4*
lrwxrwxrwx 1 root root     17 Mar  2 07:58 /mnt/live/memory/images/05-devel.xzm/usr/lib64/libexpat.so -> libexpat.so.1.9.1*
lrwxrwxrwx 1 root root     17 Mar  2 07:58 /mnt/live/memory/images/05-devel.xzm/usr/lib64/libexpat.so.1 -> libexpat.so.1.9.1*
-rwxr-xr-x 1 root root 190616 Mar  1 19:07 /mnt/live/memory/images/05-devel.xzm/usr/lib64/libexpat.so.1.9.1*
Where does this discrepancy in the libexpat versions between 001-core and 05-devel come from (although I'm guessing that porteus creators just forgot to update expat)?

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3975
Joined: 20 Mar 2012, 03:42
Distribution: v5.0-64bit
Location: australia
Contact:

Porteus-v5.01 bug reports

Post#170 by ncmprhnsbl » 07 May 2024, 12:55

i3slkiller wrote:
07 May 2024, 05:28
Where does this discrepancy in the libexpat versions between 001-core and 05-devel come from (although I'm guessing that porteus creators just forgot to update expat)?
nice catch :0 thanks :)
ok, what's happening is libexpat in 001-core comes from aaa_libraries. (and 05-devel is from expat)
which is a slackware installation necessity so that it's there for stuff linked to it while the early packages are installed.
later in the process it's overwritten by the expat package.
which would be why the aaa_libs package hasn't been updated since any patch upgrade of expat comes later, after installation.
for the most part, apparently, that old libexpat has been/is fine for the stuff the needs it... until now.
now, why expat was put in devel instead of 001-core, i don't know.. i mean, it didn't matter much until expat patch updates started coming in, and now in particular this python update linking to it.
tldr: expat will be moved from 05-devel to 001-core.
(and the one in devel is also out of date :p )
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 8435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.01 ISO
Location: Western NY, USA

Porteus-v5.01 bug reports

Post#171 by Ed_P » 13 May 2024, 01:04

ncmprhnsbl » May 12th, 2024, 7:09 pm wrote:A small update for 001-core is now available (as of May 10)
Booting stops and requires me to signin as root to run startx. :o
Booted system doesn't have my /guest/home/ files & folders whether as my save.dat file or as my changes.xzm module. :(
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 8435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.01 ISO
Location: Western NY, USA

Porteus-v5.01 bug reports

Post#172 by Ed_P » 22 May 2024, 06:07

The 240511 001-core update works fine in the new 240521 Cinnamon ISO. :good:

Thank you ncmp. :)
Ed

User avatar
Ed_P
Contributor
Contributor
Posts: 8435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.01 ISO
Location: Western NY, USA

Porteus-v5.01 bug reports

Post#173 by Ed_P » 19 Jun 2024, 05:33

For some reason I've been getting locked out of adding/writing files to my NTFS drive. Not all the time but several times recently.

When I am done with my Windows work I boot to my Porteus-CINNAMON-v5.01-x86_64 system and things are normal but then hrs later, which means after I have closed the laptop's lid, I open the lid, enter my Porteus password and do stuff normally, then I go to copy a file to the NTFS drive and I can't. :crazy: :unknown: A major pain when I am in my Update mode, ie save.dat in use.

My system:

Code: Select all

~#  uname -a
Linux porteus.example.net 6.8.10-porteus #1 SMP PREEMPT_DYNAMIC Fri May 17 18:09:34 MSK 2024 x86_64 11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz GenuineIntel GNU/Linux

~#  cat /etc/porteus/*
001-core.xzm:20240511
002-xorg.xzm:20240511
002-xtra.xzm:20240511
003-cinnamon.xzm:20231229
initrd.xz:20230923

~#  ls -l /mnt/live/memory/images
000-kernel.xzm : May 17 11:31
001-core.xzm : May 11 01:59
002-xorg.xzm : May 11 02:04
002-xtra.xzm : May 11 02:06
003-cinnamon.xzm : Dec 29 00:05
07-printing-x86_64-2023-02-04.xzm : Feb 4 2023
Dell6.4.10-wifi.xzm : Aug 18 2023
Dellautonet.xzm : Dec 19 16:00
Dellsound.xzm : May 14 2022
firefox-122.0-x86_64-en-US.xzm : Jan 27 23:51
mychanges.xzm : Jun 15 02:41
wmctrl-1.07-x86_64-2salix15.0.xzm : Feb 6 11:54

~#  cat /proc/cmdline
quiet BOOT_IMAGE=(loop)/boot/syslinux/vmlinuz from=/ISOs/Porteus/Porteus-CINNAMON-v5.01-x86_64-240521.iso volume=33 reboot=cold extramod=/porteus5.0/Modules noload=kde;jinn;lxqt;xfce;lxde;mate;open;dat.xzm;menu2

ISO: /ISOs/Porteus/Porteus-CINNAMON-v5.01-x86_64-240521.iso
Added in 16 hours 24 minutes 19 seconds:
I have my power setting lock-on-suspend set to true, could it be that is causing the problem? Coming out of suspend mode isn't unlocking what was locked when the lid was closed? :%)
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3975
Joined: 20 Mar 2012, 03:42
Distribution: v5.0-64bit
Location: australia
Contact:

Porteus-v5.01 bug reports

Post#174 by ncmprhnsbl » 20 Jun 2024, 04:32

Ed_P wrote:
19 Jun 2024, 21:58
For some reason I've been getting locked out of adding/writing files to my NTFS drive.
1.is this an internal drive?
2.does it have windows on it?
3.is you save.dat on it? (sounds like)
4.is it mounted when suspending? (clearly if 3. is true)
Ed_P wrote:
19 Jun 2024, 21:58
I have my power setting lock-on-suspend set to true, could it be that is causing the problem? Coming out of suspend mode isn't unlocking what was locked when the lid was closed?
my understanding is lock-on-suspend just means the 'lock screen' is activated, maybe it does other stuff, but i wouldn't think so.
you could try turning this off and see if it makes a difference.
seems like it's remounting on resume as ready only .. ls -l on /mnt or /mnt/<your_drive>/ might give some insight..
that it doesn't occur consistently makes it hard to debug.
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Ed_P
Contributor
Contributor
Posts: 8435
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 5.01 ISO
Location: Western NY, USA

Porteus-v5.01 bug reports

Post#175 by Ed_P » 20 Jun 2024, 21:41

1. yes
2. yes
3. yes
4. :unknown: It was when booting.
ncmprhnsbl wrote:
20 Jun 2024, 04:32
my understanding is lock-on-suspend just means the 'lock screen' is activated
At this point I agree.
ncmprhnsbl wrote:
20 Jun 2024, 04:32
seems like it's remounting on resume as ready only .. ls -l on /mnt or /mnt/<your_drive>/ might give some insight..
Thank you, I will definitely try those commands.
ncmprhnsbl wrote:
20 Jun 2024, 04:32
that it doesn't occur consistently makes it hard to debug.
:shock: No!

It's only started in the past month or so. Maybe a 240521 ISO update problem. :unknown:

Added in 36 minutes 37 seconds:
What I see with things working.

Code: Select all

guest@porteus:~$ ls -l /mnt/
total 26
lrwxrwxrwx  1 root  root   21 Jun 20 06:39 isoloop -> /mnt/live/mnt/isoloop/
drwxr-xr-x 18 root  root  460 Jun 20 06:39 live/
drwxrwxrwx  4 guest root 2048 Dec 31  1969 nvme0n1p1/
drwxrwxrwx  1 guest root 8192 Jun 19 21:57 nvme0n1p3/
drwxrwxrwx  1 guest root 4096 Apr 24 14:11 nvme0n1p4/
drwxrwxrwx  1 guest root 4096 Apr 24 14:11 nvme0n1p5/
drwxrwxrwx  1 guest root 4096 Apr 24 14:11 nvme0n1p6/
drwxrwxrwx  1 guest root 4096 Jun 19 21:57 nvme0n1p7/
drwxrwxrwx  2 root  root   40 Jun 20 06:39 nvme0n1p8/
guest@porteus:~$ 
p1 - EFI
p2 - Microsoft reserved
p3 - OS (Windows 11)
p4 - ?
p5 - Image
p6 - Dell Support
p7 - Data - ISOs, /porteus5.0/changes/save.dat, /porteus5.0/Modules, /porteus5.0/Optionals, porteus5.0/Guest (bkups), etc
p8 - Backups - Windows 7 backups

Added in 1 hour 9 minutes 42 seconds:
It's happening. :x

Code: Select all

guest@porteus:~$ cp EFIdirs.txt /mnt/nvme0n1p7/
cp: cannot create regular file '/mnt/nvme0n1p7/EFIdirs.txt': Read-only file system
guest@porteus:~$ ls -l /mnt/
total 26
lrwxrwxrwx  1 root  root   21 Jun 20 06:39 isoloop -> /mnt/live/mnt/isoloop/
drwxr-xr-x 18 root  root  460 Jun 20 06:39 live/
drwxrwxrwx  4 guest root 2048 Dec 31  1969 nvme0n1p1/
drwxrwxrwx  1 guest root 8192 Jun 19 21:57 nvme0n1p3/
drwxrwxrwx  1 guest root 4096 Apr 24 14:11 nvme0n1p4/
drwxrwxrwx  1 guest root 4096 Apr 24 14:11 nvme0n1p5/
drwxrwxrwx  1 guest root 4096 Apr 24 14:11 nvme0n1p6/
drwxrwxrwx  1 guest root 4096 Jun 19 21:57 nvme0n1p7/
drwxrwxrwx  2 root  root   40 Jun 20 06:39 nvme0n1p8/
guest@porteus:~$ 
Added in 6 hours 41 minutes 15 seconds:
After working in Windows when I return to a fresh reboot of my Porteus system I see:

Code: Select all

guest@porteus:~$ cp EFIdirs.txt /mnt/nvme0n1p7/
guest@porteus:~$ 
Added in 9 hours 23 minutes 36 seconds:
After lid being closed overnight:

Code: Select all

guest@porteus:~$ cp EFIdirs.txt /mnt/nvme0n1p7/
guest@porteus:~$ 
Maybe when battery low the harddrive is put in read only mode then when notebook plugged in write mode isn't re-enabled? :hmmm:
Ed

Post Reply