Porteus-v5.0x86_64_bugs reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
Rava
Contributor
Contributor
Posts: 3949
Joined: 11 Jan 2011, 02:46
Distribution: XFCE 5.0 x86_64 + 4.0 i586
Location: Forests of Germany

Porteus-v5.0x86_64_bugs reports

Post#136 by Rava » 20 Sep 2022, 08:21

^
for now just try a different mirror (but not http://ftp.nluug.nl/os/Linux/distr/porteus since that lacks the updates ) - better a slightly slower download than a broken and useless one, yes?
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3575
Joined: 20 Mar 2012, 03:42
Distribution: v5.0-64bit
Location: australia
Contact:

Porteus-v5.0x86_64_bugs reports

Post#137 by ncmprhnsbl » 20 Sep 2022, 10:16

nanZor wrote:
20 Sep 2022, 08:17
Yep - you nailed it. The md5 for 001 on riken.jp is wrong.
Rava wrote:
20 Sep 2022, 08:21
or now just try a different mirror
actually, this time it's not a mirror issue, but my bad, i apparently messed up with that particular md5sum. a fix is in the works...
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 3949
Joined: 11 Jan 2011, 02:46
Distribution: XFCE 5.0 x86_64 + 4.0 i586
Location: Forests of Germany

Porteus-v5.0x86_64_bugs reports

Post#138 by Rava » 20 Sep 2022, 10:21

ncmprhnsbl wrote:
20 Sep 2022, 10:16
i apparently messed up with that particular md5sum. a fix is in the works...
Does that mean the two files are downloaded - one is not okay?
Or are both okay and only the server md5sum file is wrong?
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3575
Joined: 20 Mar 2012, 03:42
Distribution: v5.0-64bit
Location: australia
Contact:

Porteus-v5.0x86_64_bugs reports

Post#139 by ncmprhnsbl » 20 Sep 2022, 22:53

both okay and only the server md5sum file was wrong.
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 3949
Joined: 11 Jan 2011, 02:46
Distribution: XFCE 5.0 x86_64 + 4.0 i586
Location: Forests of Germany

Porteus-v5.0x86_64_bugs reports

Post#140 by Rava » 21 Sep 2022, 13:19

ncmprhnsbl wrote:
20 Sep 2022, 22:53
both okay and only the server md5sum file was wrong.
It would have been too much of an coincidence if I got a corrupted module but still both worked well for me for many weeks now.

Anyhow, any idea why the server I choose (because fastest-mirror told me its the fastest) http://ftp.nluug.nl/os/Linux/distr/porteus did have the relatively new yt-dlp module… but not the two updated 001-core.xzm and 002-xorg.xzm modules?
Is it something the server admins of ftp.nluug.nl should be told about?
Cheers!
Yours Rava

nanZor
Shogun
Shogun
Posts: 331
Joined: 09 Apr 2019, 03:27
Distribution: Porteus 5.0 x86-64 LXDE
Location: Los Angeles

Porteus-v5.0x86_64_bugs reports

Post#141 by nanZor » 22 Sep 2022, 21:09

Savefile Manager brings up empty config file

[UPDATE} This problem does not happen with the original 001 etc modules. It appears to be a problem with the latest updates that it is showing up.

Just noticed this with XFCE (haven't tested the others for this yet). If using the savefile manager gui, at the end of the process to edit the config file, instead of bringing up the config file, it just brings up an empty file with root access.

That might be confusing. Normally I do my editing with vi and a terminal, but the gui process used to bring up the file itself for the user to edit. Now it is just a blank empty one.

The quick solution is to bail out of the savefile manager when it asks you to edit the config file, and go to the Porteus Settings Centre to do it, which *does* bring up the proper config file to edit.

I could see this empty file being confusing for new users who don't know where the config file lives.

Anyone else see this?
[Update] does not happen with the original xzm core etc. Only seems to be with the 20220723 updates...
That's a UNIX book - cool. -Garth

User avatar
Ed_P
Contributor
Contributor
Posts: 7103
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 4.0 & 5.0 ISOs
Location: Western NY, USA

Porteus-v5.0x86_64_bugs reports

Post#142 by Ed_P » 22 Sep 2022, 21:51

Good catches guys. :good:
Ed

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3575
Joined: 20 Mar 2012, 03:42
Distribution: v5.0-64bit
Location: australia
Contact:

Porteus-v5.0x86_64_bugs reports

Post#143 by ncmprhnsbl » 23 Sep 2022, 00:03

nanZor wrote:
22 Sep 2022, 21:09
Anyone else see this?
[Update] does not happen with the original xzm core etc. Only seems to be with the 20220723 updates...
yes, in this update, i reverted to the old gtkdialog version(with some tweaks) and it doesn't pick up the environment variable for the boot device.. should be able to fix this and push it in the next update..

while i'm here: bug reported via irc: the magic folders gui doesn't function due to incomplete code .. also should be fixed in the next update. (probly, i'll just clean up the old gtkdialog version for now)
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

Post Reply