Porteus-v4.0 bug reports

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
Blaze
DEV Team
DEV Team
Posts: 1875
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current Xfce x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus-v4.0 bug reports

Post#31 by Blaze » 14 May 2018, 18:21

Hi tome,
can you show this log?

Code: Select all

dmesg | grep -i "mmc\|card\|error\|faile\|warn\|wireless"
Linux porteus 4.18.3-porteus #1 SMP PREEMPT Sat Aug 18 16:50:00 UTC 2018 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

raja
Samurai
Samurai
Posts: 134
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v4.0-rc1-64
Location: Chennai,India

Porteus-v4.0 bug reports

Post#32 by raja » 15 May 2018, 17:29

Porteus-4.0 tried with new Kernel-4.16.8, and Mate desktop.

Touchpad cursor works, but needed settings change in Mate for 'tap' option.

Still, problems with Network Manager,Pulse Audio,Reboot/Shutdown actions continue.

There is no Power icon or menu entry for shutdown/reboot/suspend commands. Only logout option is available in Mate. In LxQT too there was no action on shutdown/reboot as reported earlier.

Network Manager remains disabled. Nm indicates Network Manager is not running. There is no wireless enable option too. But interface 'wlan0' is there on 'ip' command. Start command for Network Manager from terminal says, it is running and a PID is given. There is a serious problem.

I don't have 'ethernet', only 'wifi' is available. So wireless enabling is a must in any distribution.

Syslog:
May 15 14:04:47 porteus NetworkManager[1224]: <warn> [1526393087.4833] keyfile: 'hostname' option is deprecated and has no effect
May 15 14:04:50 porteus console-kit-daemon[1303]: WARNING: Failed to open connection to cgmanager. Is the cgmanager daemon running?
May 15 14:24:19 porteus NetworkManager[1224]: <warn> [1526394259.3480] bus-manager: disconnected by the system bus
May 15 14:24:19 porteus ModemManager[1239]: <warn> Could not acquire the 'org.freedesktop.ModemManager1' service name
May 15 14:24:40 porteus kernel: [ 6.291269] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
May 15 14:24:42 porteus kernel: [ 7.275148] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
May 15 14:24:42 porteus kernel: [ 7.275245] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
May 15 14:24:42 porteus kernel: [ 7.275332] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-6.bin failed with error -2
May 15 14:24:44 porteus NetworkManager[1079]: <warn> [1526394284.0494] keyfile: 'hostname' option is deprecated and has no effect
May 15 14:24:45 porteus ck-launch-session: error connecting to ConsoleKit
May 15 14:24:45 porteus NetworkManager[1079]: <warn> [1526394285.6530] error poking ModemManager: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ModemManager1 was not provided by any .service files
May 15 14:24:46 porteus mate-session[1091]: WARNING: Could not connect to ConsoleKit: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
May 15 14:24:46 porteus mate-session[1091]: WARNING: Could not connect to ConsoleKit: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
May 15 14:24:46 porteus mate-session[1091]: WARNING: Unable to find provider '' of required component 'dock'
May 15 14:24:47 porteus pulseaudio[1183]: [pulseaudio] core-util.c: Failed to connect to system bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
May 15 14:24:47 porteus pulseaudio[1183]: [alsa-sink-ALC255 Analog] core-util.c: Failed to connect to system bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[1183]: [pulseaudio] bluez5-util.c: Failed to get D-Bus connection: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
May 15 14:24:47 porteus pulseaudio[1183]: [pulseaudio] module.c: Failed to load module "module-bluez5-discover" (argument: ""): initialization failed.
May 15 14:24:47 porteus pulseaudio[1183]: [pulseaudio] module.c: Failed to load module "module-bluetooth-discover" (argument: ""): initialization failed.
May 15 14:24:47 porteus pulseaudio[1183]: [pulseaudio] main.c: Module load failed.
May 15 14:24:47 porteus pulseaudio[1183]: [pulseaudio] main.c: Failed to initialize daemon.
May 15 14:24:47 porteus pulseaudio[1167]: [pulseaudio] main.c: Daemon startup failed.

Code: Select all

[    0.000000] Linux version 4.16.8-porteus (root@) (gcc version 7.3.0 (GCC)) #2 SMP PREEMPT Sun May 13 11:06:05 Local time zone must be set--
Disappointment continues......
Linux Kernel-4.4.120-32 bit; Linux kernel-4.15.7-64 bit.

tome
Contributor
Contributor
Posts: 621
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Porteus-v4.0 bug reports

Post#33 by tome » 15 May 2018, 18:04

Blaze wrote:
14 May 2018, 18:21
dmesg | grep -i "mmc\|card\|error\|faile\|warn\|wireless"
For working 4.15.10 kernel:

Code: Select all

[    0.045099] PCI: MMCONFIG for domain 0000 [bus 00-3f] at [mem 0xf8000000-0xfbffffff] (base 0xf8000000)
[    0.045106] PCI: MMCONFIG at [mem 0xf8000000-0xfbffffff] reserved in E820
[    0.081606] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    0.244838] wbsd: Winbond W83L51xD SD/MMC card interface driver
[    0.247917]   No soundcards found.
[    1.153300] mmc0: cannot verify signal voltage switch
[    1.197109] usb 1-1.5: Manufacturer: Sierra Wireless Inc
[    1.261388] mmc0: new ultra high speed SDR104 SDXC card at address 0007
[    1.261532] mmcblk0: mmc0:0007 SD64G 57.9 GiB 
[    1.262021]  mmcblk0: p1 p2
[    1.786747] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[    1.808584] EXT4-fs (mmcblk0p2): mounted filesystem without journal. Opts: (null)
[    7.035918] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[    7.035920] cfg80211: failed to load regulatory.db
[    7.074070] Intel(R) Wireless WiFi driver for Linux
[    7.380218] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[    7.380260] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
[    7.380299] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input16
[    7.380336] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input17
[    8.733415] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0489-e052.hcd failed with error -2
Whole output is in earlier post.
No intelligence, no life and no information can exist without prior intelligence, life or information (in place where things change and time is running).

tome
Contributor
Contributor
Posts: 621
Joined: 26 Jun 2013, 14:03
Distribution: x64 Openbox
Location: Poland
Contact:

Porteus-v4.0 bug reports

Post#34 by tome » 15 May 2018, 19:22

brokenman wrote:
06 May 2018, 13:12
Missing kernel module?
I think below things should be compiled in kernel and not as modules (searching for porteus dir or sgn file is before mounting 000-kernel):
CONFIG_MEMSTICK_REALTEK_PCI=y
CONFIG_MEMSTICK_REALTEK_USB=y
vs
CONFIG_MEMSTICK_REALTEK_PCI=m
CONFIG_MEMSTICK_REALTEK_USB=m
No intelligence, no life and no information can exist without prior intelligence, life or information (in place where things change and time is running).

User avatar
brokenman
Site Admin
Site Admin
Posts: 5887
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Porteus-v4.0 bug reports

Post#35 by brokenman » 16 May 2018, 19:59

@Tome yes I am also thinking this. I will try it out.

@Raja

Code: Select all

May 15 14:24:42 porteus kernel: [ 7.275332] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-6.bin failed with error -2
This is the firmware you requested I add to the firmware package. Does it recognize the card when you use the full firmware package from slackware?
The change of kernel will only address your network and mouse issues.

Added in 1 day 4 hours 37 minutes 39 seconds:
Another thing Raja,

Are you using just the stock Porteus-v4.0 ISO with no extra modules or changes in your install? I would like to see the information dump from Porteus Settings Centre if possible.
How do i become super user?
Wear your underpants on the outside and put on a cape.

beny
Full of knowledge
Full of knowledge
Posts: 742
Joined: 02 Jan 2011, 11:33
Location: italy

Porteus-v4.0 bug reports

Post#36 by beny » 18 May 2018, 09:02

raja i have an acer with this wifi controller do not exist a linux driver for slackware and also arch search for a driver version that not exist so when i use wifi with this laptop i have a wifi dongle.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4800
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Porteus-v4.0 bug reports

Post#37 by fanthom » 18 May 2018, 09:19

@beny
This wifi chipset is really popular. I would be surprised to not see it working with linux.

Please use these firmwares which are available in the kernel firmware package:

Code: Select all

/lib/firmware/ath10k/QCA9377/hw1.0/board.bin
/lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin
Should be ok then.
Please add [Solved] to your thread title if the solution was found.

raja
Samurai
Samurai
Posts: 134
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v4.0-rc1-64
Location: Chennai,India

Porteus-v4.0 bug reports

Post#38 by raja » 18 May 2018, 11:08

Hi All,

Cheers...

All problems vanished like thin ice, when I added APPEND norootcopy, in porteus.cfg.

1)My WiFi was listed ,connected. No "network disabled' message. Happy surfing!
2)No complications with "Pulse Audio"...No " failed to connect" error. Happy listening!
3) Logout, Screen Lock,Power off buttons came to life in the "Menu". Happy Shutdown/Reboot/Suspend!

So, problem lies with the init script related to managing "rootcopy" folder. Please look into, how this interferes, during the boot process., and affects 'network','audio'.
A clue here, without 'norootcopy' cheatcode , screen is filled with , /root,/dev,/sys,/proc,/opt,/run,/var.... icons.

Now , only expected icons are there.

Missing folder in firmware... could be , you are using a very fast machine for compiling ( neko's scripts rush like meteors) or I heard about the importance of -r in cp command in terminal. (recursive).

Thanks to all. Smile again!
Linux Kernel-4.4.120-32 bit; Linux kernel-4.15.7-64 bit.

raja
Samurai
Samurai
Posts: 134
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v4.0-rc1-64
Location: Chennai,India

Porteus-v4.0 bug reports

Post#39 by raja » 18 May 2018, 17:51

Forgot to say, 'rootcopy' folder is empty. Apart from 4 base modules, I have added only Opera.
Linux Kernel-4.4.120-32 bit; Linux kernel-4.15.7-64 bit.

jssouza
DEV Team
DEV Team
Posts: 619
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Porteus-v4.0 bug reports

Post#40 by jssouza » 19 May 2018, 03:10

raja, is your rootcopy directory in an ext4 filesystem?
As root, please provide the output of

Code: Select all

ls -l $PORTDIR/

raja
Samurai
Samurai
Posts: 134
Joined: 02 May 2017, 09:51
Distribution: v3.2.2-32 and v4.0-rc1-64
Location: Chennai,India

Porteus-v4.0 bug reports

Post#41 by raja » 19 May 2018, 09:24

Yes, porteus-4.0/porteus folder is in ext4 fs.

Code: Select all

[root@porteus:/home/guest# ls -l $PORTDIR/

total 28
drwx------  3 guest users 4096 May 18 13:42 base/
drwxr-xr-x 12 root  root  4096 May 19 11:57 changes/
-rw-r--r--  1 guest users 1015 Apr 29 11:12 make_iso.sh
drwx------  2 guest users 4096 May 19 00:43 modules/
drwx------  2 guest users 4096 Apr 29 11:12 optional/
-rw-r--r--  1 guest users  685 May  9 09:47 porteus-v4.0-x86_64.cfg
drwx------  3 guest users 4096 May 18 14:17 rootcopy/
boot info:

Code: Select all

[    0.000000] microcode: microcode updated early to revision 0x84, date = 2018-01-21
[    0.000000] Linux version 4.16.8-porteus (root@) (gcc version 7.3.0 (GCC)) #2 SMP PREEMPT Sun May 13 11:06:05 Local time zone must be set--
[    0.000000] Command line: BOOT_IMAGE=/boot/syslinux/vmlinuz-4.16.8 nomagic norootcopy changes=/porteus-4.0/porteus initrd=/boot/syslinux/intel-ucode.img,/boot/syslinux/initrd-4.0.xz
Added changes/ today, as everything is working fine.
Linux Kernel-4.4.120-32 bit; Linux kernel-4.15.7-64 bit.

jssouza
DEV Team
DEV Team
Posts: 619
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm
Location: Liechtenstein

Porteus-v4.0 bug reports

Post#42 by jssouza » 19 May 2018, 10:18

Looks like your rootcopy directory has wrong permissions. It should be owned by root:root and with permissions of 0755. Same as that of your changes directory.
If norootcopy cheatcode is not explicitly specified, init copies rootcopy directory contents even if it is empty. I guess this makes your top level directory (/) as either owned by guest and/or has no executable permissions set for group and other, leading to the problems you mentioned.
Please check this from a terminal by booting without the norootcopy cheatcode, then as root run:

Code: Select all

ls -ld /

alexgorr
White ninja
White ninja
Posts: 27
Joined: 23 Nov 2011, 12:48
Location: italy

Porteus-v4.0 bug reports

Post#43 by alexgorr » 19 May 2018, 14:40

1) it seems that it is not possible to mount more than 126 xzm loops (in the previous version I mount more than 300)
"The message no more space left on device"
/opt/porteus-scripts/xorg/aufs-insert
line
if [ $? -ne 0 ]; then echo "$BASE: Can't insert module to union"; umount $MOD; rmdir $MOD; exit 5; fi
some goes wrong because in previous version all works fine.

2) arrow keys do not work in gnome terminal, but in xterm yes

Have a good work !

User avatar
Ed_P
Contributor
Contributor
Posts: 4017
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus-v4.0 bug reports

Post#44 by Ed_P » 19 May 2018, 16:21

What version of Porteus did you download alexgorr? :unknown:
Ed

M. Eerie
Samurai
Samurai
Posts: 102
Joined: 31 Aug 2017, 21:18
Distribution: APorteus BUDGIE x64

Porteus-v4.0 bug reports

Post#45 by M. Eerie » 19 May 2018, 16:26

jssouza wrote:
02 May 2018, 19:57
M. Eerie wrote:
02 May 2018, 19:40
Ok, I understand. Can't it be activated via right-menu?
Yes you can. Right click and select "Open With Activate"
Stupid me. I was overwriting the script from an old custom module. :oops:

Thanks.

Post Reply