Need Help... black screen USB install...

Share your opinion about Porteus Kiosk Edition.
Post Reply
mjohnsonsa
White ninja
White ninja
Posts: 6
Joined: 22 Jan 2019, 14:39
Distribution: 4.0

Need Help... black screen USB install...

Post#1 by mjohnsonsa » 20 Mar 2019, 07:24

I am trying to install porteus kiosk on a Beelink Gemini N41 MiniPC which only supports UEFI boot. After using Win32DiskImager to burn the ISO image to the USB stick I boot up the Beelink from USB and just get a solid black screen with a solid white (non blinking) cursor in the upper left corner. I have spent most of the day trying various things (alternate burns to USB using 'dd', on a mac, different USB sticks, etc.). I can burn and install Ubuntu just fine on the MiniPC so I know it supports linux. I also know the MiniPC only supports UEFI and not legacy BIOS booting but it looks like Porteus Kiosk is supposed to support UEFI? I also burned a USB install of Porteus OS and it booted fine too, just the Porteus Kisok giving me the black screen almost immediately when trying to boot.

Anyone have an idea what is happening and how I can resolve the issue and boot from the Kiosk boot disk?

Matt

User avatar
fanthom
Site Admin
Site Admin
Posts: 5089
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Need Help... black screen USB install...

Post#2 by fanthom » 20 Mar 2019, 13:49

Matt,

I think kiosk kernel is crashing on your hardware. Please remaster the ISO:
https://porteus-kiosk.org/kiosk-customization.html

and add 'debug' flag to /boot/isolinux/isolinux.cfg in the 'append' line so it would look like here:
append initrd=/boot/initrd.xz quiet first_run debug

Please post a link to the photo so we could see whats visible on the screen once kernel crashes.

Thansk
Please add [Solved] to your thread title if the solution was found.

mjohnsonsa
White ninja
White ninja
Posts: 6
Joined: 22 Jan 2019, 14:39
Distribution: 4.0

Need Help... black screen USB install...

Post#3 by mjohnsonsa » 20 Mar 2019, 14:19

Okay, I followed the instructions but it is not printing out any debugging information on the screen. As soon as I boot with the remastered ISO it goes to the black screen with white cursor. I made sure when remastering the ISO to use the isohybrid -u for EFI as well. I did notice when going in the BIOS setup to the boot override that the USB is listed twice, the second entry shows the Partition. I tried booting to both entries but no change.

User avatar
fanthom
Site Admin
Site Admin
Posts: 5089
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Need Help... black screen USB install...

Post#4 by fanthom » 20 Mar 2019, 17:51

Please boot any working linux on this PC, download and run this script:
https://porteus-kiosk.org/public/files/debug.sh

then send generated report to support@porteus-kiosk.org.

Thank you.
Please add [Solved] to your thread title if the solution was found.

mjohnsonsa
White ninja
White ninja
Posts: 6
Joined: 22 Jan 2019, 14:39
Distribution: 4.0

Need Help... black screen USB install...

Post#5 by mjohnsonsa » 20 Mar 2019, 23:29

Thanks Fanthom, I just emailed the results file from the debug.sh script. Would appreciate any help you can provide. I have spent a lot of time trying to troubleshoot myself and try different things and am not having any luck...

Matt

Post Reply