Intermittent "device not ready yet" messages on NUC

Share your opinion about Porteus Kiosk Edition.
Post Reply
thewiz
White ninja
White ninja
Posts: 4
Joined: 08 Oct 2017, 16:53
Distribution: Ubuntu

Intermittent "device not ready yet" messages on NUC

Post#1 by thewiz » 27 Dec 2017, 13:53

Hi!

I don't know if this is a bug or some other problem, so I'll start here.

I've been trying to install Porteus Kiosk 4.5.0 on two Intel NUCs (specifically an oldish Celeron based NUC4CPYH and a fairly modern 7th gen i3-based NUC7i3BNK). I burn the installer image onto a USB (tried a few different ones), boot, configure and install on to that same USB stick. The initial boot of the "installer" always works. When I reboot after installation to run the kiosk, it typically works OK the first time; browser loads, and shows the specified URL. If I then shut down and reboot, this occasionally may work again, but often results in an error message:

device not ready yet?

with a countdown, followed by a "Error: Kiosk data not found". If I then reboot, I sometimes get the same error, but occasionally it boots up correctly. So it's not like the USB stick got damaged or corrupt for some reason, as it sometimes boots and works OK just by rebooting. My configuration is as follows:

connection=wired
dhcp=yes
browser=chrome
homepage_append=mac
homepage=http://10.0.2.10/index.html
hide_mouse=yes
disable_navigation_bar=yes
disable_private_mode=yes
wake_on_lan=yes
disable_zoom_controls=yes
additional_components=uefi.zip

Any ideas of what may be causing this? Anything I can check or look at to obtain better information?

-JM

User avatar
fanthom
Site Admin
Site Admin
Posts: 4779
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Intermittent "device not ready yet" messages on NUC

Post#2 by fanthom » 27 Dec 2017, 18:45

Hi JM,

I guess the PC has troubles with initializing the usb device (too many devices connected to the same hub?).

When you get "Kiosk data not found" error then please drop to the debug shell (press 'd') and run following command:

Code: Select all

blkid
If your usb stick is still not discovered then please swap usb port (move from usb 3.0 to usb 2.0 if possible) and run 'blkid' again.
You may get additional info by running 'dmesg' command.

Thanks
Please add [Solved] to your thread title if the solution was found.

thewiz
White ninja
White ninja
Posts: 4
Joined: 08 Oct 2017, 16:53
Distribution: Ubuntu

Intermittent "device not ready yet" messages on NUC

Post#3 by thewiz » 29 Dec 2017, 16:20

I used another USB stick. This time USB 2 instead of USB 3. This seems to have fixed the problem (at the expense of longer start-up time). I found this somewhat odd. If the computer is USB3 compatible, and boots the "installer" every time from USB3, why wouldn't it boot the istalled kiosk stick?

Anyway, I'm fine here for now. Many thanks for your prompt reply.

-JM

User avatar
fanthom
Site Admin
Site Admin
Posts: 4779
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Intermittent "device not ready yet" messages on NUC

Post#4 by fanthom » 30 Dec 2017, 08:26

Installation ISO uses isolinux as the bootloader while installed kiosk uses GRUB (so we can have persistent partition).
Maybe isolinux handles USB 3.0 sticks better?

I have not enough knowledge to provide definite answer.

You could also switch to legacy BIOS booting method (disable EFI) and check if that helps in the USB 3.0 case.

Thanks
Please add [Solved] to your thread title if the solution was found.

Post Reply