Search found 168 matches

by rych
10 Mar 2017, 06:00
Forum: Newbie questions
Topic: changing HOSTNAME results in "No protocol specified" at boot
Replies: 2
Views: 1076

changing HOSTNAME results in "No protocol specified" at boot

In Porteus 3.2.2 64 XFCE, when I use this script https://forum.porteus.org/viewtopic.php?f=39&t=6015 or manually edit the /etc/HOSTNAME file, and reboot, I receive a long list of "No protocol specified" messages at boot time, and it won't boot Xorg for a long while then. It eventually starts the GUI...
by rych
03 Mar 2017, 03:52
Forum: Bug Reports
Topic: USM bug reports
Replies: 528
Views: 127279

Re: USM bug reports

Porteus 3.2.2 64 XFCE the following downloads a few files until it tries to download LIBS.TXT.gz. This one fails, the file has 0 size, hence the error: #usm -u all ... ... Using proxy server: ... Downloading: LIBS.TXT.gz DONE File verification was good. gzip: /var/usm/slackware/LIBS.TXT.gz: unexpect...
by rych
20 Feb 2017, 07:13
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Solution: 1. Boot as usual with your stock Porteus, no need to change the kernel or e1000e. 2. The network will be trying and complaining that it can't connect 3. While it's still trying, simply execute the script resetting the PCI: #!/bin/bash #Get the PCI-Address of network card (Caution: This wo...
by rych
19 Feb 2017, 06:11
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Good news: it works! The combination of the new kernel/e1000e, resetting eth0, dhcp with resetting PCI inbetween (I suspect this is the key) gave me an IP address and a DHCP connection. I'm now going to try to narrow this result down to the necessary ingredient(s) only and will post the final, minim...
by rych
18 Feb 2017, 11:57
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Tomorrow I'm going to try your v4.9.10.tar.xz then. Also, I'm going to run the script at the end of this page https://bbs.archlinux.org/viewtopic.php?id=191981 just before bringing the eth0 up again.
by rych
18 Feb 2017, 05:47
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

OK, thanks to @neko, I've now tested his new v4.10-rc8+e1000e-3.3.5.3 kernel, (booted always fresh, confirmed that the new kernel and e1000e-3.3.5.3 were in fact loaded, tried the same commands to restart-re-enforce the eth0 and dhcp) but unfortunately DHCP doesn't connect anyway -- no difference in...
by rych
17 Feb 2017, 03:32
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

@neko
Could you upload somewhere either the UP.Porteus-XFCE-v3.2.2-x86_64.iso or, if it's too big, only the vmlinuz & 000-kernel.xzm? I'm back in the office and can now try it.
Thanks
by rych
13 Feb 2017, 06:11
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Thanks @neko, for building the e1000e-3.3.5.3. I've downloaded a fresh copy of the iso I use, Porteus-XFCE-v3.2.2-x86_64.iso and tried to patch it with your Porteus Kernel Builder. But I can't select the kernel version in the GUI and then it doesn't run, because it complains that the kernel version ...
by rych
12 Feb 2017, 05:03
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

With the e1000e replaced to 3.3.5.3-NAPI, which works on the l219 machine fine, on the problem l217 I first find out which ethX device the eth0 got renamed to, if any: root@porteus:~# ifconfig eth0 down eth0: ERROR while getting interface flags: No such device root@porteus:~# dmesg | grep -e eth -e ...
by rych
11 Feb 2017, 04:54
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Here is my sequence and the output, /etc/rc.d/rc.networkmanager stop ifconfig eth1 down ifconfig eth1 up dhcpcd eth1 : DUID 00:01:00:01:20:2b:71:b2:74:e6:e2:e2:83:3a eth1: IAID e2:e2:83:3a eth1: soliciting a DHCP lease eth1: soliciting an IPv6 router eth1: using IPv4LL address 169.254.156.56 eth1: a...
by rych
10 Feb 2017, 00:18
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Code: Select all

dhclient eth0
produced no output. It returned in about half a minute.
I'm not allowed to set up a static IP on this machine.
Will try your the ubuntu Live CD (from a usb) later.
by rych
09 Feb 2017, 05:26
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Wait ~10 seconds and then see output of ifconfig eth0 if you got an IP address like --> inet 192.168.xxx.xx ... if not, try dhclient eth0 to force getting an address. OK, I've tried again running (with 10 sec intervals) /etc/rc.d/rc.networkmanager stop ifconfig eth0 down ifconfig eth0 up dhcpcd eth...
by rych
06 Feb 2017, 13:20
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

I thought I already got a proper IP with dhcpcd eth0 ...eth0: using IPv4LL address 168.254.156.56 Or is it wrong? Must be wrong, because having it doesn't bring up the network anyway. I'll check that IP again tomorrow with a 10 sec wait and ifconfig eth0 or ip addr show | grep inet, and then dhclien...
by rych
06 Feb 2017, 05:06
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

Not sure if you guys are telling me to replace the e1000e or not, so I did what @frederick suggested for both shipped (3.2.6-k) and new one that I'd built, 3.3.5.3. The result is negative in both cases anyway. /etc/rc.d/rc.networkmanager stop (*double checked) ifconfig eth0 down ifconfig eth0 up dhc...
by rych
04 Feb 2017, 05:07
Forum: Newbie questions
Topic: [SOLVED] no connection with Intel Ethernet I217-LM
Replies: 43
Views: 10578

Re: no connection with Intel Ethernet Connection I217-LM

I'v replaced the e1000e with teh new one that I had built and restarted. It got picked up, according to modinfo, but the network is still not working. Logs show that e1000e: eth1 Nic Link is up 100 Mbps, but then also NetworkManager:dhcp4(eth1) request timeout and Activation failed.