Search found 25 matches

by tom2238
23 Mar 2020, 22:14
Forum: Intermediate/Advanced User Questions
Topic: Old Dell Latitude D610 Wireless missing
Replies: 61
Views: 3426

Old Dell Latitude D610 Wireless missing

Hi.
Maybe it is similar problem (Porteus 3.2.2, 32bit, MATE desktop):
https://ctrlv.cz/Z1ER

Try my modification now Old Dell Latitude D610 Wireless missing (Post by tom2238 #76416)
by tom2238
20 Mar 2020, 14:19
Forum: Intermediate/Advanced User Questions
Topic: Old Dell Latitude D610 Wireless missing
Replies: 61
Views: 3426

Old Dell Latitude D610 Wireless missing

Hi I have this laptop and successfully using Porteus 3.2.2 with 4.9.0-porteus kernel. guest@porteus:~$ uname -a Linux porteus 4.9.0-porteus #1 SMP PREEMPT Sun Dec 18 16:24:27 Local time zone must be set-- i686 Intel(R) Pentium(R) M processor 2.00GHz GenuineIntel GNU/Linux guest@porteus:~$ dmesg | gr...
by tom2238
14 Mar 2020, 22:48
Forum: Newbie questions
Topic: Problem with activating XZM in changes directory
Replies: 8
Views: 864

Problem with activating XZM in changes directory

Thanks roadie for your ideas. I follow this steps: 1 - Run mkKernel 2 - Select location, kernel version, arch, download, expand & patch => click OK and wait 3 - Add aufs4-loopback.patch manually 4 - Modify kernel config using make menuconfig & save 5 - Run mkKernel again 6 - Select location, kernel ...
by tom2238
14 Mar 2020, 12:25
Forum: Newbie questions
Topic: Problem with activating XZM in changes directory
Replies: 8
Views: 864

Problem with activating XZM in changes directory

roadie wrote:
13 Mar 2020, 22:51
I ended up patching the kernel by hand and was able to get a combination that worked. I found the best way was to apply the minimum number of patches needed to work. I also used only the base patches, nothing else.
Top
By hand do you mean manually edit c and h kernel files (add patch diffs)?
by tom2238
13 Mar 2020, 20:59
Forum: Newbie questions
Topic: Problem with activating XZM in changes directory
Replies: 8
Views: 864

Problem with activating XZM in changes directory

So, in dmesg is too:

Code: Select all

[83378.170165] aufs au_warn_loopback:123:loop96[18623]: you may want to try another patch 
for loopback file on ext4(0xef53) branch
For kernel compilation I used mkKernel-20-02-10-xz-noarch.xzm and proceed with default options without any user patches.
by tom2238
12 Mar 2020, 12:06
Forum: Newbie questions
Topic: Problem with activating XZM in changes directory
Replies: 8
Views: 864

Problem with activating XZM in changes directory

Hi all. I have this problem: When I use kernel from distribution iso (4.9.0 from 3.2.2 version and 4.16.3 from 4.0 version), I can activate XZMs which is located anywhere. If I compile custom kernel (eg. 4.9.162 and 4.9.216) using mkKernel, then I can activate only XZMs which is located out of AUFS ...
by tom2238
09 Mar 2020, 12:26
Forum: Newbie questions
Topic: init=/bin/bash resistance?
Replies: 3
Views: 1335

init=/bin/bash resistance?

If I tried use init=/bin/bash on Ubuntu with systemd, I got the root shell. When trying tutorial: https://linuxconfig.org/how-to-reset-lost-root-password-on-ubuntu-16-04-xenial-xerus-linux. initrd.xz file used in Porteus contain: drwxr-xr-x 2 root root 4096 dub 16 2016 bin/ -rwxr-xr-x 1 root root 40...
by tom2238
29 Jan 2020, 14:45
Forum: Newbie questions
Topic: init=/bin/bash resistance?
Replies: 3
Views: 1335

init=/bin/bash resistance?

Hi. I tried to find out if bootchartd (https://wiki.archlinux.org/index.php/Bootchart) works in Porteus. It looks like it works, but the bootchard is started using init=/sbin/bootchartd . The system starts normally. And now my findings. If I boot with init=/bin/bash parameter, the terminal (bash) do...
by tom2238
18 Jan 2020, 13:57
Forum: Newbie questions
Topic: x-gvfs-show 0 0 sometimes missing in fstab
Replies: 0
Views: 1017

x-gvfs-show 0 0 sometimes missing in fstab

Hi all. Sometimes when I start the system some desktop icons are missing on the desktop and in the file manager. It happens only sometimes and it is different partitions on the disk. The partition is mounted. The file /etc/fstab contains: # Do not edit this file as fstab is recreated automatically d...
by tom2238
12 Jan 2020, 12:34
Forum: Newbie questions
Topic: What is your porteus.cfg default?
Replies: 7
Views: 3360

What is your porteus.cfg default?

Hi.
Now I use:

Code: Select all

APPEND initrd=initrd.xz from=/dev/sda6 nocd zram=5% changes=/mnt/sda1/ timezone=Europe/Warsaw noload=000-lxde extramod=/mnt/sda1/porteus/modules/
by tom2238
11 Jan 2020, 23:56
Forum: Newbie questions
Topic: Disk icon - autorun.inf
Replies: 0
Views: 1007

Disk icon - autorun.inf

Hello. I noticed that I can change the disk icon on the desktop. It works with windows-like file autorun.inf. Is it a feature of MATE desktop or Caja? It looks nice when each disk can have its own icon. The disk.ico file itself does not work. For other distributions, I didn't notice this feature. [a...
by tom2238
16 Oct 2019, 15:22
Forum: Newbie questions
Topic: Run 64bit app on 32bit system
Replies: 4
Views: 728

Run 64bit app on 32bit system

Hi. XIlinx ISE 14.7 running good to. Module with libraries: porteus_3.2.2-multilib_amd64.xzm https://drive.google.com/file/d/14k1Wok ... sp=sharing
by tom2238
09 Oct 2019, 20:24
Forum: Newbie questions
Topic: Run 64bit app on 32bit system
Replies: 4
Views: 728

Run 64bit app on 32bit system

I tried this: - copy /usr/lib64/ and /lib64/ from 001-core.xzm (64bit) copy /usr/lib64/ and /lib64/ from 002-xorg.xzm (64bit) to folder and create module from it. - activate module (only 64bit libraries) in 32 bit userspace - modify /etc/ld.so.conf /lib /lib/i386-linux-gnu /usr/lib /usr/local/lib /u...
by tom2238
08 Oct 2019, 19:54
Forum: Newbie questions
Topic: Run 64bit app on 32bit system
Replies: 4
Views: 728

Run 64bit app on 32bit system

Hi all.
I would like to run some 64bit applications (eg. Matlab) with 64bit kernel, but with 32bit userspace. On some forums I was read it is possible. Can Porteus do it? Can I copy libraries from 001-core.xzm (64bit) to 32bit system?
by tom2238
02 Oct 2019, 15:40
Forum: Newbie questions
Topic: Caja - Unmount USB stick failed
Replies: 12
Views: 1545

Caja - Unmount USB stick failed

So, if USB stick connected to /mnt/sdc1 and device is /dev/sdc1, working without problem. Maybe problem with udev config?