Search found 25 matches

by biotec
08 Oct 2019, 20:25
Forum: Bug Reports
Topic: Porteus v5.0rc1 problems
Replies: 179
Views: 20951

Porteus v5.0rc1 problems

Hello porteus people, Stritcly speaking, what I am reporting is not a porteus5 problem, but people still using porteus4 with the default kernel will not have it, and in any case, I believe the solution should be devised with porteus5 in mind. Tje problem is that using recently built kernels, porteus...
by biotec
11 Jul 2018, 16:10
Forum: Development
Topic: gcc-gfortran for porteus v4.0
Replies: 3
Views: 1168

gcc-gfortran for porteus v4.0

Hello, my problem is similar in that I need gcc-gfortran too, but slackware-current has now switched to gcc 8.1.1, so getpkg gcc-gfortran installs version 8.1.1. I cannot found the gcc-gfortran 7.3.0 slackware packages anywhere, all slackware mirrors I visited store gcc 8.1.1 and gcc 7.3.0 for slack...
by biotec
23 Jan 2017, 23:00
Forum: Intermediate/Advanced User Questions
Topic: Invalid argument
Replies: 42
Views: 6908

Re: Invalid argument

I must update myself: as expected, Neko has already updated his work! :beer:
by biotec
23 Jan 2017, 22:52
Forum: Intermediate/Advanced User Questions
Topic: Invalid argument
Replies: 42
Views: 6908

Re: Invalid argument

As Bogomips states, only vmlinuz/bzImage is modified by the patch. However, I am compiling my own kernels with different settings that fit my needs, not Neko kernels, so my kernel cannot be used alone as a replacement. Neko work releasing kernels is of first order and of great benefit for the Porteu...
by biotec
23 Jan 2017, 08:34
Forum: Intermediate/Advanced User Questions
Topic: Invalid argument
Replies: 42
Views: 6908

Re: Invalid argument

Good new! This problem was also reported on the aufs forum from last friday, and yesterday, the aufs developer sent a patch to the forum: https://sourceforge.net/p/aufs/mailman/message/35619254/ I applied the patch on top of a previously compilation kernel tree (v.4.9.5) and recompiled ... and the p...
by biotec
22 Jan 2017, 14:50
Forum: Intermediate/Advanced User Questions
Topic: Invalid argument
Replies: 42
Views: 6908

Re: Invalid argument

Hi! I've run in this (stupid?) bug as well. In my case, I found it when trying to build a package using slackbuild a script that had 'cp -a ...' in it. Since slackbuild scripts are set to stop with ANY error, I couldn't build the package and it made me to investigate too. I'll summarize my findings,...
by biotec
19 May 2016, 22:00
Forum: Bug Reports
Topic: Porteus-3.2rc2 bug reports
Replies: 150
Views: 31724

Re: Porteus-3.2rc2 bug reports

Coming back on viewing PDF files under XFCE 32-bit (and maybe others): As you may remember, shippd epdfview failed to show png pictures in pdf files, so I was using xpdf+libXm.so. However, I discovered the current version of xpdf is very slow rendering some vectorial plots in pdf files, so I tried t...
by biotec
17 May 2016, 11:32
Forum: Bug Reports
Topic: Porteus-3.2rc2 bug reports
Replies: 150
Views: 31724

Re: Porteus-3.2rc2 bug reports

Hello, A small bug/omission that may affect some users with a broadcom wifi card: The broadcom proprietary kernel module wl.ko is missing from 000-kernel.xzm but several related files from earlier versions are still present (at least in the 32-bit version, I did not check the 64-bit version). The fo...
by biotec
13 May 2016, 09:07
Forum: Bug Reports
Topic: Porteus-3.2rc2 bug reports
Replies: 150
Views: 31724

Re: Porteus-3.2rc2 bug reports

Hello, I confirm somebody else's observation that epdfview doesn't show images in pdf files (or fails with mine at least); in my case they are pictures generated with octave as eps files and then converted to pdf. As a solution I installed xpdf and motif slackware packages and it works great on the ...
by biotec
12 May 2016, 12:28
Forum: Bug Reports
Topic: Porteus-3.2rc2 bug reports
Replies: 150
Views: 31724

Re: Porteus-3.2rc2 bug reports

I'm reporting some missing libraries on the XFCE 32bit version, of various importance. None seem essential for a basic use, but I guess some will lead to unexpected problems, especially the lack of libLLVM-3.8.so, required by several X11 drivers, and the lack of libdb-4.8, required by most rpm-handl...
by biotec
02 Apr 2016, 21:44
Forum: Newbie questions
Topic: USB accdental unplugs
Replies: 4
Views: 798

Re: USB accdental unplugs

@Bogomips, thanks for the tip. I've been considering running from RAM ..., but I believe the risk can be too high in my case: I have 30 to 40 people doing exercises on their respective laptops running Porteus from an USB stick provided by me; at the end of the session, once they switched off their l...
by biotec
28 Mar 2016, 18:17
Forum: Newbie questions
Topic: USB accdental unplugs
Replies: 4
Views: 798

USB accdental unplugs

Hi ! It is really great running Porteus entirely from an USB stick ... except when the usb connector is loose and the stick gets accidentally disconnected: even for a fraction of a second, the system becomes unstable and any unsaved work will be lost, which is not funny. As the persistence file does...
by biotec
27 Jan 2016, 19:23
Forum: Nemesis Arch based Porteus
Topic: Porteus Nemesis v3.5 BUG REPORTS
Replies: 289
Views: 51439

Re: Porteus Nemesis v3.5 BUG REPORTS

What problem are you having? I doubt that separate directories for /lib and /usr/lib are possible under Arch, (Nemesis) though I believe it was this way in the past. I've run into this too with kernel modules. but no problems with libs. I have no idea why Arch is doing it this way, I consider it sl...
by biotec
27 Jan 2016, 15:52
Forum: Nemesis Arch based Porteus
Topic: Porteus Nemesis v3.5 BUG REPORTS
Replies: 289
Views: 51439

Re: Porteus Nemesis v3.5 BUG REPORTS

Hello, I'am following with interest the development of Nemesis, and I appreciate a lot that it is being provided with LXDE instead of heavier DE's. I am trying to adapt Nemesis 3.5 to my needs as I did before with classic Porteus. I found a problem that probably cannot be properly qualified as a bug...
by biotec
12 Dec 2015, 23:48
Forum: Nemesis Arch based Porteus
Topic: nemesis under vbox
Replies: 19
Views: 4848

Re: nemesis under vbox

Hello François Well. in my hands, internet works well on a Nemesis 3.3 freshly booted under VBox 5.0.6 (the host is a Slackware; no changes cheatcode, conventionall boot method -not EFI-). Maybe are you using some particular configuration that prevents internet connection? I did not try guest additi...