Porteus 1.1 x86_64 and bluetooth mouse

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
Onraj
White ninja
White ninja
Posts: 7
Joined: 14 Jan 2012, 13:33
Location: Finland

Porteus 1.1 x86_64 and bluetooth mouse

Post#1 by Onraj » 20 Jan 2012, 16:43

Hi to all. (My first post)

Today I tried new version of Porteus but the joy ended quite fast. I have Logitech diNovo Media Desktop set and it's all connected by bluetooth. Now when I boot to KDE4 desktop BlueDevil informs me that "my mouse/keyboard is requesting access to this computer" and asks me to allow or deny. Problem is that I don't have any device to interact with my desktop. And it seems that I cant do anything even if I boot to text mode. So is there a way around this.

Another question is, is there cheatcode or something to boot volume muted. I only have my earphones connected straight to line out and I use software to adjust volume. There wasn't that welcome sound in previous versions but now there is and default volume is a bit LOUD. My head almost exploded when I first time booted whit my headphones on.

Anyways great job with releases 0.9 and 1.0, been using them quite a while and they always worked flawlessly, at least 64 bit version so big thanks to developers.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4590
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#2 by fanthom » 24 Jan 2012, 09:22

hello Onraj,

i'm afraid that you will have to borrow normal ps2/usb mouse from someone and setup bluetooth connection with it.
make sure that your changes will be saved.

regarding sound: currently we have no cheatcode addressing this issue.
disabling sound completely wont be possible as i dont know how to tell udev to skip loading sound card drivers.

it should be possible to add "volume=xx%" cheatcode for next release. setting it to 0% should mute all channels.
i have added this cheat to my TODO list.
for now please adjust alsamixer settings manually and save it's settings with 'alsactl store' command.

EDIT:\\
please add following code to /opt/porteus-scripts/paths:

Code: Select all

# set volume                                                                                                                                
VOLUME=`egrep -o " volume=[^ ]+" /proc/cmdline | cut -d= -f2`                                                                               
[ "$VOLUME" = "" ] || amixer set Master $VOLUME
now you can use 'volume=0%' to boot into GUI without sound.

@Ahau
please update cheatcodes.txt so it will be ready for next release.
As usual - i will request all docs before first rc.
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5503
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#3 by brokenman » 24 Jan 2012, 13:05

Nice. Now i can boot at 1am without my wife waking up. Stealth mode style .... just need a keyboard that doesn't make sound when i type!
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#4 by Ahau » 24 Jan 2012, 15:32

Hehe, yes! No more hovering over the 'mute' button when starting KDE.

Just to make sure for the documentation -- is the '%' character strictly required?

Here's some text:

Code: Select all

volume=some_value%

   ... This parameter sets the system's Master Volume channel to
       the value specified (as a percentage).  You will be able to raise
       or lower the volume after you boot up as normal.  The default
       value (used if you do not specify this cheatcode) is 75%.
       Example: 'volume=0%' will boot into your chosen GUI silently.
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4590
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#5 by fanthom » 25 Jan 2012, 13:50

is the '%' character strictly required?
yes.
i could add it to the script to make it not required but it's probably better like that. users will know that the value is a percentage and not some static number.
(same story as with 'ramsize' cheat)
i have edited first line in the cheat description from your post.
Please add [Solved] to your thread title if the solution was found.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#6 by Ahau » 25 Jan 2012, 15:18

I agree -- including % is better. I've updated the text on my end to reflect your change.

Thanks!
Please take a look at our online documentation, here. Suggestions are welcome!

Onraj
White ninja
White ninja
Posts: 7
Joined: 14 Jan 2012, 13:33
Location: Finland

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#7 by Onraj » 25 Jan 2012, 15:42

Thank you very much for your effort.

It worked fine on 64 bit version but I don't seem to get it working on 32 bit Porteus. Just to be sure, should it work with that too? Those path files seemed to be identical but somehow 32 bit version still default 79% for me.

Onraj
White ninja
White ninja
Posts: 7
Joined: 14 Jan 2012, 13:33
Location: Finland

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#8 by Onraj » 15 May 2012, 12:45

And after little break back to the real problem. I just downloaded v1.2 rc2 64bit and found out I still can't use my bluetooth mouse or keyboard. Now I have usb mouse to allow and authenticate when BlueDevil asks but even after that they don't do anything.

After bit of research I found that it is not just Porteus feature but it bothers others too. What I have tried, latest Ubuntu live cd and Aptosid installation cd had same problem. Also it's not specific to my diNovo set but affects all Logitech wireless peripherals as far I know, not sure.

After bit more searching I found kind of solution. In Porteus problem lies in /lib/udev/rules.d/97-bluetooth-hid2hci.rules. In other systems it can be another file in same folder. After "# Logitech devices" I have to change "KERNEL=="hiddev*" to "KERNEL=="hidraw*". After that change mouse and keyboard work as usual.

I'm not sure what it really does. It seems that blueDevil doesn't find my bluetooth dongle after that change and says that "No adapters found". So it isn't perfect solution because now it seems I can't pair my phone with my computer. But at least with it now I can type this post with my keyboard and Porteus 1.2 rc2. :Yahoo!: Hope there will be real solution one day.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5503
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#9 by brokenman » 16 May 2012, 02:13

While i have no BT devices to play with, the archwiki has a nice page:

https://wiki.archlinux.org/index.php/Bluetooth
How do i become super user?
Wear your underpants on the outside and put on a cape.

Onraj
White ninja
White ninja
Posts: 7
Joined: 14 Jan 2012, 13:33
Location: Finland

Re: Porteus 1.1 x86_64 and bluetooth mouse

Post#10 by Onraj » 17 May 2012, 09:16

Thank you brokenman, that will come in handy now that I'm half way trough my new Arch installation.

What I meant was that I can use my phone and comp with Porteus and BlueDevil without that "fix" without a problem. With it BlueDevil says that it doesn't find my Logitech bluetooth dongle at all. So it isn't real solution but quick help if someone else is having same problem. I can live with that now. Most important is that I can use new Porteus again. I've been using 1.0 version until now. Thank you for all of your help.

Post Reply