LXDE battery low message

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
oranus
Contributor
Contributor
Posts: 69
Joined: 25 Aug 2011, 13:46
Location: Turkey

LXDE battery low message

Post#1 by oranus » 12 Jan 2012, 16:00

Thanks for Porteus 1.1

On LXDE if laptop cable is unpluged xmessage warns with "Low battery" message again and again. It made me bored. So I simply solve this problem from: https://bbs.archlinux.org/viewtopic.php?id=79320

Code: Select all

#!/bin/bash
date >> ~/whos_calling_me
echo $$ >> ~/whos_calling_me
ps -FjH >> ~/whos_calling_me
xmessage.old "$@"
Cheers....

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: LXDE battery low message

Post#2 by brokenman » 13 Jan 2012, 03:00

A rather dirty hack that won't be included in any release ... but it gets the job done! Thanks for posting this ... it was annoying the hell out of me too!

Once Porteus has passed into an X session, xmessage is no longer used by anything that i know of, so this is a safe dirty hack for us. Sheeesh ... this has been a bug for a long time with LXDE. I think it boild down to some machines reporting battery status in Amp/hours where the monitor expects a percentage. Seeing such a low number as 3 or 4 triggers alarm bells.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5575
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: LXDE battery low message

Post#3 by brokenman » 22 Apr 2012, 01:01

An easier fix for this is to open the settings (right click on panel applet) and remove the message about the battery warning. This suppresses the popup aswell :)
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply