Porteus-1.1 on MacBook Air 13

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
cchuang
Black ninja
Black ninja
Posts: 33
Joined: 03 Jan 2011, 06:55
Location: Taiwan

Porteus-1.1 on MacBook Air 13

Post#1 by cchuang » 10 Jan 2012, 01:56

Porteus-1.1 is awesome, cann't wait to test on my new MacBook Air (i7 CPU)
BCM, i915 cann't be setting up well; but it also can boot with cheatcode " xserver=vesa nomodeset"
Porteus is still use Python-2.6; I manually upgrate Python to 2.7.2 and PyQt4 requires phonon dev which is absent in 1.1.

Thanks for Porteus people nice work!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus-1.1 on MacBook Air 13

Post#2 by fanthom » 10 Jan 2012, 07:46

moved from 'Development' to 'Bug reports' as it's more about bugs than feature requests.
BCM, i915 cann't be setting up well;
regarding BCM: your chipset may be still unsupported by open surce drivers. please provide output of 'lspci | grep Network' and we will know that for sure. also - please try installing 'broadcom-sta' package from Slackbuilds. open "Porteus Package Manager" -> Slackbuilds -> Express -> search for broadcom-sta and build it. if that helps then i'll add this package to the official repo.
regarding i915: i would be surprised to see this driver broken in 3.1.8 kernel. maybe you have /etc/X11/xorg.conf created on other GPU in your system? better check in "Always Fresh" mode with base modules only. if you get a failure then please upload /var/log/Xorg.0.log for review.
but it also can boot with cheatcode " xserver=vesa nomodeset"
never heard of 'xserver-vesa' cheat. 'nomodeset' should be enough.
PyQt4 requires phonon dev which is absent in 1.1
not sure what you mean by "phonon dev". is it an extra package? all phonon headers are moved to 005-devel.xzm/usr/include so please make sure you have devel module activated.

Cheers
Please add [Solved] to your thread title if the solution was found.

Post Reply