KOffice doesn't support Unicode, or something?

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
GullibleJones
White ninja
White ninja
Posts: 13
Joined: 10 Jan 2012, 00:10
Location: The Independent Republic of Massachusetts

KOffice doesn't support Unicode, or something?

Post#1 by GullibleJones » 10 Jan 2012, 00:19

First of all, let me say this distribution is wonderful. It offers exactly the same light, speedy feel as Slax used to, with even more functionality stuffed into it. I love it, and I'd like to thank all the developers and contributors for recreating Slax's former awesomeness.

Now that that's done with...

When opening RTF documents (saved from LibreOffice) in KOffice on Porteus 1.1, I've noticed that "smart" (i.e. curved) quotations marks and apostrophes are shown as the dreaded question-mark-in-a-black-diamond symbol (i.e. unrecognized character), followed by a g or an h, rather than as what they ought to be. According to 'locale' everything is en_us.UTF8... So what's going on? Did KOffice 1.x not support Unicode properly? Or is this a configuration issue that I can fix?

Falcony
Full of knowledge
Full of knowledge
Posts: 218
Joined: 01 Jan 2011, 12:44
Location: Russia

Re: KOffice doesn't support Unicode, or something?

Post#2 by Falcony » 10 Jan 2012, 10:22

Dear GullibleJones, hi!

Could you provide more details - what arch(32 or 64-bit) you have, do you native english/amerian user or internation one?

May be screenshot link to screen with problem()

echo $LANG in terminal also could be useful

It could be anything - koffice bug, out of font missing, unproperly localization

GullibleJones
White ninja
White ninja
Posts: 13
Joined: 10 Jan 2012, 00:10
Location: The Independent Republic of Massachusetts

Re: KOffice doesn't support Unicode, or something?

Post#3 by GullibleJones » 10 Jan 2012, 12:47

Thanks for the quick response... I'm using the 32-bit version with Trinity. I'll have $LANG and a screenshot in a sec.

Posted after 10 minutes 33 seconds:
Okay... $LANG is en_US.UTF-8, and here is the screenshot:

http://img713.imageshack.us/img713/9776/snapshot1jl.png

(The problem parts are circled in red.)

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: KOffice doesn't support Unicode, or something?

Post#4 by brokenman » 10 Jan 2012, 14:37

Smart quotes and such have been the bane of editing programs for years. i have a feeling our switch to UTF-8 is what broke this. What encoding was the original document set to when written? I will try get my hands on a libre office document with smart quotes and reproduce here.

Posted after 38 minutes 14 seconds:
I just installed libreoffice in Porteus and tried to recreate the event. By default a document in libre office (under Porteus) reproduces perfectly in koffice (under Porteus).

To turn off smart quotes in Libre Office Writer, so that the double quote character is shown in the document as ” — exactly as you typed it — and doesn’t get converted into something curly:

Go to Tools > Autocorrect Options
Select the Localized Options tab
Click the button under Start Quote. If you’re using the Basic Latin character set, scroll all the way to the top of the character set display and click the ” box (third box from the top left row, next to the !). If you are using some other character set try searching near the top of the set for the ” character.
Click OK
Click the button under End Quote. Scroll all the way to the top of the character set display and click the ” box (third box from the top left row, next to the !)
Click OK
Click OK

Smart quotes are now off for the document that you’re working on. They will also be off for any new documents that you create, including spreadsheets and files created by other Libre Office applications.

To get rid of smart quotes already in a document:

Highlight any start smart quote and copy it (Ctrl-C or File > Copy)
Select Edit > Find & Replace
Paste the smart quote into the Search for box
Type ” in the Replace with box
Click the Replace All button
Click Close
Repeat these steps using a copy of the end smart quote

In any case this has given me the opportunity to add libreoffice to the 32bit repo.
How do i become super user?
Wear your underpants on the outside and put on a cape.

GullibleJones
White ninja
White ninja
Posts: 13
Joined: 10 Jan 2012, 00:10
Location: The Independent Republic of Massachusetts

Re: KOffice doesn't support Unicode, or something?

Post#5 by GullibleJones » 10 Jan 2012, 17:14

Ah, the distro I was using before must have had "smart" quotes turned on by default. Thankee-sai!

User avatar
brokenman
Site Admin
Site Admin
Posts: 5436
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: KOffice doesn't support Unicode, or something?

Post#6 by brokenman » 10 Jan 2012, 20:52

Libre Office now available on server. PPM will resolve dependencies.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply