[Solved] unable to mount a vfat usb stick

Non release banter
Post Reply
User avatar
banshee22
White ninja
White ninja
Posts: 18
Joined: 08 Sep 2011, 08:46
Location: France

[Solved] unable to mount a vfat usb stick

Post#1 by banshee22 » 09 Jan 2012, 14:17

Hi All,

I'm unable to mount a vfat usb stick.
I can see /dev/sdc1, but "mount -t vfat /dev/sdc1 /mnt/myrep" return me something like:

"mount: wrong fs type, bad option, bad super block on /dev/sdc1....."

Usb stick I'm trying to mount is just an empty FAT32 usb stick formated on windows.
I can mount it on mandriva without having anything to do: udev mounts it well.

in /var/log/syslog, I've a messsage like: "FAT: unrecognized mount option"iocharset=" or missing value"

Does it tells something to somebody?

Thanks!

Banshee
Last edited by banshee22 on 12 Jan 2012, 09:25, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4616
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: unable to mount a vfat usb stick

Post#2 by fanthom » 09 Jan 2012, 14:40

could be a bug in 'Language Selection Tool' - did you use it to create french language pack?
please show me content of "/sbin/mount.vfat" if you have that file.

also - please post output of 'blkid' command when stick is plugged in.
Please add [Solved] to your thread title if the solution was found.

User avatar
banshee22
White ninja
White ninja
Posts: 18
Joined: 08 Sep 2011, 08:46
Location: France

Re: unable to mount a vfat usb stick

Post#3 by banshee22 » 09 Jan 2012, 15:40

Not sure about what is "langage selection tool". It's been a long time since i've set langage to french ;-) I think I've not use this tool, just configure lxde...

this is /sbin/mount.vfat :

#!/bin/bash
# File generated by Porteus Language-Selection tool
mv /sbin/mount.vfat /sbin/mount.vfat-tmp
/bin/mount $1 "$2" -o iocharset=
mv /sbin/mount.vfat-tmp /sbin/mount.vfat

blkid command:

/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/loop5: TYPE="squashfs"
/dev/loop6: TYPE="squashfs"
/dev/loop7: TYPE="squashfs"
/dev/sda1: LABEL="SYSTEM" UUID="4478E58978E57A56" TYPE="ntfs"
/dev/sda2: LABEL="DATA" UUID="08304E4D304E4244" TYPE="ntfs"
/dev/sdb1: LABEL="USB DISK" UUID="1831-3FE8" TYPE="vfat"
/dev/sdc1: UUID="6674-385D" TYPE="vfat"
/dev/loop8: TYPE="squashfs"
/dev/loop9: TYPE="squashfs"
/dev/loop10: TYPE="squashfs"
/dev/loop11: TYPE="squashfs"
/dev/loop12: TYPE="squashfs"
/dev/loop13: TYPE="squashfs"
/dev/loop14: TYPE="squashfs"
/dev/loop15: TYPE="squashfs"
/dev/loop16: TYPE="squashfs"
/dev/loop17: TYPE="squashfs"
.....................................

Thanks for your help Fanthom!!

Publié after 8 minutes 19 seconds:
Ok, this works! I've set iso8859-1 for iocharset value in /sbin/mount.vfat

Thanks again for your quick help!

May be you could tell me more about langage selection tool or give me a link to read about it?

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: unable to mount a vfat usb stick

Post#4 by Ahau » 09 Jan 2012, 16:00

Glad it's working for you now :)

Language Selection Tool can be accessed from the KDE or LXDE menu under 'System -> Language Selection Tool'. It will walk you through the process of setting your default language and keyboard layout and download some files necessary to change your locale. It will also create a module for you that will retain these settings and locale files.
Please take a look at our online documentation, here. Suggestions are welcome!

Post Reply