[SOLVED] pxe-boot: porteus data not found

Post here if you are a new Porteus member and you're looking for some help.
ereinion
White ninja
White ninja
Posts: 6
Joined: 01 Mar 2012, 10:41
Location: Spb.Ru

Re: [SOLVED] pxe-boot: porteus data not found

Post#16 by ereinion » 02 Mar 2012, 19:01

Have news :)

Set up Debian in Hyper-V (Porteus does not starts in Hyper-V from iso image) and installed Monkey 0.9.3 on it.
Porteus loads files from httpfs, but stucks at "live system ready now - starting Porteus"...

User avatar
fanthom
Site Admin
Site Admin
Posts: 4620
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED] pxe-boot: porteus data not found

Post#17 by fanthom » 03 Mar 2012, 00:46

@ereinion
Porteus loads files from httpfs, but stucks at "live system ready now - starting Porteus"...
not sure what it could be. is porteus starting ok on client PC when carried on CD/usb stick?
what's the client PC specs? 'psinfo' raport would be handy...

i would insist on taking easiest approach first. please try Vbox + 32bit Porteus as it's proven to work.
if you get that up on running then you will know that there is all ok with hardware/connection and can move forward with Debian/Windows experiments.
Please add [Solved] to your thread title if the solution was found.

liguero
White ninja
White ninja
Posts: 14
Joined: 16 Mar 2012, 09:13
Location: FRANCE

Re: [SOLVED] pxe-boot: porteus data not found

Post#18 by liguero » 16 Mar 2012, 12:38

Boot PXE Ethernet Broadcom BCM5906M [14e4:1713] Driver tg3

You must add 2 drivers to the file initrd.xz.

1. /lib/modules/3.1.8-porteus/kernel/drivers/net/tg3.ko
2. /lib/modules/3.1.8-porteus/kernel/drivers/net/phy/libphy.ko

On the client PXE, boot in "Text mode", then login as root.

Verify parameters : lspci -knn, ifconfig, netstat -r, /etc/resolv.conf ...

Then if all is correct, execute "startx"!

Perhaps you have to modify router's address for internet access :

Add --dhcp-option=3,x.x.x.x to the file /boot/pxelinux.cfg/start :

# start the DHCP server and TFTP server
./dnsmasq --enable-tftp --tftp-root=$ROOT/boot \
--dhcp-option=3,192.168.1.1 \
--dhcp-boot=/pxelinux.0,"$IP",$IP \
--dhcp-range=$RANGE.50,$RANGE.250,infinite --log-dhcp

Cheers

Post Reply