[SOLVED] Problem Installing then running gnumeric

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
rovitotv
White ninja
White ninja
Posts: 5
Joined: 28 Nov 2011, 21:14
Location: Middletown, Ohio USA
Contact:

[SOLVED] Problem Installing then running gnumeric

Post#1 by rovitotv » 28 Nov 2011, 21:27

Greetings,
I am new to porteus and have version 1.0 64 bit installed on a USB thumb drive 16 GB. The 16 GB I divided between 1 GB ext3 for Porteus and the other space for files 15 GB as NTFS. Everything boots and runs fine. I can surf the web and even compile some basic C++ programs. Now I have a need to use a spread sheet so I downloaded the file: gnumeric-1.10.17-x86_64-1sl.xzm from http://www.ponce.cc/porteus/x86_64/modu ... 64-1sl.xzm to my thumb drive on the NTFS partition. Then I double click the gnumeric install package and Porteus asks me for the root password which I provide then some stuff appears on the screen that indicates it installed ok. I even have a gnumeric icon in the menu under Applications->Science & Math. But when I click on the icon nothing happens gnumeric never starts. I can follow the same process for http://www.ponce.cc/porteus/x86_64/modu ... 64-1sl.xzm and it all seems to work. Any ideas? Am I doing something stupid.

Really I would like a way to get painless way to get Open Office installed. Thanks for the help.
Last edited by rovitotv on 28 Nov 2011, 22:22, edited 1 time in total.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Problem Installing then running gnumeric

Post#2 by Ahau » 28 Nov 2011, 21:42

welcome, rovitotv!

It sounds like you're missing a dependency (another package that gnumeric needs to have installed before it can run). If you open Porteus Package Manager and use that to download gnumeric, it should download gnumeric and all required dependencies, and if you then use Porteus Package Manager to activate gnumeric, it should activate the modules upon which it depends as well. Once you do that, you should be good to go.
Please take a look at our online documentation, here. Suggestions are welcome!

beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: Problem Installing then running gnumeric

Post#3 by beny » 28 Nov 2011, 21:55

The Gnumeric spreadsheet is part of the GNOME desktop environment: a project to create a free, user friendly desktop environment.

rovitotv
White ninja
White ninja
Posts: 5
Joined: 28 Nov 2011, 21:14
Location: Middletown, Ohio USA
Contact:

Re: Problem Installing then running gnumeric

Post#4 by rovitotv » 28 Nov 2011, 22:07

Ahau,
I forgot to mention I did try and Porteus Package Manager as well but could not find any spreadsheet program listed as a module. So I was trying the manual route....


Beny,
I see maybe I should try koffice instead?

Posted after 9 minutes 42 seconds:
I installed koffice from here:
http://www.ponce.cc/porteus/x86_64/modu ... 6_64-2.xzm

Once again it all installed ok but would not run. I then opened up a shell and executed the command /usr/bin/kspread and it appears I am missing a shared library called libImath.so.6. Both the Porteus package manager nor the modules download directory seem to have a module that fits that description. Anybody have any ideas?

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Problem Installing then running gnumeric

Post#5 by Ahau » 28 Nov 2011, 22:12

try ilmbase, in the libraries section.

PPM should be picking that up... hmm...
Please take a look at our online documentation, here. Suggestions are welcome!

rovitotv
White ninja
White ninja
Posts: 5
Joined: 28 Nov 2011, 21:14
Location: Middletown, Ohio USA
Contact:

Re: Problem Installing then running gnumeric

Post#6 by rovitotv » 28 Nov 2011, 22:21

Getting closer now I have a error while loading shared libraries: libIlmImf.so.6: cannot open shared object file: no such file or directory

Posted after 4 minutes 55 seconds:
Got it working, all I had to do that time was load openexr from the porteus package manager. Nice now I have KOffice working. Thanks, for the help.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED] Problem Installing then running gnumeric

Post#7 by fanthom » 28 Nov 2011, 22:45

I forgot to mention I did try and Porteus Package Manager as well but could not find any spreadsheet program listed as a module. So I was trying the manual route....
i guess that you didn't update the index. this must be done manually in ppm1.

@brokenman
suggestion: PPM3 upon startup could check internet availability and packages db version in the background. if server version differers with one saved locally PPM should notify users about an update.
Please add [Solved] to your thread title if the solution was found.

rovitotv
White ninja
White ninja
Posts: 5
Joined: 28 Nov 2011, 21:14
Location: Middletown, Ohio USA
Contact:

Re: [SOLVED] Problem Installing then running gnumeric

Post#8 by rovitotv » 28 Nov 2011, 23:02

Yes, that helped alot!!! Now I have lots of packages listed in the Porteus Package Manager. Sorry I don't know why I didn't hit the update index selection it was right in front of me. Thanks for the support, Porteus is a great piece of open source software.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5439
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: [SOLVED] Problem Installing then running gnumeric

Post#9 by brokenman » 30 Nov 2011, 12:54

Yes this is the default function of PPM3 ... to initiate automatic update checks in background unless user has unticked the option in configuration and prefers to update manually.
How do i become super user?
Wear your underpants on the outside and put on a cape.

Post Reply