Problem with a sound card

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
Blaze
DEV Team
DEV Team
Posts: 1545
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus 3.2 Cinnamon x86_64
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Problem with a sound card

Post#1 by Blaze » 31 Dec 2010, 11:10

Name of sound card: HDA ATI SB
Porteus v09 32bit loading v17085s analog.
Problem: Silent sound.

Code: Select all

root@porteus:~# cat /proc/asound/card0/codec#* | grep Codec
Codec: VIA VT1708S
rroot@slax:~# hwinfo --sound
20: PCI 14.2: 0403 Audio device
  [Created at pci.301]
  UDI: /org/freedesktop/Hal/devices/pci_1002_4383
  Unique ID: 5Dex.03xSVVGXVU1
  SysFS ID: /devices/pci0000:00/0000:00:14.2
  SysFS BusID: 0000:00:14.2
  Hardware Class: sound
  Model: "ASUSTeK SBx00 Azalia"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x4383 "SBx00 Azalia"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x83b7
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xf7cf4000-0xf7cf7fff (rw,non-prefetchable)
  IRQ: 16 (131893 events)
  Module Alias: "pci:v00001002d00004383sv00001043sd000083B7bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
In Ubuntu and Slax 6.1.2 - sound works fine.

P.S. It is not my problem.
Last edited by Blaze on 05 Jan 2011, 16:40, edited 1 time in total.
Linux porteus 4.13.3-porteus #1 SMP PREEMPT Sat Sep 23 18:22:13 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
fanthom
Site Admin
Site Admin
Posts: 4623
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Problem with a sound card

Post#2 by fanthom » 01 Jan 2011, 09:56

please post reply of "cat /proc/asound/cards" command as all cards are listed there.
any chance of getting screenshoot of 'alsamixer' settings?
Please add [Solved] to your thread title if the solution was found.

User avatar
brokenman
Site Admin
Site Admin
Posts: 5651
Joined: 27 Dec 2010, 03:50
Distribution: Porteus v3.2rcX all desktops
Location: Brazil
Contact:

Re: Problem with a sound card

Post#3 by brokenman » 02 Jan 2011, 18:34

At first look i suspect an issue with hda intel driver. I have the same issue.

Posted after 19 hours 53 minutes 22 seconds:
Please try opening kmix and turning both gain and phoneout up. This worked for me. Driver is good.
How do i become super user?
Wear your underpants on the outside and put on a cape.

User avatar
francois
Contributor
Contributor
Posts: 5116
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Problem with a sound card

Post#4 by francois » 09 Jan 2011, 05:27

I don't know if this could help. There is no sound problem for me. I am working with ultraslim MSI 340X, sound card:

root@slax:~# lspci
...
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

root@slax:~# cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfe9f8000 irq 46

I imagine that you have tried the following tricks, citation from the hyperlink:
http://www.slax.org/forum.php?action=vi ... a%20driver

francois.e

Type the command alsamixer in terminal, using tab to select main volume and adjust volume with upper or down arrows.

izan

you can try alsaconf in the terminal (root previleges are required)
then go to changes/etc/modprob.d/ where the file "sound" should be present
the add the folllowing sequence "options snd-hda-intel model=MODEL" at the end of that file (sound)
then reboot and try to adjust your voulume with alsamixer command using the key board arrows (m=mute!)
eg: i have a toshiba laptop "tecra h10 11h" i added the following sequence
options snd-hda-intel model=toshiba
it worked at least for me
I hope it will work for you too.
Voltaire: Le mieux est l'ennemi du bien.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: Problem with a sound card

Post#5 by Ahau » 09 Jan 2011, 06:23

For me, the problem was unmuting. I had to run alsamixer, as francois suggests, tab to the speakers, then hit m to unmute the speakers. If there is an (MM) at the bottom of the speakers column, they are muted. Pressing m changes that to (00).
Please take a look at our online documentation, here. Suggestions are welcome!

Post Reply