[Solved] Framebuffer disable

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
xtavras
White ninja
White ninja
Posts: 5
Joined: 07 Nov 2011, 13:55
Location: Berlin

[Solved] Framebuffer disable

Post#1 by xtavras » 07 Nov 2011, 14:01

Hi,

is it possible to turn off the framebuffer during "only text-mode" boot? otherwise there is only the black screen, standard options, like "vga=normal" or "nofb" don't help.

Thx,
Stan
Last edited by xtavras on 08 Nov 2011, 11:59, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4587
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Framebuffer disable

Post#2 by fanthom » 07 Nov 2011, 14:20

Welcome on board xtavras,

framebuffer is disabled by default in text mode. when you look at /boot/porteus.cfg you will see that only KDE. LXDE and copy2ram has 'vga=796' cheatcode which initializes VESA framebuffer (it's destroyed by KMS later in the boot process by KMS capable drivers).

what's your GPU model?
please provide log file generated by 'psinfo' uploaded to pastebin.com website.

Cheers
Please add [Solved] to your thread title if the solution was found.

xtavras
White ninja
White ninja
Posts: 5
Joined: 07 Nov 2011, 13:55
Location: Berlin

Re: Framebuffer disable

Post#3 by xtavras » 08 Nov 2011, 08:12

Hi fanthom,

thx for your help.

its not a standard hardware and namely lspci says: "VGA: XGI Technology Inc. (eXtreme Graphics Innovation) Z11/Z11M". SystemrescueCD can handle it, but I don't like it and would like to use Porteus instead :)

btw, the blackscreen comes immediately after the "triggering udev events" message.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4587
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Framebuffer disable

Post#4 by fanthom » 08 Nov 2011, 11:05

btw, the blackscreen comes immediately after the "triggering udev events" message.
xgifb is still in the "staging" area of the kernel so may be unstable on some hardware .

please try Porteus-1.1 rc1 which has 3.1 kernel (you can find it in "Development" subsection of the forum).
if you still get black screen in rc1 then try to blacklist xgifb module an check if that gonna work.

Code: Select all

echo "blacklist xgifb" > /etc/modprobe.d/blacklist-xgifb.conf
if you dont save changes then create this file in /portues/rootcopy folder.

btw: is Porteus-1.0 working fine once it's getting into GUI? do you have 2D/3D acceleration, etc..?


Cheers
Please add [Solved] to your thread title if the solution was found.

xtavras
White ninja
White ninja
Posts: 5
Joined: 07 Nov 2011, 13:55
Location: Berlin

Re: Framebuffer disable

Post#5 by xtavras » 08 Nov 2011, 11:58

Thanks a lot fanthom!

the xgifb blacklisting has helped me, it works now.

Solution for all:
$ mkdir -p /path/to/your/usb-flash/porteus/rootcopy/etc/modprobe.d
$ echo "blacklist xgifb" > /path/to/your/usb-flash/porteus/rootcopy/etc/modprobe.d/blacklist-xgifb.conf

User avatar
fanthom
Site Admin
Site Admin
Posts: 4587
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [Solved] Framebuffer disable

Post#6 by fanthom » 08 Nov 2011, 16:20

glad that it's sorted,

once you blacklisted xgifb - which driver is used in GUI?
please upload /var/log/Xorg.0.log to pastebin.com and link it here.
(it will also tell me if you have 2D/3D acceleration)

i'm trying to find out if we should remove this driver from next release so blacklisting wont be necessary.

Cheers
Please add [Solved] to your thread title if the solution was found.

xtavras
White ninja
White ninja
Posts: 5
Joined: 07 Nov 2011, 13:55
Location: Berlin

Re: [Solved] Framebuffer disable

Post#7 by xtavras » 09 Nov 2011, 07:53

Hi,

no, X will not start, here is the Xlog

http://pastebin.com/i9nFgpLv

User avatar
fanthom
Site Admin
Site Admin
Posts: 4587
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [Solved] Framebuffer disable

Post#8 by fanthom » 09 Nov 2011, 09:19

seems that XGI driver is problematic/broken:

Code: Select all

LoadModule: Module xgi does not have a xgiModuleData data object
confirmed in this thread:
http://www.linuxquestions.org/questions ... rg-837500/

do you care about GUI at all? (in initial post you were interested in text mode boot).
did you get into GUI before blacklisting xgifb?
does VESA mode work on your PC?

i have recompiled xgi and xgixp on porteus, please try them:
http://www.mediafire.com/file/psjaek95n ... 6-2ftm.xzm
http://www.mediafire.com/file/ncj405l5h ... 6-1ftm.xzm

in case of fail, please upload Xorg.0.log once again.

btw: can you start X session in SystemrescueCD without problems? does it use vesa or xgi driver?
Cheers
Please add [Solved] to your thread title if the solution was found.

Post Reply