cdemu 1.3.0 (or better 1.4.0)

If you are looking for a specific 64-bit package and you can't find it in any of the 64-bit repos, please post a request for it here
Post Reply
User avatar
Rava
Contributor
Contributor
Posts: 1319
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 3.1.0 x86-64 XFCe
Location: Germany

cdemu 1.3.0 (or better 1.4.0)

Post#1 by Rava » 27 Oct 2011, 19:52

I am trying to get cdemu running with Porteus, but it fails...

Maybe one of you has an idea. I never used dbus-python before. I have no clue where the reason for the below listed errors might be...

I used these:
cdemu-daemon-1.3.0-x86_64-1_nhh.tgz (tgz2xzm) --> I did not find any 13.17 version with uses txz... :unknown: I downloaded all cdemu* from http://www.nielshorn.net/slackware/slack_pkg.php
cdemu-client-1.3.0

And also the needed;:
dbus-python-0.83.1-x86_64-1.xzm (txz2xzm)
libao-1.1.0-x86_64-1.xzm
libdaemon-0.14-x86_64-2_nhh.xzm
libmirage-1.4.0-x86_64-1_nhh.xzm

When trying to start the demon, it gives me:

Code: Select all

Inserting vhba kernel module					[FAILED]
Waiting for /dev/vhba_ctl to be created	 [FAILED]
Starting cdemu-daemon							  [FAILED]
When starting the daemon by hand, it tells me this:

Code: Select all

bash-4.1$ cdemud
Starting daemon in local mode with following parameters:
 - num devices: 1
 - ctl device: /dev/vhba_ctl
 - audio driver: null
 - bus type: session

ERROR: Failed to load plugin /usr/lib64/ao/plugins-4/libesd.so => dlopen() failed
cdemu0: Device: failed to open control device /dev/vhba_ctl!
cdemud: Daemon: failed to initialize device 0!
Daemon initialization failed: Device initialization failed.
bash-4.1$ ls -o /usr/lib64/ao/plugins-4/libesd.so
-rwxr-xr-x 1 root 8552 2011-03-09 20:12 /usr/lib64/ao/plugins-4/libesd.so
bash-4.1$ file /usr/lib64/ao/plugins-4/libesd.so
/usr/lib64/ao/plugins-4/libesd.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
Any ideas why that might be?

I know that cdemu V1.4.0 no longer uses libdaemon, and that *might* prevent the issues I ran into, but I found no slackware package for that version. :unknown:
Cheers!
Yours Rava

beny
Full of knowledge
Full of knowledge
Posts: 720
Joined: 02 Jan 2011, 11:33
Location: italy

Re: cdemu 1.3.0 (or better 1.4.0)

Post#2 by beny » 30 Oct 2011, 09:27

hi rava if you have done the vhba module against kernel version you have to do in console :modprobe vhba to load it,and try to start cdemu again ,bye but i receive other error from dbus ERROR: Failed to acquire daemon interface version (this most likely means your daemon is out-of-date): org.freedesktop.DBus.Error.ServiceUnknown: The name :1.40 was not provided by any .service files

Post Reply