[Solved] touchpad vertical scrolling

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

[Solved] touchpad vertical scrolling

Post#1 by fanthom » 31 Dec 2010, 05:31

I have tried many configurations by adjusting /etc/X11/xorg.conf, /etc/X11/xorg.conf.d/50-synaptic.conf,
trying different x11-input-synaptics drivers and still no joy :bad:

if anybody knows the solution, please post it here.
Please add [Solved] to your thread title if the solution was found.

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: touchpad vertical scrolling

Post#2 by Ahau » 10 Jan 2011, 19:48

Here are some relevant threads that I've found:

http://www.linuxquestions.org/questions ... nt-849714/
http://www.linuxquestions.org/questions ... op-675065/

The problem appears to be that your system is recognizing your touchpad as a standard mouse, rather than a SynPS/2 device (or it recognizes it as SynPS/2 and then changes it to standard mouse).

Check this with cat /proc/bus/input/devices. My system came up with a standard mouse.

Temporary work around:

Code: Select all

rmmod psmouse
modprobe psmouse proto=auto
Apparently you can add those lines to the end of your /etc/rc.d/rc.local (see first thread), though I haven't tested it. There's more info in those threads, and this does not appear to be the only way to fix it.

Thanks,

Ahau
Please take a look at our online documentation, here. Suggestions are welcome!

User avatar
fanthom
Site Admin
Site Admin
Posts: 4566
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: touchpad vertical scrolling

Post#3 by fanthom » 10 Jan 2011, 19:56

you can also edit /etc/modprobe.d/psmouse.conf and change:
'options psmouse proto=imps'
to
'options psmouse proto=auto'

should do the job :)

Thanks Ahau - [Solved]
Please add [Solved] to your thread title if the solution was found.

Post Reply