PCManFM does not mount usb partiotions

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
Post Reply
kalo86
Samurai
Samurai
Posts: 133
Joined: 28 Mar 2011, 18:04
Location: Italy

PCManFM does not mount usb partiotions

Post#1 by kalo86 » 05 Oct 2011, 18:37

Hello,
I am using Porteus v1.0 in LXDE style, I moved out the KDE-modules from the /base and /modules folders because I only use the lightweight desktop environment.
There is a problem: when I insert a USB pendrive (or external USB Hard drive), Porteus is not showing a notification and it's not mounting the partition.
If I open PCManFM, even if I go to /mnt/sdbX or /sdcX I don't find the usd device. This is the same also in /media.
Then I made an experiment: I downloaded the Salix i486 LXDE module "pcmanfm-1.2.3-i486-1gv.txz", I converted the module with txz2xzm and I mounted this module on Porteus.
The result is that I have the PC Man FM Mod v1.2.3 and now Porteus (or maybe PCManFM-Mod) is able to auto-mount the usb partition of any device that I insert on the usb port of my netbook.

Question: is possible to insert PCManFM-Mod as the new-defaul file manager on LXDE module?
I tried to extract the 003-lxde.xzm module and change the pcmanfm to pcmanfm-mod but at the next reboot I have a lot of problems. I don't have good skills for doing this... :x

Anyway, if You want to try, you can copy this module on /base or /modules of the /porteus folder and at the next reboot you will be able to automount partitions.

Module: http://www.mediafire.com/?77sqj7nb5d5apxo

Regards,

kalo86

User avatar
fanthom
Site Admin
Site Admin
Posts: 4623
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: PCManFM does not mount usb partiotions

Post#2 by fanthom » 05 Oct 2011, 18:57

as per ponce's advice from this thread:
viewtopic.php?f=73&t=761&p=5909
it's not too good to mix versions of pcmanfm. from my own experience i know that pcmanfm depends heavily on libfm and they myst stay in sync to work correctly. automounting works fine in porteus-1.1-devel 64bit and i'll make sure that it works the same for 32bits one 1.1 is out.

thanks for reminding about this issue and for pcmanfm-mod package.

Cheers
Please add [Solved] to your thread title if the solution was found.

User avatar
wread
Module Guard
Module Guard
Posts: 1108
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v3.2.5-kde5-64 bits
Location: Santo Domingo
Contact:

Re: PCManFM does not mount usb partiotions

Post#3 by wread » 08 Oct 2011, 22:16

You can check if your hal-daemon is running. Issue "ps x | grep hald" in a konsole. Your lxde still needs hald to detect input devices. Next version (Porteus 1.1) won' t need it any longer.

You can also check what happens when you insert an usb this way:
1) in a konsole enter
root@porteus# tail -f /var/log/messages

2) insert your usb memory and observe the added messages; this will give you a clue of what is happening

To get out of tail you must issue ^C.

Regards
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: PCManFM does not mount usb partiotions

Post#4 by Hamza » 08 Oct 2011, 22:53

^C is Ctrl+C

@wread,
Some people cannot know this shortcut to kill the current process in konsole :)
NjVFQzY2Rg==

kalo86
Samurai
Samurai
Posts: 133
Joined: 28 Mar 2011, 18:04
Location: Italy

Re: PCManFM does not mount usb partiotions

Post#5 by kalo86 » 09 Oct 2011, 01:36

Thanks to anyone is helping me, but I am using the PCManFM-Mod upon the default file manager that LXDE uses.
I prefer to wait for the next and upcoming Porteus 1.1 :)
Regards,

kalo

newbody
Black ninja
Black ninja
Posts: 54
Joined: 19 May 2011, 14:40
Location: Sweden

Re: PCManFM does not mount usb partiotions

Post#6 by newbody » 30 Oct 2011, 08:28

I was telling everybody how good Porteus works and then ...

A friendly soul on the Puppy forum told me about this problem too.
Hm Porteus 1.1. How do I know what I have now.
Porteus Port32-10 1.0 OS oh that is 1.0 then.

Friendly suggestion. is there no easy way to get this going?
When is 1.1 planned to be launched then?

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: PCManFM does not mount usb partiotions

Post#7 by Hamza » 30 Oct 2011, 19:31

I cannot give a solution if I didn't understood your question/request.

Porteus Port32-10 1.0 OS oh that is 1.0 then. - unknown ??

Sorry.
NjVFQzY2Rg==

User avatar
Ahau
King of Docs
King of Docs
Posts: 1331
Joined: 28 Dec 2010, 15:18
Distribution: LXDE & Xfce 32/64-bit
Location: USA

Re: PCManFM does not mount usb partiotions

Post#8 by Ahau » 31 Oct 2011, 15:52

Hi newbody,

Yes, you appear to be running the 32-bit edition of Version 1.0. The 64-bit edition of Version 1.1 is currently in testing as RC-1 (early release candidate). The RC-1 for 32-bit Version 1.1 will be out in the near future, with a final release scheduled for early december. See this thread for more info:

http://porteus.org/forum/viewtopic.php?f=35&t=782
Please take a look at our online documentation, here. Suggestions are welcome!

Post Reply