[SOLVED] Asus EEEPC 1101 HaG and GMA500

Here you can post about your various experiences with PC hardware. You can also post about hardware that is not compatible with the linux kernel or not recommended for use with Porteus.
pdellu
White ninja
White ninja
Posts: 9
Joined: 26 Sep 2011, 07:51
Location: Roma, Italy

[SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#1 by pdellu » 26 Sep 2011, 08:01

Hi there, I know it's a known prob, but I think I'm missing something.
First of all, i've tested all the hardware except the bluetooth module and everything works fine, but the graphics are really poor.
Googling around i found there's a problem with the graphic accelerator (Intel GMA 500 aka Poulsbo) but to make it short at the present moment i'm able just to run a 1024x768 vesa mode which is really slow. Native resolution is 1366x768, but even tring with xrandr and cvt i'm not able to use native resolution (just a side note, puppylinux works in native res, but i've not yet compared configurations); I've red tons of similar pages,the only thing i know for sure is that this is a not fully supported hardware.
I heard something about psb_gfx kernel driver in 2.6.39 , but in the meantime is there anyone who can help me to get native resolution and an acceptable driver ??
Thanks
Paolo
Last edited by pdellu on 04 Oct 2011, 21:35, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Asus EEEPC 1101 HaG and GMA500

Post#2 by fanthom » 26 Sep 2011, 09:14

Welcome on board pdellu,

I'm sorry but i have no clue what needs to be done for getting poulsbo GPU to work in Porteus. First rc (release candidate) of upcoming Portus-1.1will be ready in about 3 weeks (with 3.1 kernel) so may be worth coming back and trying it.

As for now i would suggest you giving a shot to distros made by our friends: Quax and Mithrandill
http://fluxflux.net/?page_id=226
http://www.pixielive.org/dotclear/
as these are specialized in netbooks and i'm pretty sure that GMA500 is well supported over there.

Cheers
Please add [Solved] to your thread title if the solution was found.

pdellu
White ninja
White ninja
Posts: 9
Joined: 26 Sep 2011, 07:51
Location: Roma, Italy

Re: Asus EEEPC 1101 HaG and GMA500

Post#3 by pdellu » 27 Sep 2011, 13:48

Thx for the links, but i do think your build is better, and waiting new 1.1 is worth;
just one more question, i've seen in the developement area you've made for testing kernel for x86_64 , do you plan releasing 1.1 for 32 bit also or do i have to try to build the new kernel i need for gpu driver by my own ??

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Asus EEEPC 1101 HaG and GMA500

Post#4 by fanthom » 27 Sep 2011, 20:54

@pdellu
i'm mainly a 64bit maintainer while brokenman is doing 32bits. i know that brokenman is currently very busy with his real life so i may give him a hand with 32bits if necessary.
i should be able to release first rc of 32bits Porteus-1.1 in 2 or maybe 3 weeks after 64bit edition.

if you dont want to wait then you can compile a custom kernel yourself as per HOWTO which i posted on the main site.

Cheers
Please add [Solved] to your thread title if the solution was found.

pdellu
White ninja
White ninja
Posts: 9
Joined: 26 Sep 2011, 07:51
Location: Roma, Italy

Re: Asus EEEPC 1101 HaG and GMA500

Post#5 by pdellu » 04 Oct 2011, 21:34

Ok just a little update for anyone interested. After deep investigation I know that up from 2.6.39 kernel in staging modules there's a new psb_gfx module for GMA500 aka poulsbo Intel GPU; this module is a little bit rudimental but in constant developement and has been written by ----open your ears------ Alan Cox.
I managed , after several unsuccessful tries, it to work with kernel 3.0.3 compiled for Porteus 1.0 i486 arch and now i have native resolution 1366x768 with sensibly better performances on the graphics
In order to work there's a little tweaks needed, basically you have to boot in text mode disable the original old poulsbo module (modprobe -r poulsbo) and reload psb_gfx module (modprobe -r psb_gfx ; modprobe psb_gfx) ; this will make start a framebuffer console with correct native resolution. In order to make it work the X server you need to manually compile for porteus the xf86-video-fbdev (it has been removed from slackware builds in 13.x releases) driver from freedesktop.org and activate it, after activation xconf will correctly detect fbdev as driver and everything is fine.
I made new modules 000-kernel.xzm with 3.0.3 compiled with oldconfig defaults plus psb_gfx staging and some new module for ath9k wireless atheros card, xf86-video-fbdev.xzm; if anyone is interested i can upload them somewhere with new needed vmlinuz and initrd.xz to put in boot partition.

A note for fanthom and other developers:
- I was not able to patch aufs3 with kernel 3.0.4 cause some junks fail
- In order to quickly support hardware like mine (googling around we are many) IMHO kernel should be built without buggy standard poulsbo graphic driver but with staging new psb_gfx driver and fbdev modules should be recompiled and included in graphic modules
- You made a wonderful work
Slack rules

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#6 by fanthom » 05 Oct 2011, 06:31

nice stuff pdellu!

i'm happy that you did not give up with this task and provided valuable guide for other "happy" poulsbo owners :)
pls upload your custom kernel + fbdev DDX driver for me and other users.
i will disable original poulsbo kernel module in favor of psb_gfx - no worries about aufs3.

fbdev is generic driver and provides no hw 2D/3D acceleration so please let me know in case of finding better replacement which fits GMA500/600 GPU's. i wish to try some experiments myself but unfortunately i do not posses this type of hardware.

Thanks
Please add [Solved] to your thread title if the solution was found.

pdellu
White ninja
White ninja
Posts: 9
Joined: 26 Sep 2011, 07:51
Location: Roma, Italy

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#7 by pdellu » 05 Oct 2011, 13:46

Ok, the needed files are hosted at http://code.google.com/p/porteus-addons/ ; as soon as i have a little more time i'll post there a small wiki.
I'll drop a note about it even in x86 modules forum
Cya
Paolo

User avatar
justwantin
Black ninja
Black ninja
Posts: 51
Joined: 09 Oct 2011, 19:10
Location: Melbourne, Oz

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#8 by justwantin » 09 Oct 2011, 20:07

G'day

I'm running Porteus on a aspire 751h, nice work! I hadn't heard about Porteus until last night when I was looking for something that might work with the poulsbo videoI have on board on board. I had been using Salix but cannot really tell if display is any better but the kde background looks good.

I can play you tube videos now. Audio stream is OK but I'm not sure about the video. I tried an mpg2 video that works ok on my Salix desktop but it's useless on the acer now running Porteus. Before I try to set up the new kernel at http://code.google.com/p/porteus-addons/ may I ask if I can exoect inproved video once I have it set up?

pdellu
White ninja
White ninja
Posts: 9
Joined: 26 Sep 2011, 07:51
Location: Roma, Italy

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#9 by pdellu » 10 Oct 2011, 09:18

justwantin wrote:G'day
....
I can play you tube videos now. Audio stream is OK but I'm not sure about the video. I tried an mpg2 video that works ok on my Salix desktop but it's useless on the acer now running Porteus. Before I try to set up the new kernel at http://code.google.com/p/porteus-addons/ may I ask if I can exoect inproved video once I have it set up?
The new driver is at an early stage of develop, and it's not sure it will work on any desktop, that's what the developers say; this just to rememer you have to make backups in order to be able to revert to previous.
The new module work with a frame buffer device, which is nearly obsolete, but in my case it was anyway better than before, and so should be in your.
Improvements in my case are mainly the following :
1 - Native resolution (1366x768)
2 - Video playback from youtube movies, before was not fluid now it is
3 - Scrolling of web pages is sensibly improved
Let me know your experience.
P.S. Remember you need to work 4 files : kernel,initrd,vmlinuz,xf86-video-fbdev
PP.SS. New driver is a module, you can even if u don't feel comfortable keep the upgraded kernel and work with your previous driver, which is also a module
Cya
Paolo

guimenez
White ninja
White ninja
Posts: 20
Joined: 28 Oct 2011, 12:45
Location: Portugal

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#10 by guimenez » 28 Oct 2011, 12:48

Hi

i've 1101 Ha
I'm trying the new kernel and vga, but the vga only as 1024x778

and Wireless its not working :(

any help please?

many thanks

User avatar
fanthom
Site Admin
Site Admin
Posts: 4588
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#11 by fanthom » 29 Oct 2011, 09:58

@guimenez
welcome on board,

you can give a try to first release candidate of upcoming porteus-1.1(64bit verson):
http://ponce.cc/porteus/x86_64/testing/ ... -v1.1-rc1/
it should have everything ready for GMA driver as per pdellu instructions.

if you prefer 32bit version then rc1 is nearly ready so may be worth waiting few days.

please post output of 'lspci -k' command and we will find out how to get your wifi to work.

Cheers
Please add [Solved] to your thread title if the solution was found.

guimenez
White ninja
White ninja
Posts: 20
Joined: 28 Oct 2011, 12:45
Location: Portugal

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#12 by guimenez » 29 Oct 2011, 11:21

Thanks for replying.

When i run lspci, it says command not found :(

I can't run the 64 iso because my atom is 32 bits, and it says need an i686 kernel.

I'm doing something wrong?

and BIG THANKS for this GREAT PROJECT

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#13 by Hamza » 29 Oct 2011, 13:56

I have a question,

How could you run a 64bit OS on 32bit CPU ??
And, the supposed error is, You need to have x86_64 cpu to load the kernel.
NjVFQzY2Rg==

guimenez
White ninja
White ninja
Posts: 20
Joined: 28 Oct 2011, 12:45
Location: Portugal

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#14 by guimenez » 29 Oct 2011, 16:22

i don't know why i don't have lspci command.

without that, how can i seen my network card?

thanks

User avatar
Hamza
Warlord
Warlord
Posts: 1847
Joined: 28 Dec 2010, 07:41
Distribution: Porteus
Location: France

Re: [SOLVED] Asus EEEPC 1101 HaG and GMA500

Post#15 by Hamza » 29 Oct 2011, 16:28

Are you using the official Porteus Edition and not a variant ?
NjVFQzY2Rg==

Post Reply