Porteus 64 muted on Acer Aspire

Post here if you are a new Porteus member and you're looking for some help.
Post Reply
logick
White ninja
White ninja
Posts: 11
Joined: 18 Apr 2011, 08:38
Location: Poland

Porteus 64 muted on Acer Aspire

Post#1 by logick » 14 Sep 2011, 18:54

Hi All,

My new laptop (Acer Aspire one 722) booted from a pendrive
with the new Proteus64 played successfully his welcome tune but
failed to play any mp3, wav or ape-file with music (I tried
smplayer and qmmp which worked very well on my old laptop Toshiba).

Curiously, in a terminal, any command of the form:

mplayer music-file.mp3

(or flac, wav etc.) produced rather good sound.

I hope there is some way to make qmmp useful, as before and I will be
grateful for help. I enclose output of mplayer hoping that it can help
to understand the trouble.

Thanks in advance.

P.S. I also tried Proteus32 but without success - the only difference
was the message enclosed below:

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such file or directory)
The sound server will continue, using the null output device.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
output of mplayer commands
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

bash-4.1# mplayer La_Foule.mp3
MPlayer SVN-r32819-4.5.2 (C) 2000-2011 MPlayer Team

Playing La_Foule.mp3.
Audio only file format detected.
Clip info:
Title: La Foule
Artist: Mireille Mathieu
Album: Chante Piaf
Year: 1994
Comment:
Track: 2
Genre: Other
Load subtitles in ./
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: No such file or directory
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
AO: [sdl] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
bash-4.1# mplayer Stairway.wav
MPlayer SVN-r32819-4.5.2 (C) 2000-2011 MPlayer Team

Playing Stairway.wav.
Audio only file format detected.
Load subtitles in ./
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 1411.2 kbit/100.00% (ratio: 176400->176400)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: No such file or directory
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
AO: [sdl] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
bash-4.1# mplayer cd1.ape
MPlayer SVN-r32819-4.5.2 (C) 2000-2011 MPlayer Team

Playing cd1.ape.
libavformat file format detected.
[lavf] stream 0: audio (ape), -aid 0
Load subtitles in ./
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->176400)
Selected audio codec: [ffape] afm: ffmpeg (FFmpeg Monkey's Audio)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: No such file or directory
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO_ALSA] alsa-lib: pcm_hw.c:1293:(snd_pcm_hw_open) open '/dev/snd/pcmC0D0p' failed (-2): No such file or directory
[AO_ALSA] alsa-lib: pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
AO: [sdl] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
Last edited by logick on 15 Sep 2011, 19:33, edited 1 time in total.

User avatar
fanthom
Site Admin
Site Admin
Posts: 4547
Joined: 28 Dec 2010, 02:42
Distribution: Porteus Kiosk
Location: Poland, currently - Cork, IE
Contact:

Re: Porteus 64 muted on Acer Aspire

Post#2 by fanthom » 14 Sep 2011, 19:54

hello logick,

please shrink your initial post and export psinfo log on pastebin.com - it will be easier to read it for other people :wink:
i believe that solution for your problem lies in this thread:
http://porteus.org/forum/viewtopic.php?f=46&t=748

please let us know if that helped to you.

btw:
sci_fi had a problem with getting microphone to work and seems that this issue is still unresolved:
viewtopic.php?f=46&t=749&sid=a353127f97 ... 7082c35f39
if you want to dig into it then i would recommend using new (testing) kernel from here:
http://ponce.cc/porteus/x86_64/testing/ ... 64.tar.bz2

Cheers
Please add [Solved] to your thread title if the solution was found.

logick
White ninja
White ninja
Posts: 11
Joined: 18 Apr 2011, 08:38
Location: Poland

Re: Porteus 64 muted on Acer Aspire

Post#3 by logick » 15 Sep 2011, 19:17

@fanthom

After adding the file .asoundrc from the post of sci_fi all problems with qmmp and smplayer vanished.
I did not check the microphone yet - I use it rather seldom. Thanks again for your precious help.

Best regards.

P.S. I will do my best to shrink my previous post but - to be honest - it will be my first encounter with pastebin.com

User avatar
francois
Contributor
Contributor
Posts: 4902
Joined: 28 Dec 2010, 14:25
Distribution: kde xfce porteus manjaro kubun
Location: Enfin l'été, le changement climatique attendu: le soleil.

Re: Porteus 64 muted on Acer Aspire

Post#4 by francois » 16 Sep 2011, 12:56

Pastebon is really easy. You can take my word on it.
Voltaire: Le mieux est l'ennemi du bien.

Post Reply